Problems detecting 7 images  

Partagez vos trucs et astuces dans ce forum ou obtenez de l'aide sur l'utilisation d'Autopano Pro / Giga.
Attention, pas de post sur les bugs ici ...
no avatar
clairew90
New member
 
Topic author
Posts: 9
Likes: 0 post
Liked in: 0 post
Joined: Wed Aug 19, 2015 11:30 am
Info

Problems detecting 7 images

by clairew90 » Fri Sep 04, 2015 5:37 pm

Hello,

I wrote in before because I had issues detecting 7 images to make a panorama. I have tried clicking 'force 7 images...' and I have tried playing with the control point editor. However none of these has been successful. I have attached a set of 'problem' images. Please can you have a look and let me know if there is anything we can do. We have hundreds of these groups that will not detect the 7. I need a quick way to fix it for them all.

Thanks for any help!
Attachments
Camera_6 (909).jpg
Camera_5 (904).jpg
Camera_4 (909).jpg
Camera_3 (908).jpg
Camera_2 (909).jpg
Camera_1 (909).jpg

no avatar
mediavets
Moderator
 
Posts: 16415
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

Re: Problems detecting 7 images

by mediavets » Fri Sep 04, 2015 5:40 pm

What camera, lens and panohead were used to shoot these images?

no avatar
clairew90
New member
 
Topic author
Posts: 9
Likes: 0 post
Liked in: 0 post
Joined: Wed Aug 19, 2015 11:30 am
Info

Re: Problems detecting 7 images

by clairew90 » Mon Sep 07, 2015 9:38 am

Go Pro Hero 3+ fisheye lens. 7 cameras in a spherical mount.

no avatar
Panoram1x
Member
 
Posts: 236
Likes: 1 post
Liked in: 41 posts
Joined: Sun Jun 06, 2010 9:59 pm
Location: Barcelona (Catalunya)
Info

Re: Problems detecting 7 images

by Panoram1x » Mon Sep 07, 2015 11:56 am

You have used seven cameras ... but here are only six images!

no avatar
clairew90
New member
 
Topic author
Posts: 9
Likes: 0 post
Liked in: 0 post
Joined: Wed Aug 19, 2015 11:30 am
Info

Re: Problems detecting 7 images

by clairew90 » Mon Sep 07, 2015 1:49 pm

6 is the maximum attachment - I have attached the 7th photo below to this reply. Thanks for pointing out!
Attachments
Camera_7 (908).jpg

no avatar
Panoram1x
Member
 
Posts: 236
Likes: 1 post
Liked in: 41 posts
Joined: Sun Jun 06, 2010 9:59 pm
Location: Barcelona (Catalunya)
Info

Re: Problems detecting 7 images

by Panoram1x » Mon Sep 07, 2015 2:30 pm

Once you have created the group in Autopano and before launching the detection You should adjust the focal, I tested with 18 mm, and set the type of lens as fisheye.

Thus has worked well at the first attempt.
fish_1.jpg


Vert_1Lin.jpg

This second image is the result after vertical tool and a little bit of yaw correction

If you need any further clarification ... you already know, ask!
Experimentation is the funniest way to learn, to ask the fastest
jordi.panoram1x[at]gmail[dot]com

no avatar
Panoram1x
Member
 
Posts: 236
Likes: 1 post
Liked in: 41 posts
Joined: Sun Jun 06, 2010 9:59 pm
Location: Barcelona (Catalunya)
Info

Re: Problems detecting 7 images

by Panoram1x » Mon Sep 07, 2015 3:01 pm

Oops! I forgot a detail.
If you have many sets of images with this issue you can use the general settings of Autopano and adjust these default settings and avoid having to adjust to each group.

Sett_1.jpg
Experimentation is the funniest way to learn, to ask the fastest
jordi.panoram1x[at]gmail[dot]com

no avatar
clairew90
New member
 
Topic author
Posts: 9
Likes: 0 post
Liked in: 0 post
Joined: Wed Aug 19, 2015 11:30 am
Info

Re: Problems detecting 7 images

by clairew90 » Mon Sep 07, 2015 3:29 pm

Thank you for your help! I tried what you suggested and had success with that panorama. It also worked on some others. I am still having issues however. For one of the issue ones I have attached 6 images in this reply and the final one in the next reply so you can see - I have played with the focal lengths with no improvement.
Attachments
Camera_6 (906).jpg
Camera_5 (901).jpg
Camera_4 (906).jpg
Camera_3 (905).jpg
Camera_2 (906).jpg
Camera_1 (906).jpg

no avatar
clairew90
New member
 
Topic author
Posts: 9
Likes: 0 post
Liked in: 0 post
Joined: Wed Aug 19, 2015 11:30 am
Info

Re: Problems detecting 7 images

by clairew90 » Mon Sep 07, 2015 3:30 pm

Final image
Attachments
Camera_7 (905).jpg

no avatar
Panoram1x
Member
 
Posts: 236
Likes: 1 post
Liked in: 41 posts
Joined: Sun Jun 06, 2010 9:59 pm
Location: Barcelona (Catalunya)
Info

Re: Problems detecting 7 images

by Panoram1x » Mon Sep 07, 2015 5:04 pm

I think we have at least three reasons why it is difficult to assemble the images.
Parallax: An inherent problem of multiple cameras mounts (obviously it is impossible for the seven are at the same point)
The variations in brightness and WB that make it difficult to detect the control points (but AFAIK GoPro don't have a manual mode)
Repetitive patterns in the pictures ( In an artificial tunnel, what else can expect!)
And I think that have no solution, you will have to "work helping APG."
In which way?
As I have done to solve this second consultation. Manually adding the missing links.

In this picture you can see a hole that suggest the position of the image without links and which are its neighbors for find links with them.
Hole_2.jpg

CP_2.jpg

I turned the original images before starting to work with them so that "up" is "up" in the picture, so when I look at where must be the control points my sense of spatial orientation may help me.
With this result (before corrections)
Res_2.jpg

You can also try (I have not yet done) set the quality of detection to high and / or filtering mode to spherical filter.
Sett_2.jpg

...
Tell me if this works in the right direction


Who is online

Users browsing this forum: No registered users and 1 guest