Guys any bug related with sound and VR?  

Share your tips and tricks here or get help with any Panotour 2.0+ problem!
No bug reports (of any kind) in this forum!
no avatar
bernardcustard
Member
 
Topic author
Posts: 108
Likes: 12 posts
Liked in: 1 post
Joined: Thu Sep 22, 2011 10:19 pm
Location: Valencia, Spain
Info

Guys any bug related with sound and VR?

by bernardcustard » Fri Apr 07, 2017 6:54 am

I just finished a tour with sound and many other options but my big surprise it´s that it goes perfect in PC but when it comes to tablet or mobile it does not work properly. With tab and mobile the first voice over does not goes automatically i don´t now why because it says that its true.

With the VR option it does not work the audio inside any panorama. I just check everything but it seems it´s ok. Any idea?

Mobile Android S7 samsung or tab S2 samsung. version browser SAFARI Version 10.0.3 Version of PANOTOUR PRO 2.5.5.

This it´s a little bit of code in the Vr section.

filename_corevr.xml

<krpano>
<!-- Global variables used by actions and plugins -->
<krpano
tour_soundson="true"
tour_soundsvolume="100"
tour_autotourenabled="false"
tour_autorotateenabled="false"
tour_controlmodemousetype="drag"
tour_controlmodetouchtype="drag"
tour_fullscreen="false"
tour_displaymap="false"
tour_displaythumbnails="true"
tour_displayfloorplan="false"
tour_displayinfo="false"
tour_displayspots="true"
tour_displaycontrols="true"
tour_language="en" />
<krpano tour_gyroscopedevices="true" devices="no-desktop.and.html5" />
<krpano tour_vrdevices="true" devices="html5" />
<krpano videos_sounds_path="%FIRSTXML%" devices="html5" />
<krpano videos_sounds_path="%SWFPATH%" devices="flash" />
<krpano projection_current_params="view.fisheyefovlink=0.5&amp;view.architectural=0.0&amp;view.pannini=0.0&amp;view.fisheye=0.0&amp;view.stereographic=false" />


<krpano vrtourdevice.desktop="desktop" vrtourdevice.tablet="tablet" vrtourdevice.mobile="mobile" />
<krpano vrtourdevicescale.desktop="1.0" vrtourdevicescale.tablet="1.0" vrtourdevicescale.mobile="2.0" />
<action name="vrtourcurrentscale" autorun="preinit">
mul(stagescale,get(vrtourdevicescale));
</action>

User avatar
Annis
Kolor Team
 
Posts: 6062
Likes: 801 posts
Liked in: 444 posts
Joined: Mon Aug 12, 2013 12:47 pm
Location: France
Info

Re: Guys any bug related with sound and VR?

by Annis » Fri Apr 07, 2017 8:53 am

Do you have several sound files meant to play at the same time?
What browser are you using on the Samsung phones?

Sound can't start automatically on mobile, it requires a physical user touch of the screen. See general mobile limitations.

no avatar
bernardcustard
Member
 
Topic author
Posts: 108
Likes: 12 posts
Liked in: 1 post
Joined: Thu Sep 22, 2011 10:19 pm
Location: Valencia, Spain
Info

Re: Guys any bug related with sound and VR?

by bernardcustard » Fri Apr 07, 2017 11:34 am

No i don´t have any sounds at the same time. No, just chrome browser.

User avatar
Annis
Kolor Team
 
Posts: 6062
Likes: 801 posts
Liked in: 444 posts
Joined: Mon Aug 12, 2013 12:47 pm
Location: France
Info

Re: Guys any bug related with sound and VR?

by Annis » Fri Apr 07, 2017 12:04 pm

Does the sound start if you pause then enable it from a button or control bar?
If so then it's a Chrome issue, also brought up here viewtopic.php?f=92&t=35299&p=196555#p196555 and here on the KrPano forum https://krpano.com/forum/wbb/index.php? ... adID=15019

Edit: Hadn't seen your PM, I'll check out the link.

Edit 2: Confirmed, I have the issue on the latest version of Chrome on Android (57) but not on an earlier version. It's related to the links I posted above.

no avatar
bernardcustard
Member
 
Topic author
Posts: 108
Likes: 12 posts
Liked in: 1 post
Joined: Thu Sep 22, 2011 10:19 pm
Location: Valencia, Spain
Info

Re: Guys any bug related with sound and VR?

by bernardcustard » Fri Apr 07, 2017 2:46 pm

:( :( i would try to see your thing. I don´t know why in the hell they touch all the things and then they don´t work :S:S. That´s what i thought that might be a weird thing. Thanks so much Annis. I would let you know how i manage the issue.

no avatar
bernardcustard
Member
 
Topic author
Posts: 108
Likes: 12 posts
Liked in: 1 post
Joined: Thu Sep 22, 2011 10:19 pm
Location: Valencia, Spain
Info

Re: Guys any bug related with sound and VR?

by bernardcustard » Mon Apr 10, 2017 6:29 pm

Hi guys. Two things that could save this issue. One it´s downgrade the chrome version if your customer wants that version VR with audio and the other one it´s download https://play.google.com/store/apps/deta ... rora&hl=es from playstore. It works better than the standalone firefox in Android that it´s not working the gyro option. At least something it´s nothing.

no avatar
bernardcustard
Member
 
Topic author
Posts: 108
Likes: 12 posts
Liked in: 1 post
Joined: Thu Sep 22, 2011 10:19 pm
Location: Valencia, Spain
Info

Re: Guys any bug related with sound and VR?

by bernardcustard » Tue May 02, 2017 10:36 am

Is there any sort of solution with the audio and WEBVR yet? We still have the same version of chrome. Are there any solutions that we can hack or do we need to wait for Chrome mobile update?

User avatar
Annis
Kolor Team
 
Posts: 6062
Likes: 801 posts
Liked in: 444 posts
Joined: Mon Aug 12, 2013 12:47 pm
Location: France
Info

Re: Guys any bug related with sound and VR?

by Annis » Tue May 02, 2017 1:34 pm

No hack or workaround as far as I know, can only wait on a Chrome update.

no avatar
bernardcustard
Member
 
Topic author
Posts: 108
Likes: 12 posts
Liked in: 1 post
Joined: Thu Sep 22, 2011 10:19 pm
Location: Valencia, Spain
Info

Re: Guys any bug related with sound and VR?

by bernardcustard » Tue May 02, 2017 2:16 pm

:(:( So sad. We always depend of them grrr. It´s so weird watching content in Vr with no audio. Thanks @annis for your quick answer.


Who is online

Users browsing this forum: No registered users and 4 guests

cron