Page 1 of 1

APG masks not working in APV

PostPosted: Wed Sep 05, 2018 4:23 am
by warikl
Hi
I am using APV to stitch together some fisheye footage. I have been creating masks in APG which look fine in the test renders. However the masks are completely ignored in APV.
I have followed all of the advice on the Autopano Video Solutions page including:
- Setting the blend settings in APG to multiband, level -2, cutting ISO, no Weighting
- Setting the blend settings in APV to sharp
- Putting all of the files in the same folder on a local drive.

The one thing I have not done is to have the Stitching Tab selected in the Timeline. Whenever I select the Stitching Tab, the orientation switches from Fisheye 1:1 to Spherical 2:1. This then refuses to allow me to render the frame as a fisheye image. Why does the orientation change whenever I switch from the Authoring Tab to the Stitching Tab. Is there a way to lock the orientation to stop this from happening?
Here is a frame using APV. Notice that the back of the actress is being blended in with the couch.
AVP stitch closeup2.jpg


Here is a test frame that I rendered using APG. Note, the back of the actress is solid.
APG stitch closeup2.jpg
APG test stitch. Back of the actress is solid.

I am currently using APV 3.0.0 and APG 4.4.1, Windows 64, GTX1070 Nvidia Card.
Footage was shot on a red Monstro camera using a 15mm lens. Footage is imported into APV as Prores .mov files.

Any help or suggestions would be appreciated.

Thanks
Warik

Re: APG masks not working in APV

PostPosted: Thu Sep 06, 2018 6:24 am
by warikl
After a lot of trial and error, I think this is a limitation of working in the fisheye format. I am now outputting my footage in AVP in the Spherical (Equirectangular) format. This means the masks that I set up in APG are working correctly. I then have to take the footage into After Effect and use the VR convertor effect to convert the footage into the fisheye format.

So, not exactly a solution. But it is a good work around.

Re: APG masks not working in APV

PostPosted: Thu Sep 06, 2018 12:26 pm
by SoenkeW
Did you select "fisheye" in the "Realtime Preview" window in AVP?

And did you click "Apply"? Applying the adjustments is very vital in AVP to have the settings take effect.

Best regards!

Re: APG masks not working in APV

PostPosted: Thu Sep 06, 2018 12:31 pm
by SoenkeW
By the way... I am always using AFX to convert into Fulldome/Fisheye format. This way you have better control over the orientation values and better ways to animate orientations. And even for stabilization purposes it is better to work with 2:1 format.

Re: APG masks not working in APV

PostPosted: Fri Sep 07, 2018 2:34 am
by warikl
Hi
Thanks for your suggestions. I do select Fisheye in the Realtime Preview window and click on Apply. However it still seems to default back to 2:1 whenever I select the Stitching tab in the Timeline. (It then goes back to the fisheye view when I select the Authoring Tab).

I agree that working in the 2:1 format is a much better workflow. I find it also easier to fix stitching errors (that I just can't seem to fix in APG) in After Effects while the sequence is still in the 2:1 format.