little planet effect and iphone devices  

Share your tips and tricks here or get help with any Panotour problem!
No bug reports (of any kind) in this forum!
no avatar
argiro.starida
Member
 
Topic author
Posts: 10
Likes: 0 post
Liked in: 0 post
Joined: Sat May 12, 2012 6:54 pm
Info

little planet effect and iphone devices

by argiro.starida » Sat Sep 29, 2012 6:40 pm

Hello!
I have used the little planet effect. It looks great on internet but it looks weird on iphone/ipad devices. I know it is not possible to see it on these devices because it's a flash thing but does anyone know if and HOW can I make it not play the little planet effect when seen by iphone/ipad? When it detects iphone/ipad devices to start the panorama without the effect.
thanx in advance
Argiro

User avatar
Sam Rohn
Member
 
Posts: 41
Likes: 1 post
Liked in: 0 post
Joined: Fri Mar 11, 2011 2:36 am
Location: Brooklyn, New York
Info

by Sam Rohn » Sun Sep 30, 2012 10:49 am

yes, using the planet intro results in starting the tour looking at the floor on html5 devices as planets do not work on non-flash, disabling planet intro for html5 should prob be default behavior

to fix it, you need to set different starting view per device type via the krpano device attribute

http://krpano.com/docu/xml/#devices-notes

this is from a krpano project, but similar code should work for ptp

Code: Select all
<!-- HTML 5 intro - no planet -->       
<view     
devices="html5"
hlookat="0"
vlookat="0"
maxpixelzoom="1.0"
fovmax="110"
/>
   
<!-- little planet intro - flash only -->
<view         
devices="flash"
stereographic="true"
fisheye="1.0"
fov="155"
fovtype="VFOV"
fovmax="150"
hlookat="0"
vlookat="90"
/>

<!-- ETC -->

just add the device attribute as show to the appropriate xml elements as needed

sam
Last edited by Sam Rohn on Sun Sep 30, 2012 11:15 am, edited 1 time in total.
Sam Rohn :: 360° Panoramic Photography :: www.samrohn.com :: Location Scout :: www.nylocations.com :: New York City
PanoPress :: WordPress Plugin for 360° Panoramas in Flash & HTML5 :: www.panopress.org

no avatar
argiro.starida
Member
 
Topic author
Posts: 10
Likes: 0 post
Liked in: 0 post
Joined: Sat May 12, 2012 6:54 pm
Info

by argiro.starida » Mon Oct 01, 2012 3:01 pm

Thank you very much for you reply and the code!!!:)
I'll try it and let you know what happened.
Argiro

no avatar
argiro.starida
Member
 
Topic author
Posts: 10
Likes: 0 post
Liked in: 0 post
Joined: Sat May 12, 2012 6:54 pm
Info

by argiro.starida » Tue Oct 02, 2012 9:05 am

Hello Sam,

I've tried the code but unfortunately nothing happened. I'm quite new to all these. Do I have to put the code somewhere specifically in the xml? Or do I have to replace some of the code with the new one?

Thank you again for your help
Argiro

User avatar
Sam Rohn
Member
 
Posts: 41
Likes: 1 post
Liked in: 0 post
Joined: Fri Mar 11, 2011 2:36 am
Location: Brooklyn, New York
Info

by Sam Rohn » Wed Oct 03, 2012 5:52 am

sorry, this was not meant as a cut and paste solution, you would probably need to be a bit familiar w modifying krpano code to figure out exactly what needs to be changed, panotour little planet intro code is laid out bit differently then the way i have been doing things in single pano krpano projects...

but the device tag and alt starting view for html5 is the way to fix it, perhaps someone more familiar w modifying ptp than myself could come up with a working fix, disabling planet intro on html5 should be built into ptp templates so maybe if you report this as a bug they can get it fixed in next release

sam
Last edited by Sam Rohn on Wed Oct 03, 2012 5:55 am, edited 1 time in total.
Sam Rohn :: 360° Panoramic Photography :: www.samrohn.com :: Location Scout :: www.nylocations.com :: New York City
PanoPress :: WordPress Plugin for 360° Panoramas in Flash & HTML5 :: www.panopress.org

no avatar
argiro.starida
Member
 
Topic author
Posts: 10
Likes: 0 post
Liked in: 0 post
Joined: Sat May 12, 2012 6:54 pm
Info

by argiro.starida » Wed Oct 03, 2012 8:08 am

yes the copy paste didn't work but I tried several things and finally I made it work. Thank you very much for your help and the great starting point to the solution :)
Argiro

User avatar
ATXcloud
Member
 
Posts: 137
Likes: 0 post
Liked in: 0 post
Joined: Mon Jun 06, 2011 6:06 am
Location: AUSTIN, TX USA
Info

by ATXcloud » Wed Oct 03, 2012 5:48 pm

Argiro, mInd sharing what you did to solve it? Thank you
Howdy from Deep in the Heart of Texas!


Who is online

Users browsing this forum: No registered users and 2 guests

cron