Weird Firefox 59.0.1 Mac Problem  

This forum is fully dedicated to Panotour / Panotour Pro bug reports as well as feature discussion.
no avatar
ZITRONENWOLF
Member
 
Topic author
Posts: 113
Likes: 1 post
Liked in: 5 posts
Joined: Sun Mar 31, 2013 2:13 pm
Location: Stuttgart, Germany
Info

Weird Firefox 59.0.1 Mac Problem

by ZITRONENWOLF » Tue Mar 20, 2018 10:28 am

Hi,

did anyone have a problem similar to this one:
on one Mac (OSX 10.9.5) with Firefox 59.0.1 the tours made with PTP higher than 2.5 don't work. All elements are there but not the panorama. There is no error message. The panorama just stays white.
On the same computer and Firefox 58 it works.
On another Mac with same OSX and Firefox 59.0.1 it also works.

I'm confused.

Best, ZITRONENWOLF

User avatar
bdd
Kolor Team
 
Posts: 2802
Likes: 14 posts
Liked in: 129 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

Re: Weird Firefox 59.0.1 Mac Problem

by bdd » Tue Mar 20, 2018 1:04 pm

Another user faced the same issue.
Here is the thread about the issue (in french) : viewtopic.php?f=94&t=39195

We did not find yet what leads to this issue.

Can you try your tours with the following option at the end of the URL ?
?html5=only+webgl

gérald

no avatar
ZITRONENWOLF
Member
 
Topic author
Posts: 113
Likes: 1 post
Liked in: 5 posts
Joined: Sun Mar 31, 2013 2:13 pm
Location: Stuttgart, Germany
Info

Re: Weird Firefox 59.0.1 Mac Problem

by ZITRONENWOLF » Tue Mar 20, 2018 1:39 pm

The end ?html5=only+webgl doesn't help...

User avatar
bdd
Kolor Team
 
Posts: 2802
Likes: 14 posts
Liked in: 129 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

Re: Weird Firefox 59.0.1 Mac Problem

by bdd » Tue Mar 20, 2018 3:27 pm

The issue seems to come from a bad handling by Firefox of old MacOS versions.
Can you try the CSS version of the tour instead of the WebGL one ?

Add ?html5=only+css3d at the end of the URL of your tour .

Gérald

no avatar
ZITRONENWOLF
Member
 
Topic author
Posts: 113
Likes: 1 post
Liked in: 5 posts
Joined: Sun Mar 31, 2013 2:13 pm
Location: Stuttgart, Germany
Info

Re: Weird Firefox 59.0.1 Mac Problem

by ZITRONENWOLF » Tue Mar 20, 2018 4:07 pm

That works!
Does this have negative side-effects? Or could I change all my tour-addresses to this?

no avatar
benji33
Kolor Team
 
Posts: 5848
Likes: 92 posts
Liked in: 199 posts
Joined: Tue Apr 09, 2013 10:59 am
Location: France
Info

Re: Weird Firefox 59.0.1 Mac Problem

by benji33 » Wed Mar 21, 2018 5:18 pm

Of course, the css3d support is poor on many browsers and mobile devices browsers.

The better way is to create a rule into the JavaScript code present into the HTML file to do that only when Firefox with an old macOS is recognized. Or only for Firefox for instance.
Benjamin

no avatar
ZITRONENWOLF
Member
 
Topic author
Posts: 113
Likes: 1 post
Liked in: 5 posts
Joined: Sun Mar 31, 2013 2:13 pm
Location: Stuttgart, Germany
Info

Re: Weird Firefox 59.0.1 Mac Problem

by ZITRONENWOLF » Thu Sep 13, 2018 5:20 pm

Maybe it is interesting for anybody:
I solved the problem in deactivating one Firefox-Plugin (a youtube-video-grabber).
The weird thing comes now: I upgraded my two computers to OSX 10.10. Both Firefoxes on the computers were identical (version 62 and all settings and plugins the same). On my mobile computer no problem. On the desktop again the problem that the panorama was not shown. Deactivating the plugins had no effect. Changing to fullscreen-mode had an effect: it worked. Again the ending html5=only+css3d worked. Every other browser worked too.
Really strange what this Firefox makes...

benji33 likes this post.


Who is online

Users browsing this forum: No registered users and 2 guests