Really weird problem  

Share your tips and tricks here or get help with any Panotour problem!
No bug reports (of any kind) in this forum!
no avatar
Nelike Imagery
Member
 
Topic author
Posts: 110
Likes: 0 post
Liked in: 0 post
Joined: Tue Apr 13, 2010 3:12 pm
Info

Really weird problem

by Nelike Imagery » Wed Sep 21, 2011 9:20 am

Hi,

im facing a really, really weird problem with my project which is under development. Im facing an issue where the tour can be seen only with IE and Chrome but not with Mozilla, Opera or Safari. Those browsers cannot load the picture files and they are show as forbidden. Bluehost tried to change the file permissions but didn't solve the problem. Now i want to know if anyone has faced the same situation or anyone is able to help me with this?

Here is the link to the tour and see the problem yourself:
http://imaginefinland.fi/vt/ita-suomi/etela-savo/mikkeli/mikkelinkadut.html

This project is important one for us and any help is appreciated. Thank you for replies already.

Regards,
Jesse Passoja
Nelike Imagery
www.inelike.fi
Latest panoramas: http://inelike.fi/aiheeton/latest-panoramas/

User avatar
bdd
Kolor Team
 
Posts: 2802
Likes: 14 posts
Liked in: 130 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

by bdd » Wed Sep 21, 2011 9:44 am

Hi,

Maybe a problem linked with the ".htaccess" file.

If you try to access a tile without specifying the protocol on CHrome : you get the tile
imaginefinland.fi/vt/ita-suomi/etela-savo/mikkeli/mikkelinkadutdata/mikkelinkadut24/1/2/0_2.jpg

If you try to force the http protocol, you don't get the tile : Forbidden error
http://imaginefinland.fi/vt/ita-suomi/etela-savo/mikkeli/mikkelinkadutdata/mikkelinkadut24/1/2/0_2.jpg

Gérald

no avatar
Nelike Imagery
Member
 
Topic author
Posts: 110
Likes: 0 post
Liked in: 0 post
Joined: Tue Apr 13, 2010 3:12 pm
Info

by Nelike Imagery » Wed Sep 21, 2011 9:48 am

Hi Gérald,

im not sure what i should do with the .htaccess file because it's generated by wordpress which is running in the server. I opened it and it has this info inside:

RewriteEngine on

# BEGIN WordPress

# END WordPress

RewriteCond %{HTTP_REFERER} !^http://imaginefinland.fi/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://imaginefinland.fi$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.imaginefinland.fi/.*$ [NC]
RewriteCond %{HTTP_REFERER} !^http://www.imaginefinland.fi$ [NC]
RewriteRule .*\.(jpg|jpeg|gif|png|bmp)$ - [F,NC]

Anything wrong there?

Regards,

Jesse

no avatar
Nelike Imagery
Member
 
Topic author
Posts: 110
Likes: 0 post
Liked in: 0 post
Joined: Tue Apr 13, 2010 3:12 pm
Info

by Nelike Imagery » Thu Sep 22, 2011 1:02 pm

Problem solved. Last line in the .htaccess file was denying access to the pictures. Now it's working perfectly :)

Regards,

Jesse


Who is online

Users browsing this forum: No registered users and 0 guests