AP 2.5 RC2 issue with glibc 2.10  

Archive of all bug reports. This forum is closed - you cannot create new topics or comments here! If you think a specific topic was moved here by mistake, please contact the moderators!
no avatar
atuor
Member
 
Posts: 36
Joined: Sat Sep 12, 2009 12:50 pm
Location: Vaud, Suisse

AP 2.5 RC2 issue with glibc 2.10

by atuor » Sat Jan 22, 2011 10:43 pm

Hello,
Just tried the last RC2 (tried B2 before, which worked) on OpenSuse 11.2, and it says now I need glibc 2.11

/lib/libc.so.6: version `GLIBC_2.11' not found (required by /home/alain/bin/AutopanoPro25RC2/libQtGui.so.4

Is this normal that ver. requirements changed ? I found no simple way to update glibc for my distro :-/ If someone has a goog idea ... ;-)
Olympus OMD-E5 - Kalahari pano head - OpenSuse OS

User avatar
AlexandreJ
Kolor Team
 
Posts: 5918
Joined: Mon Nov 14, 2005 4:56 pm
Location: Francin, France

by AlexandreJ » Mon Jan 24, 2011 4:28 pm

I don't have the answer. I've opened an issue on that : issue 545 opened

User avatar
ygilquin
Kolor Team
 
Posts: 200
Joined: Wed Sep 29, 2010 9:00 am
Location: Francin

by ygilquin » Fri Jan 28, 2011 3:04 pm

This is a regression in RC2 and will be fixed in next release.
--
Yann G.
www.kolor.com

User avatar
fma38
Member
 
Posts: 5827
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France

by fma38 » Fri Jan 28, 2011 5:45 pm

I don't know if it is the same issue, but I remember I was unable to start APG under debian stable, because of glibc.

Could it be possible to check that the final release will work with debian stable? Maybe not with the current one (lenny), which is pretty old, but with the next (which should be released soon)?
Frédéric

Canon 20D + 17-40/f4 L USM + 70-200/f4 L USM + 50/f1.4 USM
Merlin/Orion panohead + Papywizard on Nokia N800 and HP TC-1100

no avatar
atuor
Member
 
Posts: 36
Joined: Sat Sep 12, 2009 12:50 pm
Location: Vaud, Suisse

by atuor » Thu Feb 03, 2011 8:16 pm

If it it a regression, it hasn't been fixed in the final release. It works with OpenSuse 11.3, but not 11.2, which has glibc 2.10 not glibc 2.11
Olympus OMD-E5 - Kalahari pano head - OpenSuse OS

User avatar
AlexandreJ
Kolor Team
 
Posts: 5918
Joined: Mon Nov 14, 2005 4:56 pm
Location: Francin, France

by AlexandreJ » Fri Feb 04, 2011 8:58 am

Yes, we confirm that. The regression has not been fully fixed. The story :

We are using now an automatic build system to make all the compilations. For linux, we use ubuntu 10.10 under virtualbox to do that. So the full software is linked to glibc of this release.

What we need to do is to deploy 2 new virtualbox ( 32bits / 64 bits) under an older version of ubuntu ( the selected target is ubuntu 8.04 LTS ). So, with this background, the full software will be linked to the glibc of this OS and then should be compatible with a larger version of distribution.
This task is planned to be done soon.


Return to Archive

Who is online

Users browsing this forum: No registered users and 0 guests