Image-stitching and virtual tour solutions My account Updates
It is currently Mon Sep 22, 2014 11:17 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Sat Jan 22, 2011 10:43 pm 
Offline
Member

Joined: Sat Sep 12, 2009 12:50 pm
Posts: 27
Location: Vaud, Suisse
Hello,
Just tried the last RC2 (tried B2 before, which worked) on OpenSuse 11.2, and it says now I need glibc 2.11

/lib/libc.so.6: version `GLIBC_2.11' not found (required by /home/alain/bin/AutopanoPro25RC2/libQtGui.so.4

Is this normal that ver. requirements changed ? I found no simple way to update glibc for my distro :-/ If someone has a goog idea ... ;-)

_________________
Olympus E-P1 - M. Zuiko 9-18 F4-5.6, 14-42mm F3.5-5.6, 17mm F2.8 Pancake, 14–150mm F4.0–5.6 - Panosaurus Head


Top
 Profile  
 
 Post subject:
PostPosted: Mon Jan 24, 2011 4:28 pm 
Offline
Administrator
User avatar

Joined: Mon Nov 14, 2005 4:56 pm
Posts: 5901
Location: Francin, France
I don't have the answer. I've opened an issue on that : issue 545 opened


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jan 28, 2011 3:04 pm 
Offline
Administrator
User avatar

Joined: Wed Sep 29, 2010 9:00 am
Posts: 199
Location: Francin
This is a regression in RC2 and will be fixed in next release.

_________________
--
Yann G.
www.kolor.com


Top
 Profile  
 
 Post subject:
PostPosted: Fri Jan 28, 2011 5:45 pm 
Offline
Member
User avatar

Joined: Wed Dec 07, 2005 6:21 pm
Posts: 5826
Location: Grenoble, France
I don't know if it is the same issue, but I remember I was unable to start APG under debian stable, because of glibc.

Could it be possible to check that the final release will work with debian stable? Maybe not with the current one (lenny), which is pretty old, but with the next (which should be released soon)?

_________________
Frédéric

Canon 20D + 17-40/f4 L USM + 70-200/f4 L USM + 50/f1.4 USM
Merlin/Orion panohead + Papywizard on Nokia N800 and HP TC-1100


Top
 Profile  
 
 Post subject:
PostPosted: Thu Feb 03, 2011 8:16 pm 
Offline
Member

Joined: Sat Sep 12, 2009 12:50 pm
Posts: 27
Location: Vaud, Suisse
If it it a regression, it hasn't been fixed in the final release. It works with OpenSuse 11.3, but not 11.2, which has glibc 2.10 not glibc 2.11

_________________
Olympus E-P1 - M. Zuiko 9-18 F4-5.6, 14-42mm F3.5-5.6, 17mm F2.8 Pancake, 14–150mm F4.0–5.6 - Panosaurus Head


Top
 Profile  
 
 Post subject:
PostPosted: Fri Feb 04, 2011 8:58 am 
Offline
Administrator
User avatar

Joined: Mon Nov 14, 2005 4:56 pm
Posts: 5901
Location: Francin, France
Yes, we confirm that. The regression has not been fully fixed. The story :

We are using now an automatic build system to make all the compilations. For linux, we use ubuntu 10.10 under virtualbox to do that. So the full software is linked to glibc of this release.

What we need to do is to deploy 2 new virtualbox ( 32bits / 64 bits) under an older version of ubuntu ( the selected target is ubuntu 8.04 LTS ). So, with this background, the full software will be linked to the glibc of this OS and then should be compatible with a larger version of distribution.
This task is planned to be done soon.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group