Wired connection to Merlin/Orion  

Everything you need to motorize your head
no avatar
jriley
Member
 
Topic author
Posts: 147
Likes: 0 post
Liked in: 0 post
Joined: Tue Apr 08, 2008 2:51 pm
Location: Spartanburg, SC USA
Info

Wired connection to Merlin/Orion

by jriley » Tue Feb 17, 2009 11:50 pm

I have been getting a bit frustrated waiting around for my Tronisoft Papy kit and I would like to play a little with the Merlin/Orion head using a wired connection. :cool:

On one end, we have a Mac (that can run Windows XP under Parallels). Available ports: Ethernet and USB. I have a Keyspan USB to Serial converter. I have a null-modem cable, if needed.

On the other end, we have the Orion/Merlin with what appears to be a RJ11 phone jack.

How do we best make the twain meet? BTW - I already have Papywizard running in Windows XP under Parallels.

no avatar
mediavets
Moderator
 
Posts: 16415
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Wed Feb 18, 2009 12:45 am

You need an RS232-TLL convertor and some way of powering it, 2x220 ohm resistors, and an RJ-11 cable - in other words the equivalent of the Tronisoft kit without the BTLink Bluetooth-RS232 adapter - and a straight through 9-way serial cable.

Someting like this - but you'd need to figure out how to power it - a battery perhaps?

http://www.robotshop.us/droids-db9-serial-adapter.html

This one is port powered if your USB-serial convertor can provide the power?:
http://www.232analyzer.com/TTL-RS232-RS485-Serial-Converters/RS232-TTL3.3V-Converter.htm

And you could mod. this and it works direct from USB:
http://www.superdroidrobots.com/shop/item.asp?itemid=795&catid=58
Last edited by mediavets on Wed Feb 18, 2009 1:15 am, edited 1 time in total.
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

no avatar
jeremyp
Member
 
Posts: 33
Likes: 0 post
Liked in: 0 post
Joined: Sun Feb 15, 2009 4:28 am
Location: Sydney, Australia
Info

by jeremyp » Wed Feb 18, 2009 6:51 am

And you could mod. this and it works direct from USB:
http://www.superdroidrobots.com/shop/item.asp?itemid=795&catid=58

What TTL line level should we be using. I see cables like this running either 5V or 3.3V ?

Cheers,

Jeremy

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Wed Feb 18, 2009 8:37 am

The Merlin/Orion uses 5V TTL level. But it should be possible to use 3.3V TTL interface. Be sure their inputs can be wired to 5V levels (using a limitation resistor), and also that 3.3V output is enough for Merlin inputs (does anybody has make a test?).
Frédéric

User avatar
Paul
Member
 
Posts: 778
Likes: 0 post
Liked in: 0 post
Joined: Sat Aug 30, 2008 4:46 pm
Location: Bonn, Germany
Info

by Paul » Wed Feb 18, 2009 8:44 am

Paul

close, but no cigar ... ... ...

User avatar
claudevh
Moderator
 
Posts: 1349
Likes: 0 post
Liked in: 0 post
Joined: Sun Nov 25, 2007 11:12 pm
Location: Mont-Saint-André (Belgium)
Info

by claudevh » Wed Feb 18, 2009 9:56 am

Hi all,

3.3V modules don't work with the Merlin/Orion who use 5V, except if they are equiped with a "Dual Voltage Level Shifter" (like the SN74LVC8T245DGVR from Texas Instrument) this allows for universal low-voltage bidirectional translation between any of the 1.8-V,2.5-V, 3.3-V, and 5.5-V voltage nodes!

Some BT modules are allready equiped with a level shifter ( e.g. Sparkfun BlueSmirf, A7eng EB301 ...)

Actually, I finish my small study about finding "alternative to Tronisoft" (ongoing practical experiments) and I will communicate soon with recommandations (max 5 days more please!) ;)

Be patient ! :)

Concerning the USB converter from FTDI, don't buy the 3.3V model but the 5V model and it will work !
(not the "FTDI TTL-232R 3.3V" but the "FTDI TTL-232R", both 2 currently available also from FTDI http://apple.clickandbuild.com/cnb/shop/ftdichip?op=catalogue-products-null&prodCategoryID=47&title=Cables:+TTL-232R or other current sources)

:cool:
Last edited by claudevh on Wed Feb 18, 2009 10:02 am, edited 1 time in total.
:cool: Claude :cool:
Merlin + Papywizard on Windows 7 & Nokia 770 § N810 & Acer (Netbook) + PanoramaApp Androïd + Deltawave PapyMerlin BT + Autopano
Spherical Pano (180 x 360) with Canon 40D + Canon EF-S 10-22mm f/3.5-4.5 Zoom & Pôle Pano with Canon 5D MK2 and shaved Tokina 10-17 3.5-4.5 AF DX Fisheye
Gigapixel photography with Nikon D200 + Sigma 70-200 F 2.8 EX DG APO HSM

no avatar
mediavets
Moderator
 
Posts: 16415
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

by mediavets » Wed Feb 18, 2009 10:15 am

claudevh wrote:Hi all,

Concerning the USB converter from FTDI, don't buy the 3.3V model but the 5V model and it will work !
(not the "FTDI TTL-232R 3.3V" but the "FTDI TTL-232R", both 2 currently available also from FTDI http://apple.clickandbuild.com/cnb/shop/ftdichip?op=catalogue-products-null&prodCategoryID=47&title=Cables:+TTL-232R or other current sources)

:cool:

The cable as purchased is only 1.8m - by how much could you extend the cable?

I guess you still need the 2x220ohm resistors?
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

User avatar
claudevh
Moderator
 
Posts: 1349
Likes: 0 post
Liked in: 0 post
Joined: Sun Nov 25, 2007 11:12 pm
Location: Mont-Saint-André (Belgium)
Info

by claudevh » Wed Feb 18, 2009 10:30 am

Hi All,

Andrew is right ...

Only 1,8 m lenght yes! But USB cale extension are common ....

Yes, of course, the 2 resistors 220 Ohms are mandatory !

:cool:
:cool: Claude :cool:
Merlin + Papywizard on Windows 7 & Nokia 770 § N810 & Acer (Netbook) + PanoramaApp Androïd + Deltawave PapyMerlin BT + Autopano
Spherical Pano (180 x 360) with Canon 40D + Canon EF-S 10-22mm f/3.5-4.5 Zoom & Pôle Pano with Canon 5D MK2 and shaved Tokina 10-17 3.5-4.5 AF DX Fisheye
Gigapixel photography with Nikon D200 + Sigma 70-200 F 2.8 EX DG APO HSM

User avatar
Paul
Member
 
Posts: 778
Likes: 0 post
Liked in: 0 post
Joined: Sat Aug 30, 2008 4:46 pm
Location: Bonn, Germany
Info

by Paul » Wed Feb 18, 2009 11:26 am

wired connection with a standard USB cable and this converter and the two resistors

http://sigma-shop.com/shop/product_info.php?cPath=23&products_id=45

same as ebay item 310087736425

manual: http://www.sigma-shop.com/manuals/ftdi_manual.pdf
selectable 5V with jumper
Paul

close, but no cigar ... ... ...

no avatar
loddie
Member
 
Posts: 18
Likes: 0 post
Liked in: 0 post
Joined: Sat Feb 21, 2009 6:12 pm
Info

by loddie » Mon Feb 23, 2009 6:11 am

Paul,

It seems the wired option you listed is a cheap one, particularly for US based users. If I have a PC (w/Windows XP), Merlin, shutter release cable, USB cable, two resistors (2x 220 Ohm), Papywizard, and the converter, is there anything else I would need to have a functional PW/Merlin?

If so, has anyone assembled a tutorial how to assemble this wired option? I would be fine with tethered functionality.

User avatar
Paul
Member
 
Posts: 778
Likes: 0 post
Liked in: 0 post
Joined: Sat Aug 30, 2008 4:46 pm
Location: Bonn, Germany
Info

by Paul » Mon Feb 23, 2009 12:04 pm

just solder the two resistors to a 4 wire phone cord RJ12
and connect RX TX Ground


Paul

close, but no cigar ... ... ...

no avatar
loddie
Member
 
Posts: 18
Likes: 0 post
Liked in: 0 post
Joined: Sat Feb 21, 2009 6:12 pm
Info

by loddie » Mon Feb 23, 2009 8:49 pm

Thanks Paul! My soldering iron has not arrived yet, so I may have more questions once I get my hands dirty.

Cheers, LeRoy

no avatar
macbenutzer
Member
 
Posts: 75
Likes: 0 post
Liked in: 0 post
Joined: Fri Apr 17, 2009 1:01 pm
Location: Aachen - Aix-la-Chapelle
Info

by macbenutzer » Fri Apr 17, 2009 7:33 pm

Paul wrote:wired connection with a standard USB cable and this converter and the two resistors
http://sigma-shop.com/shop/product_info.php?cPath=23&products_id=45
manual: http://www.sigma-shop.com/manuals/ftdi_manual.pdf
selectable 5V with jumper

Hallo Paul, Hi Paul,
following your suggestion i ordered this article and am trying to get it working now...

Two things you could maybe help me with:
- where do i connect the 5V+? -> CTS# - ? / GND - Ground / RXD - Data (1x 220 Ohm) / UCC - ? / RTS# - ? / TXD - Data (1x 220 Ohm)
(i am not sure and tried it on UCC but i do get an USB-undercurrent error on my computer when connecting it)

- any hint how or what i have to choose in the system setting on Mac OS X?
I installed the new connection (with theis archive: FTDIUSBSerialDriver_v2_2_10.dmg) and activated it in the system preferences - but there are so many options there... (modem etc.).

Thanks - Danke - Peter
MacPro - MacBook - OS X 10.6.2 - D300 - D700 - Fuji S5 - PhaseOne P65+/P30+
8mm/10,5mm/10-20mm/17-35mm/18mm/25mm/85mm/etc. - wired + BT Merlin/Orion

User avatar
Paul
Member
 
Posts: 778
Likes: 0 post
Liked in: 0 post
Joined: Sat Aug 30, 2008 4:46 pm
Location: Bonn, Germany
Info

by Paul » Fri Apr 17, 2009 10:31 pm

no need to wire up 5V as they are supplied via the usb connector

Mac: sorry, I am using only unreal stuff ...
Paul

close, but no cigar ... ... ...

no avatar
macbenutzer
Member
 
Posts: 75
Likes: 0 post
Liked in: 0 post
Joined: Fri Apr 17, 2009 1:01 pm
Location: Aachen - Aix-la-Chapelle
Info

by macbenutzer » Fri Apr 17, 2009 11:41 pm

Paul wrote:no need to wire up 5V as they are supplied via the usb connector

Ok - i will try that... when i get the new adapter. The one i tried earlier is dead.
But which cable is which on the RJ11 connector going into the Merlin? There are 4 cables and i saw two different schemes how to connect them in this forum - as i have destroyed already one adapter i am a bit "unsure" now...

----------------
| yellow -> ?
| green -> ?
| brown -> ?
| white -> ?
----------------
The connectors looking up - the nose facing down - the cable going off to the right.

THANK YOU!!!


Last edited by macbenutzer on Fri Apr 17, 2009 11:42 pm, edited 1 time in total.
MacPro - MacBook - OS X 10.6.2 - D300 - D700 - Fuji S5 - PhaseOne P65+/P30+
8mm/10,5mm/10-20mm/17-35mm/18mm/25mm/85mm/etc. - wired + BT Merlin/Orion

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Sat Apr 18, 2009 8:07 am

Look at:

http://www.autopano.net/forum/p27797-2008-08-13-20-08-41#p27797

Yellow = GND
Green = NC
Brown = +12V
White = DATA

If you are using a USB cable, then you don't need to wire the +12V from the Merlin; just use GND, and DATA (through resistors, to RD and WR).
Frédéric

no avatar
macbenutzer
Member
 
Posts: 75
Likes: 0 post
Liked in: 0 post
Joined: Fri Apr 17, 2009 1:01 pm
Location: Aachen - Aix-la-Chapelle
Info

by macbenutzer » Sat Apr 18, 2009 8:41 am


This was the image i soldered the cable after... and which killed my adapter and shut off my computer. The computer is ok but the adapter is dead. Maybe i did a mistake - i will doublecheck again when i get a new adapter.

I had tried another scheme before but then the computer told me that there was not enough power to establish the USB connection. So i thought this was wrong.

Thanks a lot for now (as i have nothing to experiment with right now :-(

Peter
MacPro - MacBook - OS X 10.6.2 - D300 - D700 - Fuji S5 - PhaseOne P65+/P30+
8mm/10,5mm/10-20mm/17-35mm/18mm/25mm/85mm/etc. - wired + BT Merlin/Orion

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Sat Apr 18, 2009 9:29 am

As long as you don't wire the +12V from the Merlin, or the +5V from the USB adapter, you shouldn't burn anything. If you have a doubt, use a voltmeter to see where is the +12V...
Frédéric

no avatar
macbenutzer
Member
 
Posts: 75
Likes: 0 post
Liked in: 0 post
Joined: Fri Apr 17, 2009 1:01 pm
Location: Aachen - Aix-la-Chapelle
Info

by macbenutzer » Fri Apr 24, 2009 8:58 pm

Hi - i am back with a new adapter.
I soldered it now as advised and my Mac lists the adapter under USB devices. This is from the log:
/var/log/system.log.0.bz2:Apr 17 21:48:44 360pixel kernel[0]: FTDIUSBSerialDriver: 0 4036001 start - ok

How can i determine now the serial-port i have to tell Papywizard under Preferences? I tried some (like 0,1,4,5) but Papywizard does connect to the hardware. Also the adapter does not show any blinking LEDs.

More hints how to get that connection going under OS X 10.5.6?

Thank you!!!
MacPro - MacBook - OS X 10.6.2 - D300 - D700 - Fuji S5 - PhaseOne P65+/P30+
8mm/10,5mm/10-20mm/17-35mm/18mm/25mm/85mm/etc. - wired + BT Merlin/Orion

User avatar
claudevh
Moderator
 
Posts: 1349
Likes: 0 post
Liked in: 0 post
Joined: Sun Nov 25, 2007 11:12 pm
Location: Mont-Saint-André (Belgium)
Info

by claudevh » Fri Apr 24, 2009 10:06 pm

Hi Peter,

I know just nothing about MAC, but you can have a look hereafter:
http://www.autopano.net/forum/p40653-2009-03-12-23-35-06#p40653

:cool:
:cool: Claude :cool:
Merlin + Papywizard on Windows 7 & Nokia 770 § N810 & Acer (Netbook) + PanoramaApp Androïd + Deltawave PapyMerlin BT + Autopano
Spherical Pano (180 x 360) with Canon 40D + Canon EF-S 10-22mm f/3.5-4.5 Zoom & Pôle Pano with Canon 5D MK2 and shaved Tokina 10-17 3.5-4.5 AF DX Fisheye
Gigapixel photography with Nikon D200 + Sigma 70-200 F 2.8 EX DG APO HSM

no avatar
macbenutzer
Member
 
Posts: 75
Likes: 0 post
Liked in: 0 post
Joined: Fri Apr 17, 2009 1:01 pm
Location: Aachen - Aix-la-Chapelle
Info

by macbenutzer » Fri Apr 24, 2009 11:22 pm

Hi Claudevh,
looks interesting - but i have no folder called "/dev", just an alias. Where should it normally point to? I will have a deeper look into it...
Thanks - i will keep you informed.
Peter
MacPro - MacBook - OS X 10.6.2 - D300 - D700 - Fuji S5 - PhaseOne P65+/P30+
8mm/10,5mm/10-20mm/17-35mm/18mm/25mm/85mm/etc. - wired + BT Merlin/Orion

User avatar
fma38
Moderator
 
Posts: 5850
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Dec 07, 2005 6:21 pm
Location: Grenoble, France
Info

by fma38 » Sat Apr 25, 2009 8:45 am

Where does the alias lead? What does the following command return:

$ ls /dev/*
Frédéric

no avatar
macbenutzer
Member
 
Posts: 75
Likes: 0 post
Liked in: 0 post
Joined: Fri Apr 17, 2009 1:01 pm
Location: Aachen - Aix-la-Chapelle
Info

by macbenutzer » Sat Apr 25, 2009 2:03 pm

Hi, we are getting nearer (well, i am with your help):
i looked into /dev as Frederic described (with the adapter connected - otherwise it is is not shown!!!) and here is the relevant part:

/dev/ptys0 /dev/tty.usbserial-A6007ZIp /dev/ttyw5

I then entered this line ("/dev/tty.usbserial-A6007ZIp") in Papywizard under serial port but there is another error: (Papywizard log):

009-04-25 14:54:00,540::MainThread::INFO::Connecting to real hardware...
2009-04-25 14:54:00,836::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-25 14:54:00,837::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-25 14:54:01,044::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-25 14:54:01,045::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-25 14:54:01,252::Dummy-4::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-25 14:54:01,253::Dummy-4::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-25 14:54:01,253::Dummy-4::EXCEPTION::Shooting.switchToRealHardware()Traceback (most recent call last): File "papywizard/model/shooting.pyc", line 378, in switchToRealHardware File "papywizard/hardware/head.pyc", line 90, in init File "papywizard/hardware/axis.pyc", line 252, in init File "papywizard/hardware/axis.pyc", line 243, in _sendCmdHardwareError: Axis 1 can't send command
2009-04-25 14:54:01,312::MainThread::ERROR::Can't connect to hardwareAxis 1 can't send command

2009-04-25 14:54:07,884::MainThread::INFO::Go to simulation mode
2009-04-25 14:54:08,100::MainThread::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-25 14:54:08,100::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-25 14:54:08,308::MainThread::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-25 14:54:08,308::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-25 14:54:08,516::MainThread::EXCEPTION::Axis._sendCmdTraceback (most recent call last): File "papywizard/hardware/axis.pyc", line 236, in _sendCmd File "papywizard/hardware/serialDriver.pyc", line 114, in sendCmdIOError: Timeout bei seriellem Lesevorgang
2009-04-25 14:54:08,516::MainThread::WARNING::Axis._sendCmd(): axis 1 can't sent command. Retrying...
2009-04-25 14:54:08,516::MainThread::EXCEPTION::Shooting.switchToSimulatedHardware()Traceback (most recent call last): File "papywizard/model/shooting.pyc", line 391, in switchToSimulatedHardware File "papywizard/hardware/head.pyc", line 106, in shutdown File "papywizard/hardware/axis.pyc", line 372, in stop File "papywizard/hardware/axis.pyc", line 243, in _sendCmdHardwareError: Axis 1 can't send command

Papywizard then went into simulation mode.
At least Papywizard seems to see the adapter now but the communication does not work yet.:-)

Peter
MacPro - MacBook - OS X 10.6.2 - D300 - D700 - Fuji S5 - PhaseOne P65+/P30+
8mm/10,5mm/10-20mm/17-35mm/18mm/25mm/85mm/etc. - wired + BT Merlin/Orion

no avatar
macbenutzer
Member
 
Posts: 75
Likes: 0 post
Liked in: 0 post
Joined: Fri Apr 17, 2009 1:01 pm
Location: Aachen - Aix-la-Chapelle
Info

by macbenutzer » Sat Apr 25, 2009 2:10 pm

[SOLVED]
Sorry guys - i had not connected the power cord to the Merlin... its rotating!!! :-))))
I just made it move in the two axis and it follows. Big grin!!!

Thank you so far - i will write this "connecting to Mac story" together in a shorter form later for easier reading.

Peter
MacPro - MacBook - OS X 10.6.2 - D300 - D700 - Fuji S5 - PhaseOne P65+/P30+
8mm/10,5mm/10-20mm/17-35mm/18mm/25mm/85mm/etc. - wired + BT Merlin/Orion

User avatar
claudevh
Moderator
 
Posts: 1349
Likes: 0 post
Liked in: 0 post
Joined: Sun Nov 25, 2007 11:12 pm
Location: Mont-Saint-André (Belgium)
Info

by claudevh » Sat Apr 25, 2009 2:28 pm

Hi Peter,

Very happy for you !
I am still looking for "correct" replacement solution to the Parallax EB501 ser...
I wil come back with that later.

:cool:
:cool: Claude :cool:
Merlin + Papywizard on Windows 7 & Nokia 770 § N810 & Acer (Netbook) + PanoramaApp Androïd + Deltawave PapyMerlin BT + Autopano
Spherical Pano (180 x 360) with Canon 40D + Canon EF-S 10-22mm f/3.5-4.5 Zoom & Pôle Pano with Canon 5D MK2 and shaved Tokina 10-17 3.5-4.5 AF DX Fisheye
Gigapixel photography with Nikon D200 + Sigma 70-200 F 2.8 EX DG APO HSM

Next

Who is online

Users browsing this forum: No registered users and 2 guests