Tilted bracketing layers when stitching  

This forum is dedicated to Autopano Pro / Giga bug reports and features discussion.
Please read the posting rules before starting a topic!
no avatar
stadh
Member
 
Topic author
Posts: 124
Likes: 5 posts
Liked in: 3 posts
Joined: Wed Jan 28, 2015 5:59 pm
Info

Tilted bracketing layers when stitching

by stadh » Fri Jan 19, 2018 12:48 am

It seems like a bug to me. Or is there a setting that I overlooked?

I shot a spherical panorama with 32 positions and bracketing with 3 exposure variants, resulting in 96 images.
I checked that the bracketing sequences are exactly aligned. Not a pixel difference. Perfectly aligned. See this screencast:

alignedimages.mov
(5.72 MiB) Downloaded 109 times


When importing the images with the VRDrive wizard, I checked that the settings for stacks are set to "Fixed links" (I use the German version, don't know the exact English wording in the GUI. See screenshot to see what I mean).

ishot-2018-01-19_00-45-061.png


I did not enable Fusion in the Panorama editor:

ishot-2018-01-19_00-49-361.png


Then I rendered with "Antighost" preset and included all layers into the resulting PSB file.

ishot-2018-01-19_00-50-101.png


APG created a 4-layer PSB file with 3 layers containing the brackets and a fourth layer containing a fusioned image.
(Question: Why is there a fusioned layer, if I did not enable Fusion? Not an issue for me, but I don't understand this)


That fusioned image contains parts of each layer of course; however, here the layers are slightly shifted, resulting in blurry text for example. See here when I make only the fusioned layer visible:

blurrytext.mov
(6.29 MiB) Downloaded 105 times



I thought that exactly this phenomenon is NOT possible to happen, if I take care that I set the stacks to fixed links.
Am I wrong with this assumption? Or is there a bug in APG?


Thanks,
Daniel

no avatar
stadh
Member
 
Topic author
Posts: 124
Likes: 5 posts
Liked in: 3 posts
Joined: Wed Jan 28, 2015 5:59 pm
Info

Re: Tilted bracketing layers when stitching

by stadh » Fri Jan 19, 2018 8:01 am

One more data point, that might be of interest:
The three bracket layers in the PSB do NOT show that blurryness. Only the fourth (fusion) layer does.
However, the single bracketing layers are tilted against each other a bit.

That means to me: It cannot be a stitching issue, as then it would be visible in the single bracketing layers as well, right?
(To support this assumption, I rendered over night a second version of this pano with manually created control points directly on these signs with text, so that stitching *must* be perfect. The result is not any different than before).

But the renderer does not use fixed joints between the layers when stitching each single layer.


Who is online

Users browsing this forum: No registered users and 0 guests