"Assertion failed!" in decoder.c using CineForm source files  

This forum is dedicated to Autopano Video bug reports and features discussion.
Please read the posting rules before starting a topic!
no avatar
pcenginefx
New member
 
Topic author
Posts: 8
Likes: 2 posts
Liked in: 2 posts
Joined: Wed Feb 24, 2016 11:19 pm
Info

"Assertion failed!" in decoder.c using CineForm source files

by pcenginefx » Thu Mar 17, 2016 4:27 am

So my problem is this - Since the Kodak SP360 4K can only record up to 9mins at a time per file, the camera cuts up longer videos into multiple files. To be able to get the same stitch across the entire video in AVP, I need to first combine each camera's files into one video using Premiere Pro. Then I export as Quicktime Cineform to maintain quality and import the videos into AVP for stitching. As soon as I start rendering out of AVP, I get the following Assert:

Assertion Failed!
Program: CFHDDecoder64.dll
File: decoder.c
Line: 2204
Expression: segment.tuple.tag == CODEC_TAG_SAMPLE

Assert.JPG


I've attached a screenshot of the assert to this thread.

MY PC SPECS:
Windows 10 PRO x64
64GB RAM
i7-5930K 3.5GHz
New install of both Adobe CC & AVP/APG
AVP version 64x 2.3.1

Please let me know if you need anything further from me - hopefully this can be fixed quickly - thanks!

no avatar
media360
Member
 
Posts: 10
Likes: 4 posts
Liked in: 0 post
Joined: Thu Feb 25, 2016 8:01 am
Info

Re: "Assertion failed!" in decoder.c using CineForm source f

by media360 » Wed Oct 05, 2016 2:39 am

I am having a similar error.

Input: clips are 3 X Cineform High 422 mov files

Output: (7680x3840)
AVP will not output any of the cineform options
ProRes422 works but ProRes422HQ does not.

The render will run for a while but then i do receive the same error at random or it will crash. If i re open and render the same file again it will usually render the whole clip but then happen to another file later in the batch render.

Win10 64
32GB Ram
i7
latest Premiere / AME version
AVP 2.5.0 64bit
GTX970
SSD HDD

Thanks :)

no avatar
media360
Member
 
Posts: 10
Likes: 4 posts
Liked in: 0 post
Joined: Thu Feb 25, 2016 8:01 am
Info

Re: "Assertion failed!" in decoder.c using CineForm source f

by media360 » Wed Oct 05, 2016 5:27 am

adding to the above post.

These 4 errors arise.

4errors.jpg


If ignore is clicked the render continues

User avatar
olivierbo
Kolor Team
 
Posts: 2225
Likes: 1 post
Liked in: 134 posts
Joined: Thu Nov 06, 2014 11:44 am
Info

Re: "Assertion failed!" in decoder.c using CineForm source f

by olivierbo » Wed Oct 05, 2016 10:33 am

Hello,

Please use our new video file merger tool included with AVP 2.5: http://www.kolor.com/wiki-en/action/vie ... Tools_menu

Best,
OLivier

no avatar
media360
Member
 
Posts: 10
Likes: 4 posts
Liked in: 0 post
Joined: Thu Feb 25, 2016 8:01 am
Info

Re: "Assertion failed!" in decoder.c using CineForm source f

by media360 » Fri Oct 07, 2016 1:54 am

Hi OLivier,
The reason for the render out of AME was adding pre stitch noise reduction. No merging is required for these files.

Or are you suggesting that by merging it will add the appropriate tags that AVP is looking for and allow cineform exporting?
I have just run the same 3 input clips through the AVP file merger before stitching but this error appeared instead when trying to export as cineform Med422 7680x3840

Cine in out.JPG



Thank you
James

User avatar
olivierbo
Kolor Team
 
Posts: 2225
Likes: 1 post
Liked in: 134 posts
Joined: Thu Nov 06, 2014 11:44 am
Info

Re: "Assertion failed!" in decoder.c using CineForm source f

by olivierbo » Fri Oct 07, 2016 8:23 am

Hi James,

Do you have any codec installed on your system? This can create some errors. Avoid any pre-processing that can also create some errors.
Which camera are you using?

Cheers,
Olivier

no avatar
media360
Member
 
Posts: 10
Likes: 4 posts
Liked in: 0 post
Joined: Thu Feb 25, 2016 8:01 am
Info

Re: "Assertion failed!" in decoder.c using CineForm source f

by media360 » Fri Oct 07, 2016 8:35 am

Hi Olivier,

The only codecs are anything that comes by default within Adobe CC and the Kolor Cineform plugin for VLC, everything else is standard.

Sony A7Rii (exports h264)
Noise Reduction in Premiere Pro
Exported via Adobe Media Encoder into Cineform High 422 mov

Thanks
James

User avatar
olivierbo
Kolor Team
 
Posts: 2225
Likes: 1 post
Liked in: 134 posts
Joined: Thu Nov 06, 2014 11:44 am
Info

Re: "Assertion failed!" in decoder.c using CineForm source f

by olivierbo » Fri Oct 07, 2016 9:40 am

Hello,

Can you try with the original videos (without any pre-processing)?

Best,
Olivier

no avatar
jarnoburger
New member
 
Posts: 1
Likes: 0 post
Liked in: 0 post
Joined: Tue Oct 11, 2016 12:35 pm
Info

Re: "Assertion failed!" in decoder.c using CineForm source f

by jarnoburger » Tue Oct 11, 2016 12:39 pm

I am getting crazy..
Please fix it..
We NEED pre-edited cineform files , before they go into autopano.
But 8 out 10 projects crash..
Thtas way too much man..

User avatar
olivierbo
Kolor Team
 
Posts: 2225
Likes: 1 post
Liked in: 134 posts
Joined: Thu Nov 06, 2014 11:44 am
Info

Re: "Assertion failed!" in decoder.c using CineForm source f

by olivierbo » Tue Oct 11, 2016 1:19 pm

Hello,

We are working on that bug. Do you have an Apple computer? This problem only occurs on Windows.

Best,
Olivier

User avatar
Emeric
Kolor Team
 
Posts: 156
Likes: 3 posts
Liked in: 14 posts
Joined: Tue Apr 12, 2016 9:45 am
Info

Re: "Assertion failed!" in decoder.c using CineForm source f

by Emeric » Tue Oct 11, 2016 5:02 pm

media360 wrote:
I have just run the same 3 input clips through the AVP file merger before stitching but this error appeared instead when trying to export as cineform Med422 7680x3840

Cine in out.JPG



Hi media360, your problem of "unknown audio codec" and "cannot create encoder" is different than the one talked about in this thread, but here how to work around it:
First for the "unknown audio codec", when using CineForm or ProRes pipeline, you must use PCM audio. The most common formats are supported (sowt, fl32, twos, etc) but if you are unsure which one to choose, use 'sowt' (PCM 16b integer little endian).
Second for the "cannot create encoder" I believe it can be linked to the fact that you have either unsupported audio tracks (check) or multiple but different audio tracks.

These problems (as well as the infamous CineForm/ProRes crash on windows) are being worked on. Thanks.

User avatar
Emeric
Kolor Team
 
Posts: 156
Likes: 3 posts
Liked in: 14 posts
Joined: Tue Apr 12, 2016 9:45 am
Info

Re: "Assertion failed!" in decoder.c using CineForm source f

by Emeric » Tue Oct 11, 2016 5:03 pm

And by the way, does anyone have this problem on windows 7. Or really, any other version than 10 ???

User avatar
Emeric
Kolor Team
 
Posts: 156
Likes: 3 posts
Liked in: 14 posts
Joined: Tue Apr 12, 2016 9:45 am
Info

Re: "Assertion failed!" in decoder.c using CineForm source f

by Emeric » Thu Oct 13, 2016 11:58 am

Hey guys,
Can you try AVP 2.5.1 (http://www.kolor.com/2016/10/13/video-s ... deo-2-5-1/) and tell us what problems are solved and what are the ones that remains?

no avatar
rlebar
New member
 
Posts: 2
Likes: 2 posts
Liked in: 0 post
Joined: Tue Feb 14, 2017 11:27 pm
Info

Re: "Assertion failed!" in decoder.c using CineForm source f

by rlebar » Wed Mar 29, 2017 1:37 am

I am running into this problem as well! Running 2.6.0

Exported 6 gopro hero 5 cameras from premiere in mov go pro cineform...the stitch gets about halfway through the render and crashes with this error.
Attachments
error capture.PNG

no avatar
ctgsproductions
New member
 
Posts: 8
Likes: 0 post
Liked in: 0 post
Joined: Wed Mar 30, 2016 5:45 pm
Location: New York, NY
Info

Re: "Assertion failed!" in decoder.c using CineForm source f

by ctgsproductions » Wed Apr 18, 2018 4:07 pm

Hello,

I am having the exact same error message after trying to export from AVP version 2.6.
Was this issue resolved?
If yes, how?

Thank you.
Ulrich.


Who is online

Users browsing this forum: No registered users and 3 guests