.htaccess disables tour videos on Chrome   [SOLVED] - View the solution

This forum is fully dedicated to Panotour / Panotour Pro bug reports as well as feature discussion.
no avatar
embfilmmakers
New member
 
Topic author
Posts: 6
Likes: 0 post
Liked in: 1 post
Joined: Thu Aug 04, 2016 8:39 am
Info

.htaccess disables tour videos on Chrome

by embfilmmakers » Tue Mar 14, 2017 10:30 am

Hi,
I've recently upload a Panotour that works perfectly, and then I put an .htaccess and .htpasswd files on the same directory as the index.html file and indexdata folder so I can protect the content with a password.
If I use Chrome the tour doesn't load any video, and errors start to display on the bottom ("network loading error!"; "loading video failed!"). There are no such problems if I use Firefox.

If I disable or delete those .htaccess and .htpasswd files Chrome goes back to loading every tour video again.

Seems like these files are messing with something essential to load videos on Chrome.

The problem then is:
How do I protect a Panotour with a password so it works on every internet browser??

Thanks!

Nuno

User avatar
Annis
Kolor Team
 
Posts: 6062
Likes: 801 posts
Liked in: 444 posts
Joined: Mon Aug 12, 2013 12:47 pm
Location: France
Info

Re: .htaccess disables tour videos on Chrome  [SOLVED]

by Annis » Tue Mar 14, 2017 10:34 am

Did you check the option "The tour will be hosted on a website protected by credentials" in the Build Tab > Protection > Protected Website ?

no avatar
embfilmmakers
New member
 
Topic author
Posts: 6
Likes: 0 post
Liked in: 1 post
Joined: Thu Aug 04, 2016 8:39 am
Info

Re: .htaccess disables tour videos on Chrome

by embfilmmakers » Tue Mar 14, 2017 12:14 pm

In fact, I did not know there was an option for that. Shame on me!

I'll upload again and see if it is solved.

no avatar
embfilmmakers
New member
 
Topic author
Posts: 6
Likes: 0 post
Liked in: 1 post
Joined: Thu Aug 04, 2016 8:39 am
Info

Re: .htaccess disables tour videos on Chrome

by embfilmmakers » Wed Mar 15, 2017 12:37 pm

That was it, problem solved!

I checked the option "The tour will be hosted on a website protected by credentials", and it works fine.

Didn't know there was an option for that.

Thanks again!

Annis likes this post.


Who is online

Users browsing this forum: No registered users and 0 guests

cron