Pano transition in VR mode  

This forum is fully dedicated to Panotour / Panotour Pro bug reports as well as feature discussion.
no avatar
Xander Berkenhagen
Member
 
Topic author
Posts: 245
Likes: 5 posts
Liked in: 8 posts
Joined: Tue Oct 01, 2013 12:54 am
Info

Pano transition in VR mode

by Xander Berkenhagen » Thu May 05, 2016 4:49 am

Hi,

I just noticed that the pano transition between pano's is not smooth like in version 2.5.2...

Any idea how to adjust this?

Tegard,

Xander

no avatar
zodiacblue
Member
 
Posts: 22
Likes: 1 post
Liked in: 2 posts
Joined: Wed Oct 08, 2014 10:34 am
Info

Re: Pano transition in VR mode

by zodiacblue » Thu May 12, 2016 4:59 pm

I've just found the same issue think it's a bug in 2.5.3 as didn't have this problem in previous version I really don't want to go back to previous version if I can help it.

no avatar
zodiacblue
Member
 
Posts: 22
Likes: 1 post
Liked in: 2 posts
Joined: Wed Oct 08, 2014 10:34 am
Info

Re: Pano transition in VR mode

by zodiacblue » Fri May 13, 2016 10:08 am

Still Scratching my head with this one I compared two almost identical projects one created in 2.5.2 and one in 2.5.3 and could only find a few differences in the XML output. The main differences being in the _core_vr.xml files with regard to the events.dispatch command which in v 2.5.3 sets the boolean value on a few occasions compared to the v2.5.2 which I thought may cause the issue due to xml process order which the events.dispatch boolean value controls.

Tried changing the values to no avail so think this might be wrong place to look.

I then thought it might be due to preview images not loading but then looked at both sets of code for both generated tours and realised that they are set to NOPREVIEW.

Am currently looking at changing the settings for the mainloadscene function to include some sort of transition in VR or actually load the preview as opposed to not to see if that presents a more comfortable viewing experience.

Unless I'm missing something though this looks to me as if it may actually be being caused by a change in the Javascript file ie krpanoJS v1.19-pr3 vs krpanoJS v1.19-pr4 as I can't seem to find anything else that could be causing this.

User avatar
bdd
Kolor Team
 
Posts: 2802
Likes: 14 posts
Liked in: 130 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

Re: Pano transition in VR mode

by bdd » Fri May 13, 2016 10:31 am

Charles,
We use a property in the WebVR plugin that should force the laod of all tiles before changing the panorama.
THis property did not change between 2.5.2 and 2.5.3 .
So I'll ask Klaus if a bug appeard between 1.19pr3 and 1.19pr4 in krpano player.

Gérald

zodiacblue likes this post.

no avatar
zodiacblue
Member
 
Posts: 22
Likes: 1 post
Liked in: 2 posts
Joined: Wed Oct 08, 2014 10:34 am
Info

Re: Pano transition in VR mode

by zodiacblue » Fri May 13, 2016 11:11 am

Thanks Gérald

As a work around the following fix seems to solve the problem for me.

in _core_vr.xml change code in action name = mainloadscene

from - loadscene(%1, get(projection_current_params), NOPREVIEW|KEEPVIEW|KEEPMOVING, get(ptblendmode));

to- loadscene(%1, get(projection_current_params), KEEPVIEW|KEEPMOVING, get(ptblendmode));

and I've also changed the ptblendmode action

from - krpano ptblendmode="NOBLEND"
to - krpano ptblendmode="BLEND(2, easeinSine)"

:)


Who is online

Users browsing this forum: No registered users and 0 guests