Image-stitching and virtual tour solutions My account Updates
It is currently Fri Oct 31, 2014 12:40 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 11 posts ] 
Author Message
PostPosted: Sun Dec 02, 2007 8:16 pm 
Offline
Member
User avatar

Joined: Tue Dec 20, 2005 12:13 am
Posts: 2680
Location: Paaaaaaris !
J'ai un rendu très etrange avec des photos prisent en verticales (40D ou 20D plus traitement DXO V5).

La prévisu, j'ai pleins de traces noires partout...
lors du rendu, le placement des photos est complètement chamboulé, et ne correspond pas du tout à  la prévisu, ni au résultat attendu...

est-ce du au traitement de DXO V 5??? Je vais essayer les images originales...





_________________
Look. There's a rhythmic ceremonial ritual coming up !


Top
 Profile  
 
 Post subject:
PostPosted: Sun Dec 02, 2007 8:20 pm 
Offline
Member
User avatar

Joined: Tue Dec 20, 2005 12:13 am
Posts: 2680
Location: Paaaaaaris !
pour info, images originales issues du 40D, pano nicquel...
Elle est vraiment pourrie cette V5 de DXO décidement.

Je peux t'envoyer les images traitées par DXO pour que tu vois d'ou vient le pb...

_________________
Look. There's a rhythmic ceremonial ritual coming up !


Top
 Profile  
 
 Post subject:
PostPosted: Sun Dec 02, 2007 8:32 pm 
Offline
Member
User avatar

Joined: Tue Dec 20, 2005 12:13 am
Posts: 2680
Location: Paaaaaaris !
images transférée dans : /incoming/panoramas-failed/

fichier : TAF - Pb pano images traitees DXO V5.rar

Bon courage...

PS : put... j'ai vraiment pas de bol moi... retour de vacances, 6000 photos a traiter, une version de DXO V5 toute pourrie, et maintenant, ce pb avec les panos avec des photos traitées par DXO V5 en verticales (70% des panos...)

phooou, quand ca veut pas, ca veut pas ;) !

_________________
Look. There's a rhythmic ceremonial ritual coming up !


Top
 Profile  
 
 Post subject:
PostPosted: Sun Dec 02, 2007 11:00 pm 
Offline
Member
User avatar

Joined: Tue Dec 20, 2005 12:13 am
Posts: 2680
Location: Paaaaaaris !
Je crois que j'ai trouvé...

DXO a bien changé l'orientation de la photo, mais n'a pas changé la résolution de l'image...
il a laissé en X 3935 et en Y 2592, ce qui fait qu'APP reconnait bien que les images sont en paysages, mais pour le stiching, il est trompé par les valeur X et Y contenu dans les EXIFS...

Sal.... de version de DXO V5 à  la c.. !

_________________
Look. There's a rhythmic ceremonial ritual coming up !


Top
 Profile  
 
 Post subject:
PostPosted: Sun Dec 02, 2007 11:13 pm 
Offline
Member
User avatar

Joined: Tue Dec 20, 2005 12:13 am
Posts: 2680
Location: Paaaaaaris !
bon, c'est cela, en inversant les données X et Y dans les exifs, c'est OK.
Reste à  savoir maintenant si c'est le 40D qui est buggué ou DXO (j'ai une petit idée)...

_________________
Look. There's a rhythmic ceremonial ritual coming up !


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 03, 2007 9:58 am 
Offline
Administrator
User avatar

Joined: Mon Nov 14, 2005 4:56 pm
Posts: 5901
Location: Francin, France
Tu as tout bien analyser le problème. Ce bug des bandes noires vient toujours du même problème : un mauvais codage de l'exif d'orientation combiné avec un mauvais décodage. Normalement tous les cas à  con on les à  traité maintenant, donc, c'est plutot DxO qui doit produire des fichiers pas bon.


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 03, 2007 10:51 am 
Offline
Member
User avatar

Joined: Tue Dec 20, 2005 12:13 am
Posts: 2680
Location: Paaaaaaris !
en effet, je suis sur que c'est DXO qui fait mal le boulot... Les images non traitées DXO passent très bien. Et en modifiant les exifs a la main, tout est OK.

DXO nous a sortie une version V5 digne d'une poubelle, et encore... un truc inouï ! A croire qu'il ne connaissent pas la notion de tests-recette-version beta...

Alexandre, tu peux me dire sur quel valeur tu te base dans les exifs pour savoir si une photo est en paysage ou portrait. Apparement, ce n'est pas le tag Orientation ???

_________________
Look. There's a rhythmic ceremonial ritual coming up !


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 03, 2007 10:58 am 
Offline
Member
User avatar

Joined: Tue Dec 20, 2005 12:13 am
Posts: 2680
Location: Paaaaaaris !
je laisse un peu le fil ici, je le déplacerais plus tard... au cas ou des gens utilisent cette daube de version 5 de DXO !

_________________
Look. There's a rhythmic ceremonial ritual coming up !


Top
 Profile  
 
 Post subject:
PostPosted: Mon Dec 03, 2007 10:59 am 
Offline
Member
User avatar

Joined: Tue Dec 20, 2005 12:13 am
Posts: 2680
Location: Paaaaaaris !
Un petit truc Alexandre :

Certe, il ne s'agit pas de compenser les lacunes d'un truc pourri comme DXO, mais :

APP reconnait bien les images en verticale (ACDSEE les reconnaissaient comme horizontale), cependant, le fait que la valeur X soit > à  la valeur Y ne le choque pas (ACDSEE avait en fait raison)...

Donc ici, dans ce cas, APP traite les images en mode verticale , mais il fait les calculs de recollement-projection comme si les images était en mode paysage (normal, tu te bases sur les valeurs X et Y), ce qui fait qu'APP ne détermine pas réellement si l'image est verticale ou horizontale (il fait un mixte des deux).

Peut être faudrait t'il vérifier si l'info orientation correspond bien aux valeur X et Y, à  savoir :

Paysage -> X > Y
Portrait -> X < Y

Apparement, pas mal de soft de visualisation d'image ne se laisse pas avoir (ils se bases plus sur les valeurs X et Y plutôt que sur l'orientation).

_________________
Look. There's a rhythmic ceremonial ritual coming up !


Top
 Profile  
 
 Post subject:
PostPosted: Fri Mar 14, 2008 3:46 pm 
Offline
Administrator
User avatar

Joined: Mon Nov 14, 2005 4:56 pm
Posts: 5901
Location: Francin, France
Bug confirmé sur les TIFF 16bits de DxO.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Mar 18, 2008 2:25 pm 
Offline
Administrator
User avatar

Joined: Mon Nov 14, 2005 4:56 pm
Posts: 5901
Location: Francin, France
Le bug TIFF 16bits est corrigé.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group