Sound with Livepano tour isn't always in sync  

This forum is fully dedicated to Panotour / Panotour Pro bug reports as well as feature discussion.
no avatar
Redmar
Member
 
Posts: 26
Joined: Mon Aug 12, 2013 11:24 am

Sound with Livepano tour isn't always in sync

by Redmar » Wed Feb 05, 2014 1:13 pm

Hi,

We created a test tour with Panotour Pro 2 RC2 and Livepano. On most Desktop pc's (Mac and PC) and Ipads the sound is out of sync. The site is hosted on a dedicated server.

We fed Livepano with a mp4 Format H.264 movie (24 MB in size) The output livepano_high.mp4 is about 5 mb and in perfect sync.

Does anybody else have a clue what might cause this problem? Link to the test tour:
http://www.viditour.nl/clients/viditour/viditour_demo_kindervilla_livepano_v1/

User avatar
bdd
Kolor Team
 
Posts: 1775
Joined: Tue Jan 18, 2011 4:05 pm

Re: Sound with Livepano tour isn't always in sync

by bdd » Thu Feb 06, 2014 11:14 am

Redmar wrote:Hi,

We created a test tour with Panotour Pro 2 RC2 and Livepano. On most Desktop pc's (Mac and PC) and Ipads the sound is out of sync. The site is hosted on a dedicated server.

We fed Livepano with a mp4 Format H.264 movie (24 MB in size) The output livepano_high.mp4 is about 5 mb and in perfect sync.

Does anybody else have a clue what might cause this problem? Link to the test tour:
http://www.viditour.nl/clients/viditour/viditour_demo_kindervilla_livepano_v1/



We checked on different iPads, and on our desktops, and the sound in your tour is playing correctly.

On which kind of OS, which version, are you tryingyour tour ?
With which browsers ?

Gérald

no avatar
Redmar
Member
 
Posts: 26
Joined: Mon Aug 12, 2013 11:24 am

Re: Sound with Livepano tour isn't always in sync

by Redmar » Fri Feb 07, 2014 10:12 am

Hi Gérald,

We experienced this problem on a MacbookPro (latest OS) with Firefox and several (older) Windows machines with Explorer, Chrome and Firefox. On these systems the video is also chunky.

On our workstation (with 64 GB, windows 7 Xeon) we don't have this problem.

A few questions:
1. What would you advise to use as input video material in Panotour Pro? Format and Codec?
2. Is it possible to force buffering of the video in the client browser before playing? Maybe it is a problem with older computers or i-pads.
3. The quality of the low-res output as used and generated by Panotour for I-pad is very low; compared to your Chai example. Do you have any tips to improve this quality or to disable low-res output?
Link to the files generated by Panotour Pro:
High quality:
http://www.viditour.nl/clients/viditour/viditour_demo_kindervilla_livepano_v1/indexdata/spots/vidi_kindervilla_2014_01_16_145457_f74a0776_livepano_high.mp4
Low quality:
http://www.viditour.nl/clients/viditour/viditour_demo_kindervilla_livepano_v1/indexdata/spots/vidi_kindervilla_2014_01_16_145457_f74a0776_livepano_low.mp4
4. On I-pad the video doesn't automatically start; is it possible to start automatically?

Congratulations with the final release!

Best regards,
Redmar

User avatar
bdd
Kolor Team
 
Posts: 1775
Joined: Tue Jan 18, 2011 4:05 pm

Re: Sound with Livepano tour isn't always in sync

by bdd » Fri Feb 07, 2014 11:46 am

Redmar wrote:A few questions:
1. What would you advise to use as input video material in Panotour Pro? Format and Codec?

For a livepano, use directly the video form your dslr.

Redmar wrote:2. Is it possible to force buffering of the video in the client browser before playing? Maybe it is a problem with older computers or i-pads.

You can try to tune the "buffertime" atribute of the videoplayer plugin in the generated code.
http://krpano.com/plugins/videoplayer/#buffertime

Redmar wrote:3. The quality of the low-res output as used and generated by Panotour for I-pad is very low; compared to your Chai example. Do you have any tips to improve this quality or to disable low-res output?

The "low-res" output is computed to be suitable for every tablets and phones. It is using a mobile preset.
If you change the generated video, by a higher res one in the generated tour, the video may not play on some mobile devices.

Redmar wrote:4. On I-pad the video doesn't automatically start; is it possible to start automatically?

Sadly no.
Users have to click on the video to start it.

no avatar
Redmar
Member
 
Posts: 26
Joined: Mon Aug 12, 2013 11:24 am

Re: Sound with Livepano tour isn't always in sync

by Redmar » Fri Feb 07, 2014 1:21 pm

A few questions:
1. What would you advise to use as input video material in Panotour Pro? Format and Codec?

For a livepano, use directly the video form your dslr.

What if we need to do some editing in Premiere (color correction, cut, etc.)? What format and codec do you recommend?

2. Is it possible to force buffering of the video in the client browser before playing? Maybe it is a problem with older computers or i-pads.
You can try to tune the "buffertime" atribute of the videoplayer plugin in the generated code.
http://krpano.com/plugins/videoplayer/#buffertime

We'll give it a try!

3. The quality of the low-res output as used and generated by Panotour for I-pad is very low; compared to your Chai example. Do you have any tips to improve this quality or to disable low-res output?

The "low-res" output is computed to be suitable for every tablets and phones. It is using a mobile preset.
If you change the generated video, by a higher res one in the generated tour, the video may not play on some mobile devices.

Maybe an idea for the future to give the possibility to fine tune this because now it's very pixelated. How is it possible that the Chai example is of good quality on an I-pad?

4. On I-pad the video doesn't automatically start; is it possible to start automatically?
Sadly no.
Users have to click on the video to start it.

That's a shame; maybe you guys can add an option in Livepano with an overlay of a play button for the first frame? I think otherwise a lot of users won't come up with the idea to click on it because it's so new for people ;)


Return to Panotour bugs & discussion

Who is online

Users browsing this forum: No registered users and 2 guests