mp4 does not display with Safari 7.0.1???  

All things panoramic.
An open forum for every topic on photography, panoramas, IT or related.
User avatar
Destiny
Moderator
 
Posts: 4992
Joined: Mon Apr 26, 2010 11:55 pm
Location: Australia

mp4 does not display with Safari 7.0.1???

by Destiny » Thu Dec 26, 2013 2:14 am

Updating to the latest version of anything has always in my past experiences caused more issues than it fixes.. Here a case in point.. I was so easily able to view an mp4 movie embedded into a html page.. There is quite honestly, no reason why it should not work.. but it doesn't.. Now, is this a bug or a new way of doing things.. Has anyone else had this issue...

Destiny..
PS.. It might not be Safari, it might well be Mavericks needs a plugin, at the moment it default to QT..

User avatar
Destiny
Moderator
 
Posts: 4992
Joined: Mon Apr 26, 2010 11:55 pm
Location: Australia

Re: mp4 does not display with Safari 7.0.1???

by Destiny » Thu Dec 26, 2013 10:27 am

Hey.. After an epic live screen linkup with Apple, its confirmed that there is an issue with mp4 with the new Mavericks, or Safari or the way the video is embedded.. It might be an Adobe issue not creating / building the file correctly or it might be Safari not reading the files or its the Mavericks build stuffing up the plugins... What ever it is.. Apple will get back to us in a few days since the ticket has been escalated to the software development team.. As far as I can tell, if you add a mp4 into a movie polygon inside your Tour, it will work fine. However, if you embed your movie into a html, using Dreamweaver and use the Website Box using Mavericks and the latest Safari to view it, you might not get to see your movie.. It will however work with Opera..

Also, for anyone using Mavericks, I have requested that the grey UI icons be changed to colour, or at least a user option given.. At the moment its horrible.. The seniour tech guy said he will put that request forward immediately...

Destiny...

PS.. Its not just an issue with mp4, its the same issue with QT movies..

no avatar
klausesser
Member
 
Posts: 7858
Joined: Mon May 22, 2006 12:18 am
Location: Duesseldorf, Germany

Re: mp4 does not display with Safari 7.0.1???

by klausesser » Thu Dec 26, 2013 2:44 pm

Destiny wrote:PS.. Its not just an issue with mp4, its the same issue with QT movies..



Add Quicktime Player 7 - needed to do it in 10.6.8 also.

Klaus
Attachments
QT2.png
QT2.png (12.94 KiB) Viewed 500 times

User avatar
Destiny
Moderator
 
Posts: 4992
Joined: Mon Apr 26, 2010 11:55 pm
Location: Australia

Re: mp4 does not display with Safari 7.0.1???

by Destiny » Thu Dec 26, 2013 8:08 pm

That was one of the first things I tried... Some of the older codecs are needed with some apps.. However, I am using CS6 apps so QuickLook should work with the new QT player...

Destiny..

User avatar
Destiny
Moderator
 
Posts: 4992
Joined: Mon Apr 26, 2010 11:55 pm
Location: Australia

Re: mp4 does not display with Safari 7.0.1???

by Destiny » Thu Dec 26, 2013 8:31 pm

If yours is working Klaus, it's probable due to the fact that you have more current versions of Final Cut Pro X, Motion 5, or Compressor 4. These apps allow you to install all types of Apple ProRes Codecs, but the normal run of the mill Mac user will not have these apps or even have need for them.. I rarely use my Final Cut Studio so consequently its an oder version.. In fact, the price I paid for an academic licence version is now more than you can buy it for production use.. The price is now very cheap for what it is.. However, I still have no need to upgrade..

Destiny...

User avatar
Destiny
Moderator
 
Posts: 4992
Joined: Mon Apr 26, 2010 11:55 pm
Location: Australia

Re: mp4 does not display with Safari 7.0.1???

by Destiny » Wed Jan 01, 2014 6:07 am

Hi..

I think I have worked out why an mp4 movie will not work in a html locally using the Mavericks and Safari... It has to be a new Safari Security Protocol.. Apple Div Team have not gotten back to me yet due to the holiday season.. I sent them my theory, since I am sure I am right... With a url, it now has to be a full url when linking in PTP V2.... It can no longer be just the file #.html... I can view locally using Opera but thats about it, but that might have changed with the new version.. I have not updated.. I have been doing some Beta testing for the new Zoomify software and its been discovered that even Chrome, IE and Firefox has these security protocols too which effect the Zoomify JS.... Ways round it to view a mp4 in html locally might include downloading special codecs if you have the software installed to allow you to do so.. Not entirely sure on that one....

Destiny..


Return to Open discussion

Who is online

Users browsing this forum: No registered users and 5 guests