Blank page  

Share your tips and tricks here or get help with any Panotour problem!
No bug reports (of any kind) in this forum!
no avatar
rcpagan
New member
 
Posts: 9
Joined: Mon Dec 16, 2013 5:58 pm

Blank page

by rcpagan » Mon Dec 16, 2013 6:16 pm

I am getting a blank page when opening my virtual tour, this is the url for it:
http://distinx.com/vtour/lofts/virtual_ ... ltour.html

Using the developer console on firefox i found this error:
[11:52:52.769] ReferenceError: embedpano is not defined

any suggestions hoe to correct it?

thanks

no avatar
mediavets
Moderator
 
Posts: 14161
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.

Re: Blank page

by mediavets » Mon Dec 16, 2013 6:42 pm

rcpagan wrote:I am getting a blank page when opening my virtual tour, this is the url for it:
http://distinx.com/vtour/lofts/virtual_ ... ltour.html

Using the developer console on firefox i found this error:
[11:52:52.769] ReferenceError: embedpano is not defined

any suggestions hoe to correct it?

thanks

Welcome to the forum...

Is this HTML page as created by the HTML template when building the tour or have you modified it?

If its a standard HTML file created by PTP 1.8, are you sure you uploaded all the files created when the tour was built and maintained the file/folder sturcute?

Are you sure the file permissions are correct on the web server?

Which version of Firefox, with which OS, are you using to view the tour?

no avatar
rcpagan
New member
 
Posts: 9
Joined: Mon Dec 16, 2013 5:58 pm

Re: Blank page

by rcpagan » Mon Dec 16, 2013 6:54 pm

The only thing i modified on the html was the text on header. I have switched back to to the original but no success. The folder file structure was kept intact. I have tried several different permissions, no change. What should the permissions be? Just to make sure i got it right. I can open the tour locally with no problems.
Firefox 25.0.1 / OS MAC OS X 10.9 Maverick, I have tried chrome and safari and even on windows machines and have the same issue, just a blank page.
I just rebuild the tour and will upload it with no modifications.

Thanks for the assistance.

no avatar
mediavets
Moderator
 
Posts: 14161
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.

Re: Blank page

by mediavets » Mon Dec 16, 2013 7:00 pm

rcpagan wrote:The only thing i modified on the html was the text on header. I have switched back to to the original but no success. The folder file structure was kept intact. I have tried several different permissions, no change. What should the permissions be? Just to make sure i got it right. I can open the tour locally with no problems.
Firefox 25.0.1 / OS MAC OS X 10.9 Maverick, I have tried chrome and safari and even on windows machines and have the same issue, just a blank page.
I just rebuild the tour and will upload it with no modifications.

Thanks for the assistance.


What FTP program are you using to upload the tour.

Other Mac users have in the past reported that some Mac FTP programs set file permissions in correctly.

no avatar
rcpagan
New member
 
Posts: 9
Joined: Mon Dec 16, 2013 5:58 pm

Re: Blank page

by rcpagan » Mon Dec 16, 2013 7:06 pm

FileZilla 3.6.0.2

no avatar
rcpagan
New member
 
Posts: 9
Joined: Mon Dec 16, 2013 5:58 pm

Re: Blank page

by rcpagan » Mon Dec 16, 2013 7:06 pm

What are the proper permissions?
Thanks a lot

no avatar
mediavets
Moderator
 
Posts: 14161
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.

Re: Blank page

by mediavets » Mon Dec 16, 2013 7:52 pm

rcpagan wrote:What are the proper permissions?
Thanks a lot


My PTP 1.8 tour XML files have these permissions:
Attachments
ptp18-xml-permissions.jpg
ptp18-xml-permissions.jpg (32.59 KiB) Viewed 466 times

no avatar
rcpagan
New member
 
Posts: 9
Joined: Mon Dec 16, 2013 5:58 pm

Re: Blank page

by rcpagan » Mon Dec 16, 2013 11:07 pm

Thanks a lot, you guided me the right direction. The problem was related to the permissions. I was compressing the files before uploading, which must affect the permissions. I uploaded the files without compressing them and it works fine. Thanks again for your quick replies!


Return to Using Panotour / Panotour Pro 1.8

Who is online

Users browsing this forum: No registered users and 1 guest