Problems embedding pano into webpage  

Share your tips and tricks here or get help with any Panotour problem!
No bug reports (of any kind) in this forum!
no avatar
andy4nothin
Member
 
Posts: 31
Joined: Tue Sep 24, 2013 10:52 am

Problems embedding pano into webpage

by andy4nothin » Sat Nov 09, 2013 5:46 pm

Just registered version 1.8 upon realising that I couldn't use the trial version on a live website.

I've gone from seeing the black flashplayer window with 'Error: Panotour Pro Trial', to a black flashplayer window informing me of the Panotour version, build, flashplayer version, registered to email, a warning and error.

The warning is: 'unknown action: hidepanospotsaction'
The error is: decoding failed - virtualtourdata/virtualtour0/preview.jpg

The pano works from the original generated HTML or the SWF when dragged into the browser.

The error: decoding failed path is only partial, and on my developement machine, sits inside another folder, eg 127.0.0.1/www.domainname.co.uk/panos/virtualtourdata/virtualtour0/preview.jpg

I've tried variations on the relative path which all result in a totally black box.

Any suggestions would be most welcome.

no avatar
andy4nothin
Member
 
Posts: 31
Joined: Tue Sep 24, 2013 10:52 am

Re: Problems embedding pano into webpage

by andy4nothin » Sat Nov 09, 2013 9:39 pm

Since there were no suggestions, I guess this was a basic newb error.

My consclusion is that it appears that the krpano viewer will only access jpgs from within its own directory and subdirectories. I think the structure of my URL's makes the viewer flash file think it's in a different location to the image directories.

My workaround is to use an iframe. To avoid creating an HTML file for each iframe/pano, I just create an index file with an include that points to the actual iframe HTML file and pass a variable in the URL.

Here's my first effort working: http://www.uktripper.co.uk/visits.cfm/kinver-edge/

There seems to be a problem with a corrupt cached image though. Otherwise, pretty pleased.

Any critique is welcome.

no avatar
edgar_ali
Member
 
Posts: 63
Joined: Tue Jan 21, 2014 12:50 pm
Location: Wollongong, Australia

Re: Problems embedding pano into webpage

by edgar_ali » Wed Jan 22, 2014 12:01 am

I have created a simple tour using Panatour 1.8.

I opened the tour using my safari browser and I was able to see it.

I uploaded my tour to the following address and there is nothing:
http://www.screencast.com/t/rch1xOZkjvz

When uploading in a different host, I get the following message:
http://www.screencast.com/t/wnx139q1fXM

It says something about error: download of untitleddata... (check the screenshot attached above)

How Can I fix this problen so I can see my tour

no avatar
mediavets
Moderator
 
Posts: 14163
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.

Re: Problems embedding pano into webpage

by mediavets » Wed Jan 22, 2014 12:10 am

edgar_ali wrote:I have created a simple tour using Panatour 1.8.

I opened the tour using my safari browser and I was able to see it.

I uploaded my tour to the following address and there is nothing:
http://www.screencast.com/t/rch1xOZkjvz

When uploading in a different host, I get the following message:
http://www.screencast.com/t/wnx139q1fXM

It says something about error: download of untitleddata... (check the screenshot attached above)

How Can I fix this problen so I can see my tour


Please don't duplicate post.

See: viewtopic.php?f=33&t=18371&p=135611#p135611


Return to Using Panotour / Panotour Pro 1.8

Who is online

Users browsing this forum: No registered users and 1 guest