export is confusing!  

This forum is fully dedicated to Panotour / Panotour Pro bug reports as well as feature discussion.
no avatar
itsrichphoto
Member
 
Posts: 61
Joined: Thu Apr 18, 2013 10:56 pm
Location: OC, California

export is confusing!

by itsrichphoto » Thu Sep 05, 2013 6:22 pm

I am exporting a project that has 103 scenes. Not embedded.

I finished the project and sent it on a disk to a client. He complains that it isnt completely working. When I look at the original tour on the computer it works fine, but not on the disks.

From what i can see, there are .xml files upto 103.xml. in the project data folder, it goes upto 100. This means that the project data for 3 scenes are not being exported. The xml files direct to image folders that simply are not there, but they work. I therefore presume that perhaps it has created hidden folders. Not the case!

So firstly, why is panotour not exporting everything and how do I remedy this?

why does the tour work on the computer but not on the disk?

why does panotour **** things up like this?! everytime I do a big project, something happens that makes a one day job a three day job. Can anyone recommend better software because I dont have the time, patience or energy or knowledge to understand and fix why this kind of **** happens.....

I had to give an analogy last time to an angry client "its like you drive into the desert and you discover the most amazing castle". You go there in another car and its not there, then in the first car and it is there again. It doesnt make sense!
Richard Hart
Commercial and portrait photographer OC California
http://www.richhartphoto.com

no avatar
itsrichphoto
Member
 
Posts: 61
Joined: Thu Apr 18, 2013 10:56 pm
Location: OC, California

by itsrichphoto » Thu Sep 05, 2013 6:25 pm

just to clarify 101.xml 102.xml 103.xml all direct to the image files in folders 101, 102, 103 which are not there, but they show the images without error in the virtual tour on the computer. There are no hidden files in that folder

Additionally, in the first instance, when I drag all the files to toast, only 3 data files copy across...
Last edited by itsrichphoto on Thu Sep 05, 2013 6:26 pm, edited 1 time in total.
Richard Hart
Commercial and portrait photographer OC California
http://www.richhartphoto.com

no avatar
mediavets
Moderator
 
Posts: 14167
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.

by mediavets » Thu Sep 05, 2013 8:06 pm

itsrichphoto wrote:So firstly, why is panotour not exporting everything and how do I remedy this?

I think you are using Mac version PTP 1.8 - is that correct?

I would suggest you do a new built to a new folder and that way it should export all files rather than trying to do an incremental build.

I can't imagine how ir's working on your computer is files and folders are apparently missing.

Is the client viewing from local disk on a Mac and seeing the Flash version of the tour? S/he will need to set the Flash security settings appropriately if so:

http://krpano.com/docu/localusage/#top
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

no avatar
itsrichphoto
Member
 
Posts: 61
Joined: Thu Apr 18, 2013 10:56 pm
Location: OC, California

by itsrichphoto » Thu Sep 05, 2013 8:11 pm

THANKS A lot for the info!

I rebuilt it in a different folder after restarting the computer so that shouldn't have been the issue. With that export, it still worked locally, but not from the dvd.

I just made a mini tour with the missing files and exported that project, then changed the folder names to match. That worked! It still doesnt explain what is going on and why though. It has to be ptp being emotional...
Richard Hart
Commercial and portrait photographer OC California
http://www.richhartphoto.com

User avatar
gkaefer
Member
 
Posts: 3355
Joined: Tue Jun 09, 2009 1:01 pm
Location: Salzburg

by gkaefer » Thu Sep 05, 2013 10:04 pm

itsrichphoto wrote:THANKS A lot for the info!

I rebuilt it in a different folder after restarting the computer so that shouldn't have been the issue. With that export, it still worked locally, but not from the dvd.

I just made a mini tour with the missing files and exported that project, then changed the folder names to match. That worked! It still doesnt explain what is going on and why though. It has to be ptp being emotional...

have a look into flash and its security settings. Access to drives must be granted once on any pc. so sending aa tour on dvd to a client is no good idea.
even if this security dilemma is solved - not all features in ptp 1.8 will work because an execution on an available webserver is required. that is not kolor we can blame for that, its the limitations of the code parts like javascript, jquery and others.
In ptp 2.0 an embedded webserver is built in to make it possible to view tours locally. far more plugins are dependant on a webserver in ptp2.
so delivery of the tour on dvd to a client is only for trnasport, it than must be placed on a webserver...

Georg
Last edited by gkaefer on Thu Sep 05, 2013 10:04 pm, edited 1 time in total.

no avatar
itsrichphoto
Member
 
Posts: 61
Joined: Thu Apr 18, 2013 10:56 pm
Location: OC, California

by itsrichphoto » Fri Sep 06, 2013 12:10 am

gkaefer wrote:
itsrichphoto wrote:THANKS A lot for the info!

I rebuilt it in a different folder after restarting the computer so that shouldn't have been the issue. With that export, it still worked locally, but not from the dvd.

I just made a mini tour with the missing files and exported that project, then changed the folder names to match. That worked! It still doesnt explain what is going on and why though. It has to be ptp being emotional...

have a look into flash and its security settings. Access to drives must be granted once on any pc. so sending aa tour on dvd to a client is no good idea.
even if this security dilemma is solved - not all features in ptp 1.8 will work because an execution on an available webserver is required. that is not kolor we can blame for that, its the limitations of the code parts like javascript, jquery and others.
In ptp 2.0 an embedded webserver is built in to make it possible to view tours locally. far more plugins are dependant on a webserver in ptp2.
so delivery of the tour on dvd to a client is only for trnasport, it than must be placed on a webserver...

Georg

THANKS FOR THE INFO! I hadnt really thought too much about javascript not executing properly!

The real problem though was that the image files in data folder was not being generated. COmpletely illogical.... It wouldnt have worked if local or on a server....
Richard Hart
Commercial and portrait photographer OC California
http://www.richhartphoto.com


Return to Panotour bugs & discussion 1.8

Who is online

Users browsing this forum: No registered users and 1 guest