bug sur Ipad/Iphone depuis ajout code HTML (windows7 +PTPv1.8.0 64)  

Ce forum est entièrement consacré à  Panotour.
Rapport de bugs ainsi que des discussions sur les fonctionnalités.
no avatar
aircamera
Member
 
Posts: 94
Joined: Sat Jul 21, 2012 1:00 pm

bug sur Ipad/Iphone depuis ajout code HTML (windows7 +PTPv1.8.0 64)

by aircamera » Sat Aug 11, 2012 5:47 pm

Bonjour,
Voilà  mon problème :
Ma visite compatible Ipad/Iphone fonctionnait parfaitement sur tout support avant l'ajout de fenêtres HTML. Depuis, elle ne fonctionne que sur PC, les Ipad/Iphone n'affichent qu'un écran noir...
Avez vous une solution à  ce problème ?
La visite est visible à  www.visiteaerienne.com
Merci pour votre aide
Cyril

no avatar
babgon
Member
 
Posts: 52
Joined: Sat Jun 21, 2008 6:15 pm
Location: Colmar, France

by babgon » Mon Aug 13, 2012 10:26 am

bonjour

ton script AC_RunActiveContent.js n'est pas disponible sur ton serveur...
j'ai l'impression qu'il te manque les meta qui informe de la compatiblite avec iOs
meta name="viewport" content="target-densitydpi=device-dpi, width=device-width, initial-scale=1.0, minimum-scale=1.0, maximum-scale=1.0, user-scalable=no"/>
<meta name="apple-mobile-web-app-capable" content="yes"/>
EOS 400D, EF 70-200 f4, EF-S 10-22, Peleng 8mm
Sky-Watcher TD10, Girocam, Autopano Giga et Panotour Pro

no avatar
aircamera
Member
 
Posts: 94
Joined: Sat Jul 21, 2012 1:00 pm

by aircamera » Mon Aug 13, 2012 2:41 pm

babgon wrote:bonjour

ton script AC_RunActiveContent.js n'est pas disponible sur ton serveur... <meta name="apple-mobile-web-app-capable" content="yes"/>

Merci pour ta réponse. Effectivement, il n'y a pas ce fichier AC_RunActiveContent.js
En fait, ce fichier ne me dit rien. Il n'est apparemment pas créé lors de la génération de la visite.
C'est quoi ce fichier ?

no avatar
babgon
Member
 
Posts: 52
Joined: Sat Jun 21, 2008 6:15 pm
Location: Colmar, France

by babgon » Tue Aug 14, 2012 2:41 am

Non à  priori ce n'est pas Kolor qui le génère ...

c'est un script qui a rapport avec les fichiers flash (swf). peut être as tu recopier des vieux bout de code a droite à  gauche ...

Bref : a supprimer : ca ne provient pas de kolor et ca ne sert a rien ...
EOS 400D, EF 70-200 f4, EF-S 10-22, Peleng 8mm
Sky-Watcher TD10, Girocam, Autopano Giga et Panotour Pro

no avatar
babgon
Member
 
Posts: 52
Joined: Sat Jun 21, 2008 6:15 pm
Location: Colmar, France

by babgon » Tue Aug 14, 2012 2:48 am

Ta page n'a que 42 lignes de code xHTML, mais génère 18 erreurs...

le code <style> doit se trouver incluse dans la balise <HEAD>.
tu as choisi le xHTML, il faut donc declarer le doctype :
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN"
"http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="fr" xml:lang="fr">

Bref le code a beaucoup d’incohérence...

En le corrigeant et en rajoutant les 2 méta de mon premier post, est ce que ca avance sur ipad.iphone ?
EOS 400D, EF 70-200 f4, EF-S 10-22, Peleng 8mm
Sky-Watcher TD10, Girocam, Autopano Giga et Panotour Pro

no avatar
aircamera
Member
 
Posts: 94
Joined: Sat Jul 21, 2012 1:00 pm

by aircamera » Sat Jan 05, 2013 12:53 pm

Bonjour,
Après quelques mois, je reviens vers vous car je n'ai toujours pas trouvé la réponse à  mon problème.
Je résume : J'ai une visite virtuelle qui fonctionne bien sur PC comme sur tablette/smartphone.
J'ai ajouté sur PTPv1.8.0 64 des hotspots sur certaines photos qui conduisent non pas à  d'autres photos mais à  de modestes pages HTML apportant du contenu informatif.
Sur PC, tout fonctionne normalement, on peut voir les photos et les pages HTML. exemple : http://www.visiteaerienne.com/ Cliquez sur l'église vous comprendrez...
Or, sur tablettes/smartphone, j'ai un écran noir...
La page d'acceuil de mon site n'a apparemment aucun rapport avec cette erreur car si j'héberge à  nouveau le même projet sans mes petites page HTML, le contenu apparaît sur les iphones/ipad. exemple regardez avec votre ipad : http://www.visiteaerienne.com/mobile/virtualtour.html

Le problème vient donc d'une incompatibilité entre idevice et l'intégration de HTML dans la photo.

Quelqu'un peut-il m'aider ?
Merci infiniment !

no avatar
mediavets
Moderator
 
Posts: 14169
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.

by mediavets » Sat Jan 05, 2013 2:00 pm

I have no French I'm afraid, but here's my response in English; perhaps you can translate.

You have several issues:

1. If you want to build one tour that will display on both Flash-enabled platforms and iDevices you must use one of the HTML template options when building the tour. The HTML file created invokes a script that detects the browser user-agent and loads the appropriate version of the tour, either Flash or HTML/javascript. You can explore this using Safari browser on a desktop/laptop that has Flash-enabled then switching the browser user-agent setting. You may create you own HTML file but must incorporate the relavant code to retain this 'platform-detection' functionality.

2. Polygon hotspots are not supported in iDevice-compatible tours created with PTP 1.8 (krpano does not yet support polygon hotspots). You will find they are replaced by an animated GIF of pulsing circles.
http://krpano.com/docu/html5/#supportedfunctionality

3. It appears that the hotspot Link/HTML feature that uses the krpano Textfield plugin is not supported in iDevice-compatible tours created with PTP 1.8 which uses krpano 1.0.8.14, not the latest krpano 1.0.8.15 which is expected to be incorporated in PTP 2.x.
Last edited by mediavets on Sat Jan 05, 2013 2:25 pm, edited 1 time in total.
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.

no avatar
aircamera
Member
 
Posts: 94
Joined: Sat Jul 21, 2012 1:00 pm

by aircamera » Sat Jan 05, 2013 10:06 pm

Thank you for those informations. When will V2 will be avalaible ?


Return to Panotour bug et discussions 1.8

Who is online

Users browsing this forum: No registered users and 0 guests