Scrambled images - AGAIN!!!  

This forum is fully dedicated to Panotour / Panotour Pro bug reports as well as feature discussion.
no avatar
RickDrew
Member
 
Topic author
Posts: 51
Likes: 0 post
Liked in: 0 post
Joined: Fri Jul 24, 2009 8:32 pm
Info

Scrambled images - AGAIN!!!

by RickDrew » Tue Aug 28, 2012 8:06 am

OK, clean install on a brand new computer, and the same freaking problems. I have a 27 image tour of a three story building. I spent hours arranginf the images by floor and by each room on the floor. Saved the tour, opened it. All the image locations wete totally scrambled, links were moved, some images deleted. This happens EVERY time a tour exceeds several images. I consider this a MAJOR bug. It's been there for the past few releases. WILL THIS EVER GET FIXED? I'm done using PTP until this has been addressed. Countless hours wasted.

Or is PTP designed to just handle a couple of images? I mean, if a 6 core i7 with 64 gig of ram and three 3 gig 7950 radeon cards is not enough for this program, what exactly is? I render HDR stitches in PTgui in 7 seconds.

User avatar
gkaefer
Member
 
Posts: 3549
Likes: 0 post
Liked in: 15 posts
Joined: Tue Jun 09, 2009 1:01 pm
Location: Salzburg
Info

by gkaefer » Tue Aug 28, 2012 9:29 am

when I do remember correct you got asked about how your workflow. ... to find out how it finally is screwing things up on you project.

can it be that lets asume your project does contain 15 panos and you did create the tour to see the current stage of the tour...
... now - panotur is still open - you do add a panorama 16 and 17. what were your next steps in your workflow?

Georg

User avatar
bdd
Kolor Team
 
Posts: 2802
Likes: 14 posts
Liked in: 130 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

by bdd » Tue Aug 28, 2012 9:46 am

Hello,

Panotour Pro can handle much more images than that. Some customers already did some tours with more than 100 images, without having your problem.

Can you send me your project file ? only the *.kpt file in which your panoramas are correctly arranged and ordered. I do not need your images.

Did you moved your images, or renamed them between the moment you closed Panotour Pro and the moment you opened it ?
Did you type "Shift-R" keys on your keyboard after the opening of the tour ?

Gérald

User avatar
klausesser
Member
 
Posts: 8836
Likes: 5 posts
Liked in: 64 posts
Joined: Mon May 22, 2006 12:18 am
Location: Duesseldorf, Germany
Info

by klausesser » Tue Aug 28, 2012 9:52 am

RickDrew wrote:I consider this a MAJOR bug. It's been there for the past few releases. WILL THIS EVER GET FIXED? I'm done using PTP until this has been addressed. Countless hours wasted.

As Georg already mentioned: tell us more about how you do things. Otherwise you wouldn´t get help.

Basically i´d like to state that such a "bug" simply does not exist.

I did tours containing many scenes without ANY issue. I did hires tours-containing 8 - 14 images of high resolution - 700mpx/3GPx.
Also no issue at all. The size of the tours as data is around 1,3GB each of them on the server.

As examples:
http://www.360impressions.de/Sonne_11/
http://www.360impressions.de/KBogen3 (hires)

In none of the cases i experienced what you described. Of course everything depends on the way you handle the application.

best, Klaus
Last edited by klausesser on Tue Aug 28, 2012 9:53 am, edited 1 time in total.
Simplicity is the keynote of all true elegance. Coco Chanel

no avatar
RickDrew
Member
 
Topic author
Posts: 51
Likes: 0 post
Liked in: 0 post
Joined: Fri Jul 24, 2009 8:32 pm
Info

by RickDrew » Tue Aug 28, 2012 7:55 pm

As for SUE, I've been a programmer for 25 years. I've been using panoramic software, and some version of Panotour since it first came out. The problem is consitant. There is nothing in my workflow to cause it. I simply open a tour, add a couple of links or fix a typo, regenerate, save and close. Open it a day later - the links, images and screen arder are trashed. Quit without saving - open again. Still trashed. So the problem obviously occured on the previous save. Simply changing the spelling of one word and saving the tour, then opening it the next day causes the problem.

This happens randomly, but it eventually happens on EVERY tour wth more than a dozen or so images. EVERY time. On different computers, different tours, different numbers of images. Different workflows. It ALWAYS happens after the file has been opened, modified and saved several times. I don't just make a tour and move on. I have several tours that are ongoing projects. Some I add images to every few weeks and regenerate. Others I just fix a typo or add a new link between images. Often I'll open an older tour and add a map or one new image. There is no set pattern, except that the tour has been edited/modified numerous times and has more than a dozen or so panoramic images.

I have even gone as far as creating an entire tour from scratch, only to have t happen again after several edits.

My workflow? Add the images. Add some links. Save the tour, quit. Open the next day. Add more images. Add a dropdown, rearrange the file order, finalize the links, fix any typos or unclear image titles. Save, quit. Open the next day, add a map and GPS data, fix the radar position, double check links, maybe add another one. Save, generate, quit. A week later, open, fix any bad links the customer or I noticed after detailed use, fix any typos, save, regenerate. Repeat as needed. Open. Looking at a trashed file. Feel free to change the order of any step. The last one wil eventually be a trashed file. At a minimum the images are rearranged on the screen with no bad data. Worse case, images are missing, images have been swapped, all have been rearranged. Links are scrabbled. Just simply opening, making a minor change, and opening again can cause the problem. I have lost count of the number of times this has happened.

I spent several hours fixing this latest trashed tour. After several more edits over the past day, it happened again. This time all the images were rearranged, but the links were OK. I'm not going to waste my time and try and fix it again, and Im going to stop working on this project until the next release. Picture a tour on three floors, plus a basement. All the images arranged visually on the screen so I can quickly see each floor and the basic layout. Then opening the project the next time and having everything randomly shifted. Quit immediately, no changes no save. Open again. Same problem. As I said earlier, it's obviously occuring on the save, not the open.

User avatar
gkaefer
Member
 
Posts: 3549
Likes: 0 post
Liked in: 15 posts
Joined: Tue Jun 09, 2009 1:01 pm
Location: Salzburg
Info

by gkaefer » Wed Aug 29, 2012 12:11 am

RickDrew wrote:(...) I simply open a tour, add a couple of links or fix a typo, regenerate, save and close. Open it a day later - the links, images and screen arder are trashed. (...)

important here is how you save/regenerate it. also in your description of your workflow the "regenerate" can be done in two ways:

1. build tour - with "delete all existing files before saving" disabled
2. build tour - with "delete all existing files before saving" enabled

if 1. used it explains your result. (*)
if 2. used its a bug (or I do not see it either....)

additional I did start to use the "build as" instead and allways using new subdirectories for each version of my pano/tour I create...
and in each of thos diretories I save the panotour project file so they cant be overwritten by accident...

(*) it does have to do hwo panotour does name the files fitting to each pano. if an order of the pano is changed by adding, deleting panos, hotspots etc. the index gets adopted but the no longer fitting images are saved on disc from last build the mess is perfect.

Georg
Last edited by gkaefer on Wed Aug 29, 2012 12:13 am, edited 1 time in total.

User avatar
klausesser
Member
 
Posts: 8836
Likes: 5 posts
Liked in: 64 posts
Joined: Mon May 22, 2006 12:18 am
Location: Duesseldorf, Germany
Info

by klausesser » Wed Aug 29, 2012 12:29 am

Rick - I guess Georg has the point. Check the way the saving work.

Beides of that: delete and re-install the app - delete ALL connected files. Prefs and so before re-installing.
Look whether older versions are on your disk (shouldn´t be a issue at all, but . . )

best, Klaus
Simplicity is the keynote of all true elegance. Coco Chanel

User avatar
gkaefer
Member
 
Posts: 3549
Likes: 0 post
Liked in: 15 posts
Joined: Tue Jun 09, 2009 1:01 pm
Location: Salzburg
Info

by gkaefer » Wed Aug 29, 2012 10:09 am

Hi Ed,

" (...) Wow, am I wrong here or does that sound counterintuitive (...)"

this topic was on forum in past. If I remember well panotour 2 should change this / solve this behavior. in current ptp you can ener a tourname as filename during saving dialog. so each pano is getting the same name plus an increasing number assigned, so finally pano1.xml, pano2.xml etc. are created. same with hotspots inside the config files. if you now change something in the tour and save the tour project file but do not recreate your tour with overwriting all existing files, only new files will be added... old files with old index and new files with new index are mixed... so allways using fresh empty directories where to build the tour to and your're on the save side.

Im not sure with Ricks post and description of his workflow: is this mess only in the exported/created tour or is this mess also with this workflow?:

designing tour in panotour.
saving panotour project file
closing panotour. days later:
opening panotour and adding / changing somethin in the tour
saving the panotour project file again (same file, same name)
closing panotour
opning panotour, opening the project file: scrambled result

if this is the case, than my description of naming & rebuilding a tour cant be the reason...
Georg


Who is online

Users browsing this forum: No registered users and 0 guests

cron