Version 3.0 problems  

Share your tips, tricks or get help with using GoPro VR Player!
no avatar
WayneBG
Member
 
Topic author
Posts: 36
Likes: 7 posts
Liked in: 3 posts
Joined: Thu Apr 20, 2017 11:17 pm
Info

Version 3.0 problems

by WayneBG » Sun Oct 29, 2017 6:25 am

Windows 7, 64 bit computer, default VR player settings:

VR player cannot display 3D 360 videos properly---jerky, frozen & distorted frames.

VR player can display 2D 360 videos, but the ambisonic audio decoding is wrong. Does it decode the ambix ACN/SN3D format used by YouTube? The audio doesn't have any variation when rotated horizontally, only vertically. (The same video works fine on YouTube.)

I tried the Windows Media Foundation decoding, but it crashed when I loaded a 3D 360 video complaining of a missing codec.

User avatar
benji33
Kolor Team
 
Posts: 5456
Likes: 59 posts
Liked in: 167 posts
Joined: Tue Apr 09, 2013 10:59 am
Location: France
Info

Re: Version 3.0 problems

by benji33 » Mon Oct 30, 2017 4:00 pm

Thanks for this report about the 3.0 release.

For 360 rendering, it depends of the ability of your computer to make the hardware accelerated video decoding.
What is your graphics card?

Is it possible to have your video file only for testing purpose?
Yes it's the ACN/SN3D format used by Google/YouTube, only with the VLC video backend.

WMF crashed with your video file or just inform you about the missing codec?

no avatar
WayneBG
Member
 
Topic author
Posts: 36
Likes: 7 posts
Liked in: 3 posts
Joined: Thu Apr 20, 2017 11:17 pm
Info

Re: Version 3.0 problems

by WayneBG » Mon Oct 30, 2017 5:41 pm

As I recall, WMF just triggered an error message...but I don't have time to double check that now.

My display adapter is a NVIDIA GeForce GTX660 Ti.

Here are YT links to the 2D and 3D versions of the video I was testing. I can upload them later if the YT link isn't sufficient for your purposes:

2D:

https://youtu.be/1cr_tcBus14

3D:

https://youtu.be/dxDj6lVAqnU

User avatar
benji33
Kolor Team
 
Posts: 5456
Likes: 59 posts
Liked in: 167 posts
Joined: Tue Apr 09, 2013 10:59 am
Location: France
Info

Re: Version 3.0 problems

by benji33 » Thu Nov 02, 2017 10:52 am

Yes we need a true download link. but the YT version is nice for comparison :)

For WMF it can be the case depending of the video and audio codec. I need the files to verify what is wrong.

no avatar
WayneBG
Member
 
Topic author
Posts: 36
Likes: 7 posts
Liked in: 3 posts
Joined: Thu Apr 20, 2017 11:17 pm
Info

Re: Version 3.0 problems

by WayneBG » Thu Nov 02, 2017 7:50 pm

They are too large to upload here. I have uploaded them to Google Drive and sent you a PM with the link.

benji33 likes this post.

User avatar
benji33
Kolor Team
 
Posts: 5456
Likes: 59 posts
Liked in: 167 posts
Joined: Tue Apr 09, 2013 10:59 am
Location: France
Info

Re: Version 3.0 problems

by benji33 » Fri Nov 03, 2017 5:31 pm

VR player cannot display 3D 360 videos properly---jerky, frozen & distorted frames.
Status: The same on my W10 + NVIDIA GT 640. Not enough power on my side for this size of content on full hardware accelerated video decoding.

VR player can display 2D 360 videos, but the ambisonic audio decoding is wrong. Does it decode the ambix ACN/SN3D format used by YouTube? The audio doesn't have any variation when rotated horizontally, only vertically. (The same video works fine on YouTube.)
Status: The same, I'll have a look.

no avatar
totaln00b
New member
 
Posts: 6
Likes: 0 post
Liked in: 0 post
Joined: Sat Nov 04, 2017 1:49 am
Info

Re: Version 3.0 problems

by totaln00b » Sat Nov 04, 2017 2:06 am

I am having the same issues, my computer has two Nvidia Graphics cards (a Titan X (Pascal) and a Titan Xp) and the videos that I am trying to play are less than a minute long. GoPro VR Player won't even load into my Oculus Rift. I have tried to uninstall version 3.0 and reinstall gopro vr player 2.3 to see if that would resolve the issue, it has not. I have an Editor waiting to work on these videos while using the Oculus and this bug has caused us many issues. Please respond if you have any questions about my Technical specifications. (Windows 10, 64 bit OS. (a Titan X (Pascal) and a Titan Xp) 32 gb RAM, Processor= Intel(R) Core(TM) i7-6900KCPU @ 3.20 GHz 3.20 GHz

User avatar
benji33
Kolor Team
 
Posts: 5456
Likes: 59 posts
Liked in: 167 posts
Joined: Tue Apr 09, 2013 10:59 am
Location: France
Info

Re: Version 3.0 problems

by benji33 » Mon Nov 06, 2017 11:43 am

Hi totaln00b,
Yes it's a known issue with 2 graphical cards. This bug is not solved yet.
It should work with only one graphical card.

no avatar
WayneBG
Member
 
Topic author
Posts: 36
Likes: 7 posts
Liked in: 3 posts
Joined: Thu Apr 20, 2017 11:17 pm
Info

Re: Version 3.0 problems

by WayneBG » Mon Nov 06, 2017 6:22 pm

The previous version (2.3) can display the videos fine (without ambisonic audio).

no avatar
totaln00b
New member
 
Posts: 6
Likes: 0 post
Liked in: 0 post
Joined: Sat Nov 04, 2017 1:49 am
Info

Re: Version 3.0 problems

by totaln00b » Mon Nov 06, 2017 7:52 pm

Thank you Wayne, I actually tried uninstalling v 3.0 and reinstalling an older version (because yes it did play the videos flawlessly.) Unfortunately, whatever messed up v 3.0 stuck around when I reinstalled 2.3. =( Benji, if it is a known bug, could you at least tell me how to get 2.3 working again? I need to be able to reference these shots so that I can meet my deadline.

no avatar
WayneBG
Member
 
Topic author
Posts: 36
Likes: 7 posts
Liked in: 3 posts
Joined: Thu Apr 20, 2017 11:17 pm
Info

Re: Version 3.0 problems

by WayneBG » Mon Nov 06, 2017 9:23 pm

Bummer, I just left 2.3 in place when I installed 3.0...heck, I still have and use the old Kolor player.

User avatar
benji33
Kolor Team
 
Posts: 5456
Likes: 59 posts
Liked in: 167 posts
Joined: Tue Apr 09, 2013 10:59 am
Location: France
Info

Re: Version 3.0 problems

by benji33 » Tue Nov 07, 2017 10:14 am

@totaln00b
The 2.3.1 has the same issue with Oculus when working with 2 GPUs. I've no ETA date for it yet. All I can said: it's not the first prioritized bug into our referenced issues but it's one of the first to deal with into the next months.

As @WayneBG said you can have 2.3 and 3.0 working on the same computer. All "X.X" versions can be added without any removal.

@WayneBG I'll have a look on the ambisonics issue ASAP.

no avatar
totaln00b
New member
 
Posts: 6
Likes: 0 post
Liked in: 0 post
Joined: Sat Nov 04, 2017 1:49 am
Info

Re: Version 3.0 problems

by totaln00b » Wed Nov 08, 2017 7:50 pm

Yeah, I have 3.0 completely uninstalled. Version 2.3 is installed, but whatever the glitch is, it has caused 2.3 to do the exact same thing that 3.0 was doing. Once again, I don't know if this description helps you out or not but here it is, GoPro VR Player will not load into the Oculus Rift, this coincides with the GoPro player itself not allowing me to move the view around (look to the left, look to the right, behind you etc...) I have tried updating all of my drivers, all Windows updates, (I was trying to use it with premiere, updated that, didn't work.) This has also caused the standard windows vr player to stop working as well. Please let me know what this could be.

no avatar
WayneBG
Member
 
Topic author
Posts: 36
Likes: 7 posts
Liked in: 3 posts
Joined: Thu Apr 20, 2017 11:17 pm
Info

Re: Version 3.0 problems

by WayneBG » Thu Nov 09, 2017 10:53 pm

Does the 3.0.1 release address any of these problems?

no avatar
totaln00b
New member
 
Posts: 6
Likes: 0 post
Liked in: 0 post
Joined: Sat Nov 04, 2017 1:49 am
Info

Re: Version 3.0 problems

by totaln00b » Wed Nov 15, 2017 1:08 am

I just attempted to install 3.0.1 and it did not fix any of the problems :'( I have now found out that this glitch has caused other problems with other vr players that i have tried to replace it with. @benji33 I don't know if that information helps you guys figure out what this issue is, but there it is. please help.

User avatar
benji33
Kolor Team
 
Posts: 5456
Likes: 59 posts
Liked in: 167 posts
Joined: Tue Apr 09, 2013 10:59 am
Location: France
Info

Re: Version 3.0 problems

by benji33 » Thu Nov 16, 2017 2:04 pm

@totaln00b I don't see the relation between GoPro VR Player and issue into the standard windows vr player.
GoPro VR Player is executed into it's own context.
If 2.3 as the same issue, it can be linked to video drivers update or a specific windows update.
Is it with H.264 content or H.265 or other ?

@WayneBG
3.0.1 address the CineForm codec problem and solve some minor issues. It's a minor revision.
Not found yet the issue with the ambisonics for information.

no avatar
WayneBG
Member
 
Topic author
Posts: 36
Likes: 7 posts
Liked in: 3 posts
Joined: Thu Apr 20, 2017 11:17 pm
Info

Re: Version 3.0 problems

by WayneBG » Mon Dec 04, 2017 8:52 am

Any update? It doesn't appear either of the problems I reported have been addressed.

no avatar
totaln00b
New member
 
Posts: 6
Likes: 0 post
Liked in: 0 post
Joined: Sat Nov 04, 2017 1:49 am
Info

Re: Version 3.0 problems

by totaln00b » Mon Dec 04, 2017 11:26 pm

I actually was able to reinstall all of my oculus software, run a prior version of gopro vr player, like i've done 4 times prior, and for some reason, it works now :-/ I mean, i'm happy kinda i guess...


Who is online

Users browsing this forum: No registered users and 1 guest