Jerky 360 video  

Share your tips, tricks or get help with using GoPro VR Player!
no avatar
Samuel
New member
 
Topic author
Posts: 4
Likes: 0 post
Liked in: 0 post
Joined: Thu Jan 18, 2018 7:27 am
Info

Jerky 360 video

by Samuel » Thu Jan 18, 2018 7:45 am

Hi,

When I watch 360 videos with the GoPro VR Player version 3.0.2 with Oculus rift, the video is jerky when I turn my head. It works fine when viewed on the computer screen, only when watched with the Oculus rift headset this issue happens.

I am using a core i7-7700HQ CPU@2.80GHz, RAM 16GB, NVIDIA GeForce GTX 1060.

I tried watching the same video on other players on the Rift, they work fine. I hope i can resolve this as I like using the Gopro VR player for its convenience for switching between platforms, like VR headsets (HTC, Oculus) and the computer screen. I do quite some photo/video editing.

If you need more info, please feel free to let me know.
thanks.

Regards,
Samuel

User avatar
lmartin
Kolor Team
 
Posts: 245
Likes: 0 post
Liked in: 9 posts
Joined: Mon Jul 01, 2013 8:04 am
Info

Re: Jerky 360 video

by lmartin » Mon Jan 22, 2018 9:27 am

What is the value of "hmd fps" ? (Menu > Window > Show debug informations)

If you pause the video, does it remove the jerky effect when you turn your head in the Oculus ?

no avatar
Samuel
New member
 
Topic author
Posts: 4
Likes: 0 post
Liked in: 0 post
Joined: Thu Jan 18, 2018 7:27 am
Info

Re: Jerky 360 video

by Samuel » Tue Jan 23, 2018 11:12 am

Thanks for the reply.

hmd fps while playing the video range from: 51 to 61

If I pause the video and turn my head in Oculus the Jerky effect does NOT occur, Jerky effect is removed.

User avatar
lmartin
Kolor Team
 
Posts: 245
Likes: 0 post
Liked in: 9 posts
Joined: Mon Jul 01, 2013 8:04 am
Info

Re: Jerky 360 video

by lmartin » Thu Jan 25, 2018 9:30 am

Ok thanks, try the following things :
- ensure that your Oculus stuff is up to date, in particular Oculus driver, check settings in Oculus app.
- switch video decoding to WMF, Menu > Settings > Video decoding

If it does not help, it means that GoPro VR Player does not have enough GPU resources to process well.
What is the properties of your video (codec, resolution, framerate, bitrate) ?

no avatar
Samuel
New member
 
Topic author
Posts: 4
Likes: 0 post
Liked in: 0 post
Joined: Thu Jan 18, 2018 7:27 am
Info

Re: Jerky 360 video

by Samuel » Mon Jan 29, 2018 3:54 am

I have checked that Oculus is up to date and switched video decoding to WMF.
But still the same, no improvement.

How to make sure GoPro VR player gets enough GPU?
Here are the links to the video for your perusal:
https://www.dropbox.com/s/ilu7njlkjeful ... 0.mp4?dl=0
The resolution is 8k, bitrate 51133kbps, frame rate 30 frame/sec,

User avatar
lmartin
Kolor Team
 
Posts: 245
Likes: 0 post
Liked in: 9 posts
Joined: Mon Jul 01, 2013 8:04 am
Info

Re: Jerky 360 video

by lmartin » Tue Jan 30, 2018 11:02 am

Thanks,
I reproduced the same issue with my NVidia 970GTX, 8K is very huge and I think this is the problem here.
You can try to decrease the bitrate or the resolution of your video.
Or you can also try with another codec than H.264, try Cineform for example because decoding will be using only the CPU (you will need a strong CPU to decode 8K).

no avatar
Samuel
New member
 
Topic author
Posts: 4
Likes: 0 post
Liked in: 0 post
Joined: Thu Jan 18, 2018 7:27 am
Info

Re: Jerky 360 video

by Samuel » Wed Jan 31, 2018 12:05 pm

Noted, I will try that. Thank you very much for your assistance.


Who is online

Users browsing this forum: No registered users and 1 guest