Page 1 of 1

Performance Problem

PostPosted: Mon Jul 02, 2018 10:35 am
by Ramona86
Dear Kolor Team,
your software is by far the best and we love it.
I have a question about a VR Tour.

https://s3.eu-central-1.amazonaws.com/3 ... glhof.html

The tour here has 8-10 seconds to wait for a picture view.
Could you help me with that or what I can do?

I've already looked at Chrome Dev tools but it has to be in the program internally I think.

I thank you very much and wish a sunny week.

Lovely regards

Re: Performance Problem

PostPosted: Mon Jul 02, 2018 10:56 am
by bdd
By "picture view", are you talking about a "scene" or a picture displayed after a click on a spot ?

I checked your tour, and each scenes were displayed faster than 8 seconds .
And every gallery I checked was displayed quickly too.

Gérald

Re: Performance Problem

PostPosted: Mon Jul 02, 2018 1:11 pm
by Ramona86
Hi Gérald,
I meant the first load of the tour. If the cache is empty and you load for the first time, then you have a long black screen. The rest is great. Only the beginning is much longer on this tour.

Re: Performance Problem

PostPosted: Tue Jul 31, 2018 9:54 am
by benji33
It depends of the amount of data to load on start. There is also a sound file which can take time to load.

Re: Performance Problem

PostPosted: Mon Aug 06, 2018 4:24 pm
by Ramona86
Hi Benjamin,
thank you for your reply. Normally the tours are very fast. Only that with a long latenz in the first time.
Without sound too.

When I look at Chrome Dev Tools, it looks like the plugins come first and then the view are coming.

Are there any different hooks here maybe? Can it be that a plugin use a wrong hook, a too early hook and blocks the application? It looks at the Ajax request so.

Or does that come from the number of panoramas?

Many thanks for your help.
Moni

Re: Performance Problem

PostPosted: Tue Aug 07, 2018 2:56 pm
by benji33
I've tried the tour with developer console opened and the preview (first image of the first scene) is loaded after more than 3 seconds.
Where is located your AWS server? Is it replicated in different locations? Are you using CloudFront to store assets into a server cache?
The delay seems normal and depends of the bandwidth and server location and cache. If you're using S3 alone the connection take "time" on each file request.

Re: Performance Problem

PostPosted: Tue Aug 07, 2018 4:38 pm
by Ramona86
I'll check it. Have many thanks.
Greeting Moni