Performance Problem  

This forum is fully dedicated to Panotour / Panotour Pro bug reports as well as feature discussion.
no avatar
Ramona86
New member
 
Topic author
Posts: 9
Likes: 1 post
Liked in: 0 post
Joined: Tue Mar 20, 2018 10:36 am
Info

Performance Problem

by Ramona86 » Mon Jul 02, 2018 10:35 am

Dear Kolor Team,
your software is by far the best and we love it.
I have a question about a VR Tour.

https://s3.eu-central-1.amazonaws.com/3 ... glhof.html

The tour here has 8-10 seconds to wait for a picture view.
Could you help me with that or what I can do?

I've already looked at Chrome Dev tools but it has to be in the program internally I think.

I thank you very much and wish a sunny week.

Lovely regards

User avatar
bdd
Kolor Team
 
Posts: 2802
Likes: 14 posts
Liked in: 130 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

Re: Performance Problem

by bdd » Mon Jul 02, 2018 10:56 am

By "picture view", are you talking about a "scene" or a picture displayed after a click on a spot ?

I checked your tour, and each scenes were displayed faster than 8 seconds .
And every gallery I checked was displayed quickly too.

Gérald

no avatar
Ramona86
New member
 
Topic author
Posts: 9
Likes: 1 post
Liked in: 0 post
Joined: Tue Mar 20, 2018 10:36 am
Info

Re: Performance Problem

by Ramona86 » Mon Jul 02, 2018 1:11 pm

Hi Gérald,
I meant the first load of the tour. If the cache is empty and you load for the first time, then you have a long black screen. The rest is great. Only the beginning is much longer on this tour.

no avatar
benji33
Kolor Team
 
Posts: 5848
Likes: 92 posts
Liked in: 199 posts
Joined: Tue Apr 09, 2013 10:59 am
Location: France
Info

Re: Performance Problem

by benji33 » Tue Jul 31, 2018 9:54 am

It depends of the amount of data to load on start. There is also a sound file which can take time to load.
Benjamin

no avatar
Ramona86
New member
 
Topic author
Posts: 9
Likes: 1 post
Liked in: 0 post
Joined: Tue Mar 20, 2018 10:36 am
Info

Re: Performance Problem

by Ramona86 » Mon Aug 06, 2018 4:24 pm

Hi Benjamin,
thank you for your reply. Normally the tours are very fast. Only that with a long latenz in the first time.
Without sound too.

When I look at Chrome Dev Tools, it looks like the plugins come first and then the view are coming.

Are there any different hooks here maybe? Can it be that a plugin use a wrong hook, a too early hook and blocks the application? It looks at the Ajax request so.

Or does that come from the number of panoramas?

Many thanks for your help.
Moni

no avatar
benji33
Kolor Team
 
Posts: 5848
Likes: 92 posts
Liked in: 199 posts
Joined: Tue Apr 09, 2013 10:59 am
Location: France
Info

Re: Performance Problem

by benji33 » Tue Aug 07, 2018 2:56 pm

I've tried the tour with developer console opened and the preview (first image of the first scene) is loaded after more than 3 seconds.
Where is located your AWS server? Is it replicated in different locations? Are you using CloudFront to store assets into a server cache?
The delay seems normal and depends of the bandwidth and server location and cache. If you're using S3 alone the connection take "time" on each file request.
Benjamin

no avatar
Ramona86
New member
 
Topic author
Posts: 9
Likes: 1 post
Liked in: 0 post
Joined: Tue Mar 20, 2018 10:36 am
Info

Re: Performance Problem

by Ramona86 » Tue Aug 07, 2018 4:38 pm

I'll check it. Have many thanks.
Greeting Moni


Who is online

Users browsing this forum: No registered users and 2 guests

cron