Page 1 of 1

ZOOM IN ACTION do not work!!

PostPosted: Thu Nov 23, 2017 6:36 pm
by Ugo Visciani
Hi everybody,
I create a poligonal hotspot an I set a zoom action to it. I want that when I click on this spot it zoom to a specific FOV!! (because on this fov there are coming out others hotspots, and I want to make those visible) There are two options: 1) One step (it works but the zoom is not enough) 2)Destination Fov
When it is seted to destination fov it do not work. How can I let it work??

Is there a way to set the tooltip of polygonal hotspot always visible??

thanks
Ugo :)

Re: ZOOM IN ACTION do not work!!

PostPosted: Fri Nov 24, 2017 11:25 am
by Annis
What is the max zoom of your scene? If you're trying to zoom in further than the max zoom the action will not work.

Have you thought of using the Go to panorama action with the move to custom view transition instead? http://www.kolor.com/wiki-en/action/vie ... ustom_View

You will still be restricted by your scene's zoom limits.

Re: ZOOM IN ACTION do not work!!

PostPosted: Fri Nov 24, 2017 11:49 am
by Ugo Visciani
I tried to use this transition but I can not see the VIEW!!!

best
Ugo

Re: ZOOM IN ACTION do not work!!

PostPosted: Fri Nov 24, 2017 12:29 pm
by Annis
Ah. Is this a planar or spherical scene?

Try unchecking "Limiti risoluzione immagine" ?

Re: ZOOM IN ACTION do not work!!

PostPosted: Fri Nov 24, 2017 2:27 pm
by Ugo Visciani
this is a planar image...Gigapixel!!
No way also with "limit the size resolution" unchecked!

Maybe is there a way to create a custom transition for example modifying the zoom in transition to a wanted fov??

Re: ZOOM IN ACTION do not work!!

PostPosted: Fri Nov 24, 2017 3:34 pm
by Annis
Hm yes it should be possible to create such a transition. That would probably be the way to do what you're looking to do.


The zoom in action won't work because you're on a planar image, so the fov for the planar image is between 1° and 0.x, so you're trying to go to 29° which isn't compatible with a planar image. So this would be why the action isn't working for you.

Re: ZOOM IN ACTION do not work!!

PostPosted: Fri Nov 24, 2017 3:51 pm
by Ugo Visciani
Ok I understand...mhh and how can I create this "special" transition ??

Re: ZOOM IN ACTION do not work!!

PostPosted: Fri Nov 24, 2017 5:27 pm
by Annis
Copy one of the existing ones from the templates folder to the user directory and modify the parameters. You'll need to know krpano to know what to do though, it's beyond my skills unfortunately.

Re: ZOOM IN ACTION do not work!!

PostPosted: Fri Nov 24, 2017 5:46 pm
by Ugo Visciani
Ok thanks...maybe you know somebody that have this skills??

Re: ZOOM IN ACTION do not work!!

PostPosted: Fri Nov 24, 2017 10:55 pm
by 360-compunics-com-ni
You can zoom in/out of a planar pano as well, only the PTP GUI does not allow to input values smaller than "1".
So using the "Call Custom Code"-action you can assign this function to your polygon hotspot:
Code: Select all
looktohotspot(get(name), 0.35, tween(linear,2.0) );

"0.35" is the FOV in this example, and "2.0" is the time for the "lookto/zoom"-action, adjust those values as needed.