Disable zoom on floor plan  

This forum is fully dedicated to Panotour / Panotour Pro bug reports as well as feature discussion.
User avatar
Peter987
Member
 
Topic author
Posts: 39
Likes: 1 post
Liked in: 9 posts
Joined: Mon Oct 14, 2013 5:42 pm
Location: Belgium
Info

Disable zoom on floor plan

by Peter987 » Thu Jun 22, 2017 7:27 pm

We just finished a huge project, a virtual tour which is on display in a museum on a large touch screen.

On the first day of public display, we already ran into a serious show-stopping issue as users not only love to zoom into our 360˚ images, but also when a floor plan is activated.

When a user zooms in when the floor plan is displayed, the entire web page becomes zoomable (same zoom effect as COMMAND/CTRL+), resulting in missing UI and a too large displayed panoramic image. The 'devastation' can't be reversed the moment a user closes the floor plan (by clicking a map spot). There is no way for a user or for us to reset this wrong zoom-level, as keyboards are disabled for this interactive touch screen display. The UI is also missing, else we could have added a javascript powered reset button as a workaround.

To us, this is a serious bug, as it cripples the entire virtual tour.

When displaying a pano the browser won't zoom the entire page (just the pano, gui-elements stay in place), this behavior should stay the same when a floor plan is activated.

How can we fix or avoid this unwanted behavior?

This is a rather urgent request...
Little Planet - We turn your world 360˚ around!

Follow our 360˚ adventures on:
facebook.com/littleplanet.be
instagram.com/littleplanet.be
www.littleplanet.be

User avatar
Annis
Kolor Team
 
Posts: 6063
Likes: 801 posts
Liked in: 444 posts
Joined: Mon Aug 12, 2013 12:47 pm
Location: France
Info

Re: Disable zoom on floor plan

by Annis » Fri Jun 23, 2017 8:29 am

The floorplan is an HTML5 plugin that displays above the tour, so if you zoom into the floorplan, because there is no zoom for the floorplan you are acting on the page, not the tour.

I don't now if it's possible to block this zoom from happening but I will still file it as a bug just in case.

As a workaround, if you aren't using radars on your floorplan, you could create a planar scene that is your floorplan, with your spots and information. Since it'll be in the tour you won't have the browser zoom issue.

User avatar
Peter987
Member
 
Topic author
Posts: 39
Likes: 1 post
Liked in: 9 posts
Joined: Mon Oct 14, 2013 5:42 pm
Location: Belgium
Info

Re: Disable zoom on floor plan

by Peter987 » Fri Jun 23, 2017 9:46 am

Thanks for your response Annis.

Converting our floorplan to a planar scene is not an option for us, as it would replace the current pano instead of displaying the floorplan transparant on top of it.

There must be something in the KRpano/Panotour code which disables this zoom function when displaying just a pano, so I'm wondering how we can leverage this piece of code on the HTML5 content. How/where/why is this functionality suddenly being disabled when displaying html5 content, and active again when the html5 content is closed?
Little Planet - We turn your world 360˚ around!

Follow our 360˚ adventures on:
facebook.com/littleplanet.be
instagram.com/littleplanet.be
www.littleplanet.be

User avatar
Annis
Kolor Team
 
Posts: 6063
Likes: 801 posts
Liked in: 444 posts
Joined: Mon Aug 12, 2013 12:47 pm
Location: France
Info

Re: Disable zoom on floor plan

by Annis » Fri Jun 23, 2017 11:22 am

Can you show me your floorplan's settings?
Or share an online link (via PM)?

User avatar
Peter987
Member
 
Topic author
Posts: 39
Likes: 1 post
Liked in: 9 posts
Joined: Mon Oct 14, 2013 5:42 pm
Location: Belgium
Info

Re: Disable zoom on floor plan

by Peter987 » Fri Jun 23, 2017 11:24 am

Annis, I'll send you a PM right now...
Little Planet - We turn your world 360˚ around!

Follow our 360˚ adventures on:
facebook.com/littleplanet.be
instagram.com/littleplanet.be
www.littleplanet.be

User avatar
Annis
Kolor Team
 
Posts: 6063
Likes: 801 posts
Liked in: 444 posts
Joined: Mon Aug 12, 2013 12:47 pm
Location: France
Info

Re: Disable zoom on floor plan

by Annis » Fri Jun 23, 2017 3:25 pm

Thanks for the link (beautiful tour by the way).

I've done some research, and it looks like the issue is localised to iOS 10+ devices with the OS specifically disabling and ignoring the parameter that stops users from being able to zoom into the pages like that.

This affects all the HTML5 plugins of PTP because they're are HTML elements above the tour, not inside it. They aren't KrPano plugins.

I've submitted the bug but I unfortunately do not have a workaround for you.

User avatar
Peter987
Member
 
Topic author
Posts: 39
Likes: 1 post
Liked in: 9 posts
Joined: Mon Oct 14, 2013 5:42 pm
Location: Belgium
Info

Re: Disable zoom on floor plan

by Peter987 » Fri Jun 23, 2017 5:19 pm

Annis,

This isn't an iOS bug only. I experience the same issue on MacOS Sierra (tried on a MacBook Pro, while pinch-zooming on the trackpad), and the museum installation runs on Windows 10. The museum app runs in Google Chrome, but I see the same issue also happening in Safari on Mac.

So it's not just iOS...
Little Planet - We turn your world 360˚ around!

Follow our 360˚ adventures on:
facebook.com/littleplanet.be
instagram.com/littleplanet.be
www.littleplanet.be

User avatar
Annis
Kolor Team
 
Posts: 6063
Likes: 801 posts
Liked in: 444 posts
Joined: Mon Aug 12, 2013 12:47 pm
Location: France
Info

Re: Disable zoom on floor plan

by Annis » Mon Jun 26, 2017 10:08 am

I see, I will add that to the report then. Thank you for the information.

It looks like the issue is more widespread than just iOS ignoring the user-scalable=no tag.

User avatar
Peter987
Member
 
Topic author
Posts: 39
Likes: 1 post
Liked in: 9 posts
Joined: Mon Oct 14, 2013 5:42 pm
Location: Belgium
Info

Re: Disable zoom on floor plan

by Peter987 » Mon Jun 26, 2017 10:19 am

Thank you Annis.

I hope this bug will be considered as critical, as it breaks the navigation of a virtual tour on all touchscreen computers/devices, the moment a user is pinch-zooming on HTML5 plugin content.
Little Planet - We turn your world 360˚ around!

Follow our 360˚ adventures on:
facebook.com/littleplanet.be
instagram.com/littleplanet.be
www.littleplanet.be

User avatar
Peter987
Member
 
Topic author
Posts: 39
Likes: 1 post
Liked in: 9 posts
Joined: Mon Oct 14, 2013 5:42 pm
Location: Belgium
Info

Re: Disable zoom on floor plan

by Peter987 » Wed Jun 28, 2017 8:20 pm

Too bad that this bug wasn't fixed yet in the latest 2.5.8 release. I guess I will have to wait a long time now for a solution.
Little Planet - We turn your world 360˚ around!

Follow our 360˚ adventures on:
facebook.com/littleplanet.be
instagram.com/littleplanet.be
www.littleplanet.be

User avatar
Peter987
Member
 
Topic author
Posts: 39
Likes: 1 post
Liked in: 9 posts
Joined: Mon Oct 14, 2013 5:42 pm
Location: Belgium
Info

Re: Disable zoom on floor plan

by Peter987 » Thu Jan 18, 2018 2:19 pm

This bug still doesn't seem to be fixed in the 2.5.9 release. Therefor this friendly reminder.

Our current workaround is to use an outdated Google Chrome browser (v48, while Chrome is currently at v63). This old browser version has a function to disable "pinch to zoom". All newer versions don't have this option anymore.

Although this workaround prevents users from 'damaging' the default zoom level of the overall tour, it also disables pinching in and out from our detailed panoramic images :(

Really hoping for a fix rather sooner than later. Come on team Kolor, you can do it :)
Little Planet - We turn your world 360˚ around!

Follow our 360˚ adventures on:
facebook.com/littleplanet.be
instagram.com/littleplanet.be
www.littleplanet.be

2 people like this post.


Who is online

Users browsing this forum: No registered users and 4 guests