Page 1 of 1

.htaccess disables tour videos on Chrome

PostPosted: Tue Mar 14, 2017 10:30 am
by embfilmmakers
Hi,
I've recently upload a Panotour that works perfectly, and then I put an .htaccess and .htpasswd files on the same directory as the index.html file and indexdata folder so I can protect the content with a password.
If I use Chrome the tour doesn't load any video, and errors start to display on the bottom ("network loading error!"; "loading video failed!"). There are no such problems if I use Firefox.

If I disable or delete those .htaccess and .htpasswd files Chrome goes back to loading every tour video again.

Seems like these files are messing with something essential to load videos on Chrome.

The problem then is:
How do I protect a Panotour with a password so it works on every internet browser??

Thanks!

Nuno

Re: .htaccess disables tour videos on Chrome  [SOLVED]

PostPosted: Tue Mar 14, 2017 10:34 am
by Annis
Did you check the option "The tour will be hosted on a website protected by credentials" in the Build Tab > Protection > Protected Website ?

Re: .htaccess disables tour videos on Chrome

PostPosted: Tue Mar 14, 2017 12:14 pm
by embfilmmakers
In fact, I did not know there was an option for that. Shame on me!

I'll upload again and see if it is solved.

Re: .htaccess disables tour videos on Chrome

PostPosted: Wed Mar 15, 2017 12:37 pm
by embfilmmakers
That was it, problem solved!

I checked the option "The tour will be hosted on a website protected by credentials", and it works fine.

Didn't know there was an option for that.

Thanks again!