Hotspots/Graphics Appear Offline but not Online   [SOLVED] - View the solution

This forum is fully dedicated to Panotour / Panotour Pro bug reports as well as feature discussion.
no avatar
snafubar
Member
 
Topic author
Posts: 51
Likes: 0 post
Liked in: 0 post
Joined: Mon Apr 22, 2013 1:21 am
Info

Hotspots/Graphics Appear Offline but not Online

by snafubar » Sat Jun 11, 2016 1:17 am

Hello everyone, I'm having trouble getting my hotspots to appear after manually uploading via FTP to my site.

MacBook Pro, OSX 10.11.5
PTP 2.3.2
Multiple browsers tested.

My tour is extremely simple. 1 image, 2 logos and 2 hotspots. After I "build" the tour and view if offline, everything works normally. But after uploading the files, multiple times to confirm I hadn't screwed anything up, I cannot get the hotspots or graphics to appear. I can even see them in the xxxxxxx_data folder of my tour. What could be causing this?

here's a link to the tour. There are supposed to be two hotspots on the dash of the aircraft, as well as logos on the upper right and lower right of the screen.
http://www.parallaxpoint.com/test-page/

Thanks very much,

Kit

User avatar
Annis
Kolor Team
 
Posts: 6062
Likes: 801 posts
Liked in: 444 posts
Joined: Mon Aug 12, 2013 12:47 pm
Location: France
Info

Re: Hotspots/Graphics Appear Offline but not Online

by Annis » Mon Jun 13, 2016 8:32 am

Files are coming up with a 404 error when viewing the tour, check the files are uploaded and they have the correct permissions to be viewed publicly from your server.

Also, why are you not using the latest version of PTP?

no avatar
snafubar
Member
 
Topic author
Posts: 51
Likes: 0 post
Liked in: 0 post
Joined: Mon Apr 22, 2013 1:21 am
Info

Re: Hotspots/Graphics Appear Offline but not Online

by snafubar » Mon Jun 13, 2016 5:28 pm

Hi Annis, thanks for the response. I will double-check the files and the permissions... is there anything specific I should look for with the permissions ? I am simply uploading the files manually through FileZilla, which I have not had a problem with in the past.

To answer your second question, I am not using PTP 2.5 because I was having even greater problems trying to get the online versions of my tours to appear correctly. Namely, after I uploaded manually using FileZilla and linked the tour using the iFrame method used on my entire site, the tour would fail to load at all. So I began testing older versions of PTP, and found that this issue did not occur with PTP 2.3. It works well except for the hotspot issue above.

Thank you again,

Kit

no avatar
snafubar
Member
 
Topic author
Posts: 51
Likes: 0 post
Liked in: 0 post
Joined: Mon Apr 22, 2013 1:21 am
Info

Re: Hotspots/Graphics Appear Offline but not Online  [SOLVED]

by snafubar » Sat Jun 18, 2016 1:42 am

I found a solution by switching FTP clients.

Apparently Filezilla (multiple versions) for OSX was causing some sort of issue with my uploads. I switched to CyberDuck and everything seems to be working normally again.

Thanks!

User avatar
signmaster
Member
 
Posts: 289
Likes: 52 posts
Liked in: 36 posts
Joined: Thu Aug 21, 2008 1:55 pm
Location: Swan Hill, Australia
Info

Re: Hotspots/Graphics Appear Offline but not Online

by signmaster » Sat Jun 18, 2016 8:37 am

I have also found lots of problems with the newer versions of Filezilla, I downloaded an older version, 3.5.2 and it works fine.
Steve


Who is online

Users browsing this forum: No registered users and 5 guests

cron