PTP 2.2 RC1 Load and Exit speeds  

This forum is fully dedicated to Panotour / Panotour Pro bug reports as well as feature discussion.
no avatar
BrianLR
Member
 
Posts: 125
Joined: Sun Sep 07, 2008 9:44 pm
Location: New Jersey, USA

PTP 2.2 RC1 Load and Exit speeds

by BrianLR » Thu Jul 24, 2014 8:15 pm

The Documentation in the wiki mentions much improved load times:
Loading time of a project has been significantly reduced: Projects saved from v2.1 and higher load fast whereas releases prior to 2.1 load slowly. The cache feature of Panotour v2.1 significantly increases productivity and reduces drastically the loading time of large Panotour project containing HD panoramas or Gigapixels. ..... For example: Just a quick bench done on the project of the "Lac du Bourget" tour : http://www.kolor.com/virtual-tours/2013 ... rget-lake/
This tour contains 23 panoramas including 3 gigapixels.
Loading this project took 22 minutes with the 2.0 version.
Once saved with the 2.1 version, the load takes 12 seconds!. In this case the opening is 100x faster!!
This feature increases comfort and smoothness in the Hotspot Editor, learn more in Hotspot Editor Low and High Resolution


I am not finding it that fast and the Exit time is very long, for a project of 50 panos, 7 plans, with 21 Notification plugins, 30 gallery plugins and 13 general plugins it take 50 seconds to load the project and around 7 minutes to exit even when I have previously exit the project, reloaded and then made no changes and exit again. This is on a Windows 7 64bit PC with 32Gb RAM 240 SSD and Sandy Bridge iCore 7 2600K CPU (4 core HT = 8 virtual cores). This project on another PC with 8Gb RAM Q6700 Quad core CPU and 2TB HDD took forever to even load!!
Last edited by BrianLR on Fri Jul 25, 2014 4:41 am, edited 4 times in total.

no avatar
BrianLR
Member
 
Posts: 125
Joined: Sun Sep 07, 2008 9:44 pm
Location: New Jersey, USA

Re: PTP 2.2 RC1 Load and Exit speeds

by BrianLR » Fri Jul 25, 2014 3:55 am

So I kept adding plugins and go to 30 and then 40 Notification plugins and the crashes started when doing other edits like hotspots and then the load times got out of control from 7 to 15 minutes until all ground to a halt. The strange thing is that the Task Manager only showed about 5-6Gb of ram being used even though 20Gb was set aside for PTP. So I loaded the whole project on to an Apple MacBook OS 10.9.4 with 16Gb Ram and a 500Gb SSD and all is working fine no problems.

So there looks like there is still a big problem with the Windows 64bit version of PTP 2.2 RC1 with larger projects and lots of plugins.

no avatar
BrianLR
Member
 
Posts: 125
Joined: Sun Sep 07, 2008 9:44 pm
Location: New Jersey, USA

Re: PTP 2.2 RC1 Load and Exit speeds

by BrianLR » Fri Jul 25, 2014 6:43 pm

After further work and additions to the project with PTP 2.2 RC1 on Apple Mac I am finding repeated build errors, with the combo Thumbnail+Toolbar missing, it takes more and more attempts at builds to get this to appear. Other than that Mac version is stable and loads and exits reasonably fast.

no avatar
BrianLR
Member
 
Posts: 125
Joined: Sun Sep 07, 2008 9:44 pm
Location: New Jersey, USA

Re: PTP 2.2 RC1 Load and Exit speeds

by BrianLR » Mon Jul 28, 2014 5:18 pm

Now running PTP 2.2.0 'stable version' and I am still having problems with the combo Thumbnail+Toolbar not showing up all the time on all browsers and some floor plans showing no hotspots. I am not sure if this is because I switched from 2.1.3 'stable' to 2.2 Beta to 2.2 'stable' or switched platforms from Win to Mac or is it the because I have a lot of Notification plugins?. Please can someone help me in how to debug this??

User avatar
bdd
Kolor Team
 
Posts: 1737
Joined: Tue Jan 18, 2011 4:05 pm

Re: PTP 2.2 RC1 Load and Exit speeds

by bdd » Tue Jul 29, 2014 9:02 am

BrianLR wrote:Now running PTP 2.2.0 'stable version' and I am still having problems with the combo Thumbnail+Toolbar not showing up all the time on all browsers and some floor plans showing no hotspots. I am not sure if this is because I switched from 2.1.3 'stable' to 2.2 Beta to 2.2 'stable' or switched platforms from Win to Mac or is it the because I have a lot of Notification plugins?. Please can someone help me in how to debug this??



1 - Can you share an URL of your tour ?
It will be easier to debug it by looking at the tour, the diffrent errors it may display, the code generated, etc...

2 - Do you have same issue without notification plugins ?

3 - Can you share the project file ?

Gérald

no avatar
BrianLR
Member
 
Posts: 125
Joined: Sun Sep 07, 2008 9:44 pm
Location: New Jersey, USA

Re: PTP 2.2 RC1 Load and Exit speeds

by BrianLR » Sun Aug 03, 2014 3:14 am

I found the problems in my choice of options in the plugin with help from Plugin developer. Have fixed these and resolved the on screen errors.

Back to the original problem of this post, in that the project runs fine on Apple Mac but will not load on Window 7, this problem seems to occur on another recent post called 2.2 unresponsive.....


Return to Panotour bugs & discussion

Who is online

Users browsing this forum: Xander Berkenhagen and 1 guest