links ALL gone after update from 2.1.0 to 2.1.1  

This forum is fully dedicated to Panotour / Panotour Pro bug reports as well as feature discussion.
no avatar
mattkay
Member
 
Topic author
Posts: 49
Likes: 0 post
Liked in: 0 post
Joined: Mon Mar 24, 2014 6:10 am
Info

links ALL gone after update from 2.1.0 to 2.1.1

by mattkay » Wed May 28, 2014 1:01 pm

dear Kolor Team,

I was running 2.1.0 and made the update to 2.1.1.
After opening my Pano Tour I was working to adjust the radars (which by the way is not at all user friendly now) and realized that the links were suddenly missing on my map. I tried to build the tour and it said it cannot be build because the project contains panoramas where the spotstyle is not associated with a spot.
Then I realized that ALL the links of my Panorama Tour were gone.

I lost hours (again and again because of all the bugs in the software) to rebuild them all.
I am so upset and disapointed =( . A software SO full of bugs and I never heard anybody of Kolor apologize for all the inconvenience you cause because you release one update after the other without proper testing. It seems it is just normal for you that the users point you to the bugs and then you react on them...or not.

I would not complain if this was an open source software...a Joomla CMS or something which is for free. But you take nearly a thousand dollar for this software (software plus licences) and I think everybody can expect a proper programmed and tested tool for this price.
Attachments
kolor_03.gif
kolor_02.gif
kolor_01.gif

no avatar
mattkay
Member
 
Topic author
Posts: 49
Likes: 0 post
Liked in: 0 post
Joined: Mon Mar 24, 2014 6:10 am
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by mattkay » Wed May 28, 2014 1:02 pm

.
Attachments
kolor_04.gif

no avatar
adrianxrl
New member
 
Posts: 1
Likes: 0 post
Liked in: 0 post
Joined: Thu May 29, 2014 11:57 am
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by adrianxrl » Thu May 29, 2014 12:15 pm

We have just the same problem, and my team don't have any idea of what's going on. We are working on projects with 400 panoramas and we waste a lot of time and money repairing them. The projets were originally created in 2.1.


My SO is Windows 8.1 Pro x64 and Panotour 2.1.1

We are expecting for a response or solution as soon as possible.

Thank you

no avatar
Destiny
Moderator
 
Posts: 7883
Likes: 6 posts
Liked in: 228 posts
Joined: Mon Apr 26, 2010 11:55 pm
Location: Australia
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by Destiny » Thu May 29, 2014 12:36 pm

I can understand the frustration in all this... Very annoying.. But.. It has to be remembered that Version 2.1 was just an RC1 version.. To create a full Tour for a commercial project was really at your own risk.. However, V2.1.1 is a final.. The thing is.. To create a commercial Tour using a RC1 version was risky, so when updating from a RC1 version to a final is not a good idea in mid stream.. I would have remained with the last Stable version for sure with your project.. Then tip-toed testing features with V2.1 RC1 before moving onto the V2.1.1 final and attempting a big commercial project...

If however you experienced this kind of issue from beginning to end when using V2.1.1, that would be a big issue.... Kolor would need to step-up to the plate and fix the issue.. But in your case this is not apparent..

As frustrating as it all might be for you.. I feel it was far too bigger a risk to create a full blowen Tour such as yours using an RC version.. Therefore, not really Kolor fault, in my view...

Destiny..

no avatar
mediavets
Moderator
 
Posts: 16415
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by mediavets » Thu May 29, 2014 12:54 pm

Destiny wrote:I can understand the frustration in all this... Very annoying.. But.. It has to be remembered that Version 2.1 was just an RC1 version..
Destiny..


Not so - there was a Final version of 2.1 (after RC1).

no avatar
AnnaMaria
Member
 
Posts: 126
Likes: 0 post
Liked in: 1 post
Joined: Wed Oct 23, 2013 7:27 pm
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by AnnaMaria » Thu May 29, 2014 7:12 pm

1. Downloaded 2.1.1 noonish today.
2. All new spots, logos, social buttons, and associated graphics to existing file
3. Every other spot change software crashed - send a number of reports until trying to send report caused another so gave up - half way through recreating project (when spot opens pop up .png)
4. Finally completed. Saved, exported, saved again and quit.
5. Uploaded tour.
6. Realised - as in a rush for a 5pm deadline - needed to look at Nadir.
7. Opened .kpt. Sorted Nadir, went to export. Told no spots had buttons, associated .png graphic files so have to do all over again!

So have to spend the evening re-doing?

M

no avatar
giosa
Member
 
Posts: 26
Likes: 0 post
Liked in: 0 post
Joined: Thu May 26, 2011 9:27 am
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by giosa » Sun Jun 01, 2014 3:24 pm

We have just the same problem, Panotour Pro 2.1.1

... 2.1.1 is a stable version!

no avatar
Xander Berkenhagen
Member
 
Posts: 245
Likes: 5 posts
Liked in: 8 posts
Joined: Tue Oct 01, 2013 12:54 am
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by Xander Berkenhagen » Mon Jun 02, 2014 9:29 pm

Same problem here...

no avatar
HansKeesom
Member
 
Posts: 2210
Likes: 1 post
Liked in: 2 posts
Joined: Mon Jul 19, 2010 8:53 pm
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by HansKeesom » Mon Jun 02, 2014 11:20 pm

Xander Berkenhagen wrote:Same problem here...


When working with panotour, it sometimes pays to be paranoid ;-) Save project every few minutes with the minutes behind the name...

User avatar
bdd
Kolor Team
 
Posts: 2802
Likes: 14 posts
Liked in: 130 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by bdd » Wed Jun 04, 2014 8:17 am

mattkay wrote:I was running 2.1.0 and made the update to 2.1.1.
After opening my Pano Tour I was working to adjust the radars (which by the way is not at all user friendly now) and realized that the links were suddenly missing on my map. I tried to build the tour and it said it cannot be build because the project contains panoramas where the spotstyle is not associated with a spot.
Then I realized that ALL the links of my Panorama Tour were gone.

Could you please send us your project file :
1 - saved prior the spots disappeared?
2 - once you saw the link disappeared

In your screenshots, all the links are displayed.
When you said that all the links disappeared do you mean that they are displayed but when you select the spot, the spot has no style and no target, even if the target is correct in the main area ?

Gérald

User avatar
bdd
Kolor Team
 
Posts: 2802
Likes: 14 posts
Liked in: 130 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by bdd » Wed Jun 04, 2014 8:21 am

Can you please all send us your project files ?

We did not reproduce this bug here.
In the 2.1.1 version we added a bug fix on a similar bug that leads to the loose of all the spots of a single panorama if it was selected when you changed some parameters in the spot style.

If someone is able to describe the process that leads to this bug, tell us, it will help us a lot.

Gérald

User avatar
bdd
Kolor Team
 
Posts: 2802
Likes: 14 posts
Liked in: 130 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by bdd » Wed Jun 04, 2014 10:55 am

Can you please confirm that you saved your project when answering Yes to Panotour when you closed it ?

We have to confirm it, but it seems that the bug appears when closing and saving Panotour at same time.

So, until we find a fix for this issue, we recommend to save the project first. Wait for the end of the saving, and then close Panotour.

Gérald

no avatar
CCBain
Member
 
Posts: 15
Likes: 0 post
Liked in: 0 post
Joined: Sat Jul 28, 2012 7:05 pm
Location: New York
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by CCBain » Thu Jun 05, 2014 3:13 pm

This exact same thing happened to me last nigh. 11 Panos, 30+ links, picture spots, sound spots, the usual. Then I saved, went to another project, and when I came back ALL the links were gone (the arrow lines that show the links graphically) though the spots were still in place with their descriptions still in place. 2.1.1 on a Mac with the latest OS.

What is going on? I'm afraid to open any of my other projects!

User avatar
StudioVR
Member
 
Posts: 19
Likes: 0 post
Liked in: 0 post
Joined: Thu Nov 07, 2013 10:30 am
Location: Antwerpen
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by StudioVR » Thu Jun 05, 2014 10:58 pm

CCBain wrote:I'm afraid to open any of my other projects!



Do you know when this will be fixed?

I do not move any more projects, also with fear ;) Steel nerves

User avatar
bdd
Kolor Team
 
Posts: 2802
Likes: 14 posts
Liked in: 130 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by bdd » Fri Jun 06, 2014 1:14 pm

StudioVR wrote:
CCBain wrote:I'm afraid to open any of my other projects!



Do you know when this will be fixed?

I do not move any more projects, also with fear ;) Steel nerves


We release a 2.1.2 version of Panotour this morning (Paris time) that fixes this bug

Gérald

no avatar
mattkay
Member
 
Topic author
Posts: 49
Likes: 0 post
Liked in: 0 post
Joined: Mon Mar 24, 2014 6:10 am
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by mattkay » Sat Jun 14, 2014 5:11 pm

In your screenshots, all the links are displayed.


I made the screenshot after I set all the links again, so you could see that it was not funny at all with a big tour like that...
But then again, I read about one that had a 1000 Panos where the links got lost and I thought...man... It could always be worse.

Anyway - today I downloaded the bug fix release, but since my program is running now, I do not dare to install the new version.
Who knows what happens...

no avatar
mediavets
Moderator
 
Posts: 16415
Likes: 2 posts
Liked in: 130 posts
Joined: Wed Nov 14, 2007 2:12 pm
Location: Isleham, Cambridgeshire, UK.
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by mediavets » Sat Jun 14, 2014 7:59 pm

mattkay wrote:
In your screenshots, all the links are displayed.


I made the screenshot after I set all the links again, so you could see that it was not funny at all with a big tour like that...
But then again, I read about one that had a 1000 Panos where the links got lost and I thought...man... It could always be worse.

Anyway - today I downloaded the bug fix release, but since my program is running now, I do not dare to install the new version.
Who knows what happens...

Try working with a copy of your tour.

You can always go back to an earlier version.

http://download.kolor.com/ptp/stable/history

no avatar
Destiny
Moderator
 
Posts: 7883
Likes: 6 posts
Liked in: 228 posts
Joined: Mon Apr 26, 2010 11:55 pm
Location: Australia
Info

Re: links ALL gone after update from 2.1.0 to 2.1.1

by Destiny » Sun Jun 15, 2014 1:06 am

:rolleyes: In all honestly.. A 1000 panos!!! Thats way too big.. Who on earth would bother looking at that lot.. Far too many.. And... Who has time to make a 1000 panos.. That's just HUGE!

I would have thought 50 was huge.. 30 was acceptable. Up to 20 would be the way to go.. Surly a Tour such as that would be better off being broken up into parts.. With deep linking urls to open other Tours.. That way, any mistakes can be minimised and a fixed and will not take forever..

Just my thoughts..

Destiny...


Who is online

Users browsing this forum: No registered users and 1 guest