Image-stitching and virtual tour solutions My account Updates
It is currently Wed Jul 23, 2014 12:58 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 13 posts ] 
Author Message
PostPosted: Wed Apr 16, 2014 8:05 am 
Offline
Member
User avatar

Joined: Mon Apr 26, 2010 11:55 pm
Posts: 4663
Location: Australia
Hey Kolor...

I notice this happening on others Tours so I checked and found it on mine too.. Is this a html template bug for something else..

There are two notices of errors the other suggest something cannot be found so it will be ignored..... The JS error only began since PTP RC1..

Not sure if its a Safari issue or something else.. I used the Web Inspector do view the errors..

Destiny...

Attachment:
error2.jpg
error2.jpg [ 20.82 KiB | Viewed 169 times ]


Attachments:
error1.jpg
error1.jpg [ 217.04 KiB | Viewed 169 times ]
Top
 Profile  
 
PostPosted: Wed Apr 16, 2014 8:19 am 
Offline
Member
User avatar

Joined: Tue Jan 18, 2011 4:05 pm
Posts: 1562
Destiny wrote:
Hey Kolor...

I notice this happening on others Tours so I checked and found it on mine too.. Is this a html template bug for something else..

There are two notices of errors the other suggest something cannot be found so it will be ignored..... The JS error only began since PTP RC1..

Not sure if its a Safari issue or something else.. I used the Web Inspector do view the errors..

Destiny...

Attachment:
error2.jpg



Hello Destiny,

Can you please provide some URL of tours on which you found this error ?

I did not see it yet.

Gérald


Top
 Profile  
 
PostPosted: Wed Apr 16, 2014 8:36 am 
Offline
Member
User avatar

Joined: Mon Apr 26, 2010 11:55 pm
Posts: 4663
Location: Australia
Sure..

This url is your latest build V2.1.RC1 - Two errors...

http://www.destinyvirtualtours.com/PTPV ... ePano.html

This one V2 - Same two errors...

http://www.destinyvirtualtours.com/PTPV ... oTest.html

This one is RC 2 - Two errors..

http://www.destinyvirtualtours.com/PTPV ... llery.html

RC 1 - Two errors..

http://www.destinyvirtualtours.com/PTPV ... llery.html

and
Beta 5 has only one error, the "Viewport argument"

Beta 4 same, only one error.. Not sure if its the media plugin thats in the Tour that accounts for the JS error..

Destiny..


Top
 Profile  
 
PostPosted: Wed Apr 16, 2014 8:47 am 
Offline
Member
User avatar

Joined: Mon Apr 26, 2010 11:55 pm
Posts: 4663
Location: Australia
Hey Gerald.. This might give you more insight at the right of the screen shots.. I see the same kinds of errors with other members Tours.. So its not my Tours... Seems it cannot find JS files.. The second screen shoot is from the thread "Video Don't Work" viewtopic.php?f=92&t=22156

Destiny...


Attachments:
errors-3.jpg
errors-3.jpg [ 58.61 KiB | Viewed 155 times ]
errors-4.jpg
errors-4.jpg [ 43.77 KiB | Viewed 155 times ]
Top
 Profile  
 
PostPosted: Wed Apr 16, 2014 8:47 am 
Offline
Member
User avatar

Joined: Tue Jan 18, 2011 4:05 pm
Posts: 1562
Destiny wrote:

This url is your latest build V2.1.RC1 - Two errors...

http://www.destinyvirtualtours.com/PTPV ... ePano.html

I do not see any error in this one

Destiny wrote:

I do not see any error in this one too


Destiny wrote:

No error too

And the fourth link is the same as this one. So I do not see any error too.


Top
 Profile  
 
PostPosted: Wed Apr 16, 2014 8:56 am 
Offline
Member
User avatar

Joined: Mon Apr 26, 2010 11:55 pm
Posts: 4663
Location: Australia
How strange..

Then it must just be one of those things..

Did you try do this on a Mac with Mavericks and the latest Safari.. Using its web inspector.. ???

Destiny...


Top
 Profile  
 
PostPosted: Wed Apr 16, 2014 9:24 am 
Offline
Member
User avatar

Joined: Mon Apr 26, 2010 11:55 pm
Posts: 4663
Location: Australia
Really strange.. The Web inspector is rubbish.. I have checked the html template and checked the build html and the folders with the JS, and they all match.. Yet the web inspector does not recognise the full naming of the JS.. This is causing the error.. I clicked on the link it produced and it cannot find the file.. but the web inspector is wrong. That file does not exist in the folders and its not supposed to be there..

Destiny...


Attachments:
errors-5.jpg
errors-5.jpg [ 166.75 KiB | Viewed 138 times ]
Top
 Profile  
 
PostPosted: Wed Apr 16, 2014 9:35 am 
Offline
Member
User avatar

Joined: Tue Jan 18, 2011 4:05 pm
Posts: 1562
Destiny wrote:
Really strange.. The Web inspector is rubbish.. I have checked the html template and checked the build html and the folders with the JS, and they all match.. Yet the web inspector does not recognise the full naming of the JS.. This is causing the error.. I clicked on the link it produced and it cannot find the file.. but the web inspector is wrong. That file does not exist in the folders and its not supposed to be there..

Destiny...


Destiny, you are right.
Just take a look at the code of the 2 following HTML pages :

http://www.destinyvirtualtours.com/PTPV ... ePano.html
and
http://www.destinyvirtualtours.com/PTPV ... oTest.html

Look at line "55".

In the first HTML page some includes are lacking.

When you rebuild a tour, are those includes lacking ?
Are you able to tell when they are lacking and when they are not ?

I opened an issue about these lacking libraries. But I wonder how and when they lack.

FORGET THIS POST, I FOUND THE REASON. It is not a bug. The includes are added only if you have some HTML5 plugins.

Gérald


Top
 Profile  
 
PostPosted: Wed Apr 16, 2014 10:00 am 
Offline
Member

Joined: Mon May 22, 2006 12:18 am
Posts: 7619
Location: Duesseldorf, Germany
bdd wrote:
The includes are added only if you have some HTML5 plugins.



??????

Klaus


Top
 Profile  
 
PostPosted: Wed Apr 16, 2014 10:30 am 
Offline
Member
User avatar

Joined: Mon Apr 26, 2010 11:55 pm
Posts: 4663
Location: Australia
Thank you Gérald...

At least I am not going crazy.. =D

Destiny...


Top
 Profile  
 
PostPosted: Wed Apr 16, 2014 11:11 am 
Offline
Member
User avatar

Joined: Tue Apr 09, 2013 10:59 am
Posts: 1933
Location: France
Destiny wrote:
Really strange.. The Web inspector is rubbish.. I have checked the html template and checked the build html and the folders with the JS, and they all match.. Yet the web inspector does not recognise the full naming of the JS.. This is causing the error.. I clicked on the link it produced and it cannot find the file.. but the web inspector is wrong. That file does not exist in the folders and its not supposed to be there..

Destiny...


Is it your own template with jquery-xxx.js link rather than jquery-xxx.min.js link ?

_________________
Benjamin
http://www.kolor.com


Top
 Profile  
 
PostPosted: Wed Apr 16, 2014 11:17 am 
Offline
Member
User avatar

Joined: Mon Apr 26, 2010 11:55 pm
Posts: 4663
Location: Australia
No Benjamin since this issue is present with this Tour....as you can see at this screen shot... Its not my tour... Same error.... same JS file..

Destiny...


Attachments:
errors-4.jpg
errors-4.jpg [ 43.77 KiB | Viewed 115 times ]
Top
 Profile  
 
PostPosted: Wed Apr 16, 2014 2:05 pm 
Offline
Member
User avatar

Joined: Mon Apr 26, 2010 11:55 pm
Posts: 4663
Location: Australia
... and when I change the name of that JS file and add it to my lib folder.. the error is removed. But there is still one error left.. This first screen shot is from a member recently posted a Tour.. Same issue.. Perhaps none of it matters... Everything seems to work... But... I am not a programer so not sure if it gives rise to other issues...

Destiny...


Attachments:
errors-6.jpg
errors-6.jpg [ 100.8 KiB | Viewed 106 times ]
errors-7.jpg
errors-7.jpg [ 63.15 KiB | Viewed 106 times ]
Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group