Panotour 2.0 not running on Suse 11.4  

This forum is fully dedicated to Panotour / Panotour Pro bug reports as well as feature discussion.
no avatar
hannes
Member
 
Posts: 23
Joined: Fri Feb 02, 2007 5:24 pm

Panotour 2.0 not running on Suse 11.4

by hannes » Sun Oct 06, 2013 3:46 pm

hannes@Pundit2:~/SOFTWARE/PHOTO/PANO/TOUR/Panotour_2> ./Panotour
./Panotour: error while loading shared libraries: libKGFL_linux64.so: cannot open shared object file: No such file or directory

but libKGFL_linux64.so is in the folder and executable ...

second try:
hannes@Pundit2:~/SOFTWARE/PHOTO/PANO/TOUR/Panotour_2> ./Panotour.sh
hannes@Pundit2:~/SOFTWARE/PHOTO/PANO/TOUR/Panotour_2> QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameCollapseGeolocalisation", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameDescription", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameColor", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameOrder", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameBackgroundSound", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameAuthor", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameCollapsibleFloorPlan", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameRotation", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameStartParams", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameCollapseGeolocalisation", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameDescription", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameDisplay", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameCollapsibleFloorPlan", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameOrder", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameBackgroundSound", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameCollapseGeolocalisation", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameDescription", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameProjection", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameView", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameNadir", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameBackgroundSound", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameRotation", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameAdvanced", which already has a layout
QLayout: Attempting to add QLayout "" to KuiFrameCollapsible "frameDescription", which already has a layout
QLayout: Attempting to add QLayout "" to QGroupBox "groupBoxSpotParameters", which already has a layout
terminate called after throwing an instance of 'KException'
QThread::start: Thread creation error: Die Ressource ist zur Zeit nicht verfügbar

User avatar
benji33
Kolor Team
 
Posts: 2793
Joined: Tue Apr 09, 2013 10:59 am
Location: France

Re: Panotour 2.0 not running on Suse 11.4

by benji33 » Mon Oct 07, 2013 10:45 am

Thanks for report we'll have to check the Linux installer.

User avatar
bdd
Kolor Team
 
Posts: 1745
Joined: Tue Jan 18, 2011 4:05 pm

Re: Panotour 2.0 not running on Suse 11.4

by bdd » Mon Oct 07, 2013 11:09 am

We opened an issue 2597 on this subject.

User avatar
bdd
Kolor Team
 
Posts: 1745
Joined: Tue Jan 18, 2011 4:05 pm

Re: Panotour 2.0 not running on Suse 11.4

by bdd » Fri Oct 18, 2013 11:43 am

We did some changes in the 2.0 Beta 2 version that may fix this issue.
But we are not sure of that as we were not able to reproduce it.
That's why it does not appear in the changelogs of this new version.

Can you tell us if this exception still occurs with the 2.0 Beta 2 version ?

Gérald

no avatar
hannes
Member
 
Posts: 23
Joined: Fri Feb 02, 2007 5:24 pm

Re: Panotour 2.0 not running on Suse 11.4

by hannes » Mon Oct 21, 2013 1:59 pm

it is the same with beta 2 - still not running - same output

User avatar
benji33
Kolor Team
 
Posts: 2793
Joined: Tue Apr 09, 2013 10:59 am
Location: France

Re: Panotour 2.0 not running on Suse 11.4

by benji33 » Mon Oct 21, 2013 2:36 pm

Thanks for your response. I've added your report on the opened bug.

User avatar
ygilquin
Kolor Team
 
Posts: 200
Joined: Wed Sep 29, 2010 9:00 am
Location: Francin

Re: Panotour 2.0 not running on Suse 11.4

by ygilquin » Tue Oct 22, 2013 4:01 pm

We tried Panotour Pro 2.0 Beta2 under OpenSuse 12.3 (last version) and it starts without any problem.

You should also never launch ./Panotour command directly, but invoke ./Panotour.sh wrapper script which sets the environment.

Anyway, this is definitely not a problem with the package but a runtime compatibility problem. You should ensure you're running binaries with the right architecture (32/64 bits) depending on your system.

no avatar
hannes
Member
 
Posts: 23
Joined: Fri Feb 02, 2007 5:24 pm

Re: Panotour 2.0 not running on Suse 11.4

by hannes » Tue Oct 22, 2013 4:16 pm

no big problem - because I have a PC with ubuntu 12.04 were its running without problems

User avatar
benji33
Kolor Team
 
Posts: 2793
Joined: Tue Apr 09, 2013 10:59 am
Location: France

Re: Panotour 2.0 not running on Suse 11.4

by benji33 » Wed Oct 23, 2013 8:32 am

Yes panotour is designed and tested for Ubuntu but may work on others Linux versions.

User avatar
ygilquin
Kolor Team
 
Posts: 200
Joined: Wed Sep 29, 2010 9:00 am
Location: Francin

Re: Panotour 2.0 not running on Suse 11.4

by ygilquin » Fri Jan 03, 2014 9:47 am

For information Panotour Pro 2.0 RC1 runs perfectly in OpenSuse 12.3 on our side.


Return to Panotour bugs & discussion

Who is online

Users browsing this forum: No registered users and 3 guests