Page 1 of 1

Description not showing in pano

PostPosted: Wed Aug 29, 2018 2:14 pm
by goomedia
Hi all, I'm at my first tour with PTP2.5, I've added a description to some panos (the entry panos in groups) but it's not showing up, these are the settings of the description plugin in the style tab (see attachment).
Only one time a description is shown, in the first pano of the first group, then, when i navigate, no description is shown.
Could you please help me with this issue?

Re: Description not showing in pano

PostPosted: Thu Aug 30, 2018 9:21 am
by bdd
Is this tour online ?
If yes, can you share its URL ?
It will help us understand what goes wrong.

What I understand is that the second scene, that do not have any description in your project, hides the description plugin, and that this plugin never appear after this closing.

Am I right ?

Gérald

Re: Description not showing in pano

PostPosted: Thu Aug 30, 2018 9:52 am
by goomedia
Hi Gerald, thanks for your kind reply.
No, the tour is still not online, I'm testing locally, it's too heavy for my poor connection where I'm now.
I've added the description to certain single panoramas, and I was expecting to see them popup when i move to these panoramas, and disappear when I navigate.
But I cannot obtain this behaviour.
Can you please share with me the settings for description plugin to obtain this?
Thanks a lot.
Lucio

Re: Description not showing in pano

PostPosted: Thu Aug 30, 2018 10:19 am
by bdd
Strange.
I did a check with the same parameters as yours, and the tour has the behaviour you want.
the description plugin is re-opened when the scene has a description

The issue may come from another plugin.
Can you share the kpt file ?

Gérald

Re: Description not showing in pano

PostPosted: Thu Aug 30, 2018 7:40 pm
by goomedia
Sure Gerald, thanks, here is a wetransfer link: https://we.tl/t-kTCnDpWLoQ
Thanks,
Lucio

Re: Description not showing in pano

PostPosted: Fri Aug 31, 2018 10:06 am
by bdd
You are rght, there is a bug in the Description plugin code .

If you navigate thru 2 or more scenes without description then the description plugin is not restored.

You can "fix" this issue on your side by modifying the generated code.

Once the tour is built, edit the file "PTP_Alitalia_skin.xml"

Find the following action :
Code: Select all
<action name="closeDescription_description1">
   set(ptplugin[description1].currentGroup, false);
   if(%1,
      set(restore_description1, true);
   ,
      set(restore_description1, false);
   );
   closeKolorArea_description1();
</action>


Replace its code by :
Code: Select all
<action name="closeDescription_description1">
   set(ptplugin[description1].currentGroup, false);
   set(restore_description1, true);
   closeKolorArea_description1();
</action>


Beware that you'll have to do that after each build.
So prefer doing it once your project is almost finished.

Gérald

Re: Description not showing in pano

PostPosted: Fri Aug 31, 2018 9:53 pm
by goomedia
Thanks Gerald! I will try asap.
Thanks for your support, I think I will need a couple of other things in the next days!
Lucio