Build time just increased massively  

Share your tips and tricks here or get help with any Panotour 2.0+ problem!
No bug reports (of any kind) in this forum!
no avatar
Thomocheerio
Member
 
Topic author
Posts: 12
Likes: 1 post
Liked in: 0 post
Joined: Sat Dec 02, 2017 12:13 am
Info

Build time just increased massively

by Thomocheerio » Thu Feb 01, 2018 3:46 pm

Hi there,
I'm putting together quite a substantial virtual tour. The build time has just jumped from taking a minute or so to nearly 45min.
It seems like P2P is building the tour from scratch every time I make a small change. I'm pretty sure this wasn't happening before. I haven't changed any settings that I know of.
Can someone advise?

User avatar
Annis
Kolor Team
 
Posts: 6062
Likes: 801 posts
Liked in: 444 posts
Joined: Mon Aug 12, 2013 12:47 pm
Location: France
Info

Re: Build time just increased massively

by Annis » Thu Feb 01, 2018 4:17 pm

Lock your scenes if they're already built.

http://www.kolor.com/wiki-en/action/vie ... s#Advanced

no avatar
Thomocheerio
Member
 
Topic author
Posts: 12
Likes: 1 post
Liked in: 0 post
Joined: Sat Dec 02, 2017 12:13 am
Info

Re: Build time just increased massively

by Thomocheerio » Thu Feb 01, 2018 5:54 pm

Great!! That seems to have stabilised things. Thanks very much.

User avatar
signmaster
Member
 
Posts: 289
Likes: 52 posts
Liked in: 36 posts
Joined: Thu Aug 21, 2008 1:55 pm
Location: Swan Hill, Australia
Info

Re: Build time just increased massively

by signmaster » Fri Feb 02, 2018 5:40 am

Caution, you will need to check with Annis on this. I had a similar problem and I removed the cache and backup files from the tour directory, rebuilt the tour with generate all panos and from then on everything built and loaded quickly.

Steve

no avatar
Thomocheerio
Member
 
Topic author
Posts: 12
Likes: 1 post
Liked in: 0 post
Joined: Sat Dec 02, 2017 12:13 am
Info

Re: Build time just increased massively

by Thomocheerio » Fri Feb 02, 2018 1:59 pm

Thanks Steve,

Are you talking about the directory in "manage build files"?

Something is not quite right here. It has a message saying 2281 missing files and that I "need to rebuild the project". I've done that, but the message is still there.
I've pressed the "not needed file" button and it wants me to delete everything.......not keen on doing that.
Can you give some further feedback in Annis?

User avatar
signmaster
Member
 
Posts: 289
Likes: 52 posts
Liked in: 36 posts
Joined: Thu Aug 21, 2008 1:55 pm
Location: Swan Hill, Australia
Info

Re: Build time just increased massively

by signmaster » Sat Feb 03, 2018 5:18 am

Not the build directory but the directory where the Panotour file is, the .kpt file. There will be the .kpt, .cache and a number of .ktp.backup files. Backup all files somewhere else then delete the .cache and the .kpt.backup files. Open your tour file, that is the .kpt file and rebuild using the rebuild everything option and from then on should be OK.

Steve

no avatar
Thomocheerio
Member
 
Topic author
Posts: 12
Likes: 1 post
Liked in: 0 post
Joined: Sat Dec 02, 2017 12:13 am
Info

Re: Build time just increased massively

by Thomocheerio » Sat Feb 03, 2018 12:05 pm

Great!!

Thanks again. I'm fairly new to this so, it looks like I need to manage my workflow better.
It seems that I was overloading the memory. I found on the forum that simply saving, building, saving and restarting the program is the most effective way to speed things up.


Who is online

Users browsing this forum: No registered users and 1 guest

cron