Online virtual tour is loading really slow. please help   [SOLVED] - View the solution

Share your tips and tricks here or get help with any Panotour 2.0+ problem!
No bug reports (of any kind) in this forum!
no avatar
LBernos
Member
 
Topic author
Posts: 142
Likes: 47 posts
Liked in: 7 posts
Joined: Tue Sep 20, 2016 6:43 am
Info

Online virtual tour is loading really slow. please help

by LBernos » Sat May 06, 2017 11:08 am

Hello!

Our online virtual tour is loading really slow, even on a 50mbps internet connection. Most especially the 360 videos (i have alternative files)

Can anyone help me with it? any tips you can share.. or you might see in the code any mistake I make?

My boss is killing me :( please help!

Here is the link to the tour: https://s3-us-west-2.amazonaws.com/souq ... nal_2.html


Lino

User avatar
Annis
Kolor Team
 
Posts: 6062
Likes: 801 posts
Liked in: 444 posts
Joined: Mon Aug 12, 2013 12:47 pm
Location: France
Info

Re: Online virtual tour is loading really slow. please help  [SOLVED]

by Annis » Tue May 09, 2017 11:32 am

The tour loads fine here but we have a fast internet connection.

First thing you could do if optimise your image sizes. You have a logo in the top left corner which is displayed at 250px whereas the original image is 4 times that.
You have a logo at the nadir which is roughly 200px too, and again the original image is 4 times that.
Etc..

By having large images that will then be resized, all you're doing is slowing down the loading time and demanding more memory and data resources to load the tour. Even though your images aren't some of the largest I've seen.... thankfully.

Resize your images to be the size they are displaying at, or at best have them twice the size you want to display at.

That might help a bit.

Other than that, well it's all down to your server and your internet connection.

no avatar
LBernos
Member
 
Topic author
Posts: 142
Likes: 47 posts
Liked in: 7 posts
Joined: Tue Sep 20, 2016 6:43 am
Info

Re: Online virtual tour is loading really slow. please help

by LBernos » Tue May 09, 2017 2:57 pm

Thank you annis! I will do that. :)

Annis wrote:The tour loads fine here but we have a fast internet connection.

First thing you could do if optimise your image sizes. You have a logo in the top left corner which is displayed at 250px whereas the original image is 4 times that.
You have a logo at the nadir which is roughly 200px too, and again the original image is 4 times that.
Etc..

By having large images that will then be resized, all you're doing is slowing down the loading time and demanding more memory and data resources to load the tour. Even though your images aren't some of the largest I've seen.... thankfully.

Resize your images to be the size they are displaying at, or at best have them twice the size you want to display at.

That might help a bit.

Other than that, well it's all down to your server and your internet connection.


Who is online

Users browsing this forum: No registered users and 4 guests