Issues with Polish letters under IE  

Share your tips and tricks here or get help with any Panotour 2.0+ problem!
No bug reports (of any kind) in this forum!
User avatar
mjaszo
Member
 
Topic author
Posts: 70
Likes: 6 posts
Liked in: 3 posts
Joined: Mon Jul 18, 2011 1:17 pm
Location: Biala Podlaska / Warsaw
Info

Issues with Polish letters under IE

by mjaszo » Fri Feb 12, 2016 5:01 pm

Hi!
Here's a virtual tour, simple yet on fantastic subject I've been working on last summer: http://pl.chopin.warsawtour.pl/wirtualny-spacer/

I'm the author of the tour, the site has been prepared by another company. The client has two issues with it:
1. it doesn't run under Firefox 43.0.4 (it does on my computer)
2. Internet Explorer doesn't show special characters (like Polish letters) in txt. Take a look at the 1st pano. The title should say: "...Chopina / Łazienki..." and it stops after "Chopina" on "Ł"

The tour hosted on my server works fine in both cases meaning there's something wrong with joining VT+WWW. Could you check how it runs on your machines? Could you advise what could be the issue? Thanks!

User avatar
bdd
Kolor Team
 
Posts: 2591
Likes: 13 posts
Liked in: 115 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

Re: Issues with Polish letters under IE

by bdd » Mon Feb 15, 2016 9:23 am

1/ The tour works also on my Firefox 43.0.4 .
But there is a JS error on the wordpress theme when starting the page.
Any JS error occuring prior the tour is started may lead to an error on the tour.
So, you may tell your client to fix this issue and see then if the tour is working.


2/ I reproduce the issue on Internet Explorer with the truncated message containing Polish letters.
It's strange as when the messages file is opened directly, the message is correctly displayed.
So it may be a bug from the player itself.
We will do some tests, and we will contact KRpano developper to see with hiem if this bug can be fixed.
http://pl.chopin.warsawtour.pl/spacer/c ... ges-pl.xml

Gérald

User avatar
bdd
Kolor Team
 
Posts: 2591
Likes: 13 posts
Liked in: 115 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

Re: Issues with Polish letters under IE

by bdd » Mon Feb 15, 2016 12:26 pm

Can you send me your project file ?
Your kpt file only.

I reproduced the IE issue with your tour, but I tried to reproduce it locally with a new project and I did not succeed to do it using your title :
Code: Select all
Pomnik Fryderyka Chopina<br/>Łazienki Królewskie



Gérald

User avatar
bdd
Kolor Team
 
Posts: 2591
Likes: 13 posts
Liked in: 115 posts
Joined: Tue Jan 18, 2011 4:05 pm
Info

Re: Issues with Polish letters under IE

by bdd » Mon Feb 15, 2016 1:45 pm

I tried with the project file you sent me and I do not reproduce the issue.

So I checked once again your client tour.
And saw that the title is badly displayed only if the tour is accessed through the page : http://pl.chopin.warsawtour.pl/wirtualny-spacer/
TourWithinIframe.jpg
Issue when the tour id in the Iframe


Not when it is displayed directly :
http://pl.chopin.warsawtour.pl/spacer/chopin-pl.html
TourDirectAccess.jpg
No issue when the tour is accessed directly


In the first case, there is the "Uncaught ReferenceError" I told you before that occurs.
Not in the second case.

So I suggest you to tell your client to fix this JS error in their Wordpress theme, and to re-test the tour when the fix is done.
It may solve this issue too.

Gérald

User avatar
mjaszo
Member
 
Topic author
Posts: 70
Likes: 6 posts
Liked in: 3 posts
Joined: Mon Jul 18, 2011 1:17 pm
Location: Biala Podlaska / Warsaw
Info

Re: Issues with Polish letters under IE

by mjaszo » Tue Feb 16, 2016 9:53 am

Very cool discovery. I've informed the client, and we'll see what happens. Thanks a lot!


Who is online

Users browsing this forum: No registered users and 6 guests