Video Hotspot .webm doesn't load - but .mp4 does?   [SOLVED] - View the solution

Share your tips and tricks here or get help with any Panotour 2.0+ problem!
No bug reports (of any kind) in this forum!
User avatar
byarsulik
Member
 
Topic author
Posts: 71
Likes: 5 posts
Liked in: 5 posts
Joined: Wed May 20, 2015 4:05 pm
Info

Video Hotspot .webm doesn't load - but .mp4 does?

by byarsulik » Mon Aug 17, 2015 4:18 pm

I'd really love to use .webm as it is a lot smaller and will save me bandwidth trouble, is there a reason it wouldn't work although the documentation states it is a viable option?

I've used ffmpeg on MAC to convert a .mp4 into the .webm format.

Thanks in advance!

User avatar
byarsulik
Member
 
Topic author
Posts: 71
Likes: 5 posts
Liked in: 5 posts
Joined: Wed May 20, 2015 4:05 pm
Info

Re: Video Hotspot .webm doesn't load - but .mp4 does?

by byarsulik » Mon Aug 17, 2015 4:55 pm

Some more info:

If I create my video hotspot with my webm, I get this console error (See attachment).

Otherwise, the .mp4 loads correctly!
Attachments
Screen Shot 2015-08-17 at 10.53.50 AM.png
Webm console error
Screen Shot 2015-08-17 at 10.53.50 AM.png (11.43 KiB) Viewed 1821 times

no avatar
benji33
Kolor Team
 
Posts: 5848
Likes: 92 posts
Liked in: 199 posts
Joined: Tue Apr 09, 2013 10:59 am
Location: France
Info

Re: Video Hotspot .webm doesn't load - but .mp4 does?  [SOLVED]

by benji33 » Tue Aug 18, 2015 10:27 am

Depends of the video player support for your device.
You can also edit the generated code and add the mp4 + webm files address, with "|" (pipe) separator, into the hotspot videoplayer url.
Benjamin

User avatar
byarsulik
Member
 
Topic author
Posts: 71
Likes: 5 posts
Liked in: 5 posts
Joined: Wed May 20, 2015 4:05 pm
Info

Re: Video Hotspot .webm doesn't load - but .mp4 does?

by byarsulik » Tue Aug 18, 2015 4:16 pm

benji33 wrote:Depends of the video player support for your device.
You can also edit the generated code and add the mp4 + webm files address, with "|" (pipe) separator, into the hotspot videoplayer url.


I guess it's weird because I'm using chrome and it should load .webm files. The reason I'd want to use .webm is because it is smaller!

(Really my issue would be solved once video hotspots can use YouTube links in upcoming versions)

no avatar
benji33
Kolor Team
 
Posts: 5848
Likes: 92 posts
Liked in: 199 posts
Joined: Tue Apr 09, 2013 10:59 am
Location: France
Info

Re: Video Hotspot .webm doesn't load - but .mp4 does?

by benji33 » Wed Aug 19, 2015 9:25 am

Perhaps only an issue into the webm encoding ?
Benjamin

byarsulik likes this post.

User avatar
byarsulik
Member
 
Topic author
Posts: 71
Likes: 5 posts
Liked in: 5 posts
Joined: Wed May 20, 2015 4:05 pm
Info

Re: Video Hotspot .webm doesn't load - but .mp4 does?

by byarsulik » Wed Aug 19, 2015 2:17 pm

benji33 wrote:Perhaps only an issue into the webm encoding ?


It's definitely possible. I'll see if I can encode into webm another way, and see if I return similar results! Thanks!

User avatar
byarsulik
Member
 
Topic author
Posts: 71
Likes: 5 posts
Liked in: 5 posts
Joined: Wed May 20, 2015 4:05 pm
Info

Re: Video Hotspot .webm doesn't load - but .mp4 does?

by byarsulik » Wed Aug 19, 2015 3:15 pm

I have decided to stick with mp4 since that is what is working... I've reconfigured my output settings to get the smallest file size possible without ruining the quality. Thank you so much for your input!

User avatar
Annis
Kolor Team
 
Posts: 6062
Likes: 801 posts
Liked in: 444 posts
Joined: Mon Aug 12, 2013 12:47 pm
Location: France
Info

Re: Video Hotspot .webm doesn't load - but .mp4 does?

by Annis » Thu Sep 03, 2015 11:17 am

byarsulik wrote:(Really my issue would be solved once video hotspots can use YouTube links in upcoming versions)


In Panotour Pro 2.5 you can do so using the Web Content hotspot.

Make sure you use the embed url of the Youtube video.
For example, for this video https://www.youtube.com/watch?v=G4HcZdQgWWg the embed URL, found on the page in Share > Embed, is https://www.youtube.com/embed/G4HcZdQgWWg)

shaerembedyoutube.png

webcontenthotspot.png

webcontentintour.png


Who is online

Users browsing this forum: No registered users and 3 guests

cron