Direction buttons works locally but not online  

Share your tips and tricks here or get help with any Panotour 2.0 problem!
No bug reports (of any kind) in this forum!
User avatar
gabriel
Member
 
Posts: 93
Joined: Wed Nov 02, 2011 10:54 pm
Location: Vernouillet (78) - France

Direction buttons works locally but not online

by gabriel » Wed Apr 02, 2014 9:41 pm

yamaha_skin.xml
(68.91 KiB) Downloaded 11 times
Hi All, i have this problem with a tour: the direction buttons works well while locally, but nothing when online, but the keyboards arrows works well ... i have made my own direction buttons using the "simple" button plugin, and i change the action into the code, i think it is ok, otherwise the buttons doesn't work even locally, no ?
For example, here is the code for the button + :
Code: Select all
<layer name="button1"
         keep="true"
         url="%FIRSTXML%/graphics/button1/btn_plus__1_.png"
         align="bottom"
         x="-315"
         y="25"
         zorder="11"
         visible="false"
         
         ondown="button1ondown"
         onup="button1onup"
         
         
         handcursor="false"
         enabled="true"
         height="42"
         width="42"
         />
         
           <action name="button1ondown">
set(fov_moveforce, -1);
  </action>
 
  <action name="button1onup">
set(fov_moveforce, 0);
  </action>

  <events name="button1events"
    onTourStart="showbutton1();"
    hidetourcontrols="hidebutton1();"
    showtourcontrols="showbutton1();"
    keep="true" />
  <action name="hidebutton1">set(layer[button1].visible, false);</action>
  <action name="showbutton1">set(layer[button1].visible, true);</action>

this code is in the file_skin.xml.

An other thing, the tour show a black screen few seconds ( 10-20 sec. ) before anything. ( and especially this one, all my others begin immediately )
I f you want to see it online, it's here : http://www.gabrielacoca.fr/wp-content/uploads/2014/02/yamaha/yamaha.html

Thank you. Gabriel.

User avatar
gabriel
Member
 
Posts: 93
Joined: Wed Nov 02, 2011 10:54 pm
Location: Vernouillet (78) - France

Re: Direction buttons works locally but not online

by gabriel » Fri Apr 04, 2014 11:31 am

Gerald tell me that: the direction buttons described in yamaha_skin.xml file do not have any onclick or ondown events :
Code: Select all
<layer name="button4" keep="true" url="%FIRSTXML%/graphics/button4/btn_bas.png" align="bottom" x="-180" y="25" zorder="14" visible="false" handcursor="false" enabled="false" height="42" width="42"/>
, i make the correction, and it's work fine exempt for the "home button".
But for loading, it works well: by dé-activating the mp.3, now it loads quickly.
My actual code for the button home is :
Code: Select all
<layer name="button10"
keep="true"
url="%FIRSTXML%/graphics/button10/btn_reset.png"
align="bottom"
x="360"
y="25"
zorder="24"
visible="false"
devices="desktop"
height="42"
width="42"
ondown="lookto(get(panoview.h),get(panoview.v),get(panoview.fov),smooth(100,20,50));"
onup=""
/>

<events name="button10events"
onTourStart="showbutton10();"
hidetourcontrols="hidebutton10();"
showtourcontrols="showbutton10();"
keep="true" />
<action name="hidebutton10">set(layer[button10].visible, false);</action>
<action name="showbutton10">set(layer[button10].visible, true);</action>


and i don't even have the mouse active when on it on my tour: http://www.gabrielacoca.fr/wp-content/uploads/2014/02/yamaha/yamaha.html

But already thank you Gérald, for the direction button, for the loading, and for your rapidity ;-)


Return to Using Panotour / Panotour Pro

Who is online

Users browsing this forum: gabriel and 1 guest