Image-stitching and virtual tour solutions My account Updates
It is currently Fri Aug 01, 2014 11:36 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 13 posts ] 
Author Message
PostPosted: Tue Nov 12, 2013 8:41 pm 
Offline
Member

Joined: Wed Nov 06, 2013 5:45 am
Posts: 25
Thank you to anyone who can help. I may have lost 2 weeks of work on a pretty intense 16 room virtual tour...

I'm receiving the error message...

"FATAL: [PANORAMA BUILD]data/[PANORAMA BUILD]_skin.xml - XML parser error: element is malformed (#1090)"

...when I open my last built tour in a local browser.

I've rebuilt the tour with all the tiles, restarted, tried again and nothing changes?

If this is indeed FATAL, can I retrieve the data from the existing folders to recreate the entire tour without having to start from the VERY beginning?

Thank you,

Andy


Top
 Profile  
 
PostPosted: Tue Nov 12, 2013 8:52 pm 
Online
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13641
Location: Isleham, Cambridgeshire, UK.
AndyJ wrote:
Thank you to anyone who can help. I may have lost 2 weeks of work on a pretty intense 16 room virtual tour...

I'm receiving the error message...

"FATAL: [PANORAMA BUILD]data/[PANORAMA BUILD]_skin.xml - XML parser error: element is malformed (#1090)"

...when I open my last built tour in a local browser.

I've rebuilt the tour with all the tiles, restarted, tried again and nothing changes?

If this is indeed FATAL, can I retrieve the data from the existing folders to recreate the entire tour without having to start from the VERY beginning?

Thank you,

Andy


Which version of PTP are you using now to make this build?

Which version did you use originally to create the tour?

What plugins do you have in your workspace?

Have you made any custom edits to the XML files created by PTP?


Top
 Profile  
 
PostPosted: Tue Nov 12, 2013 9:17 pm 
Offline
Member

Joined: Wed Nov 06, 2013 5:45 am
Posts: 25
The tour was created in PTP2 and that's the only place I've opened the project. No special modified files and I'm only using the existing plugins such as the "Gallery", "Logo", etc.
the only unusual thing I'm doing is using multiple galleries so I can open individual images with all the bells and whistles that I don't see available in the other option


Top
 Profile  
 
PostPosted: Tue Nov 12, 2013 9:26 pm 
Online
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13641
Location: Isleham, Cambridgeshire, UK.
AndyJ wrote:
The tour was created in PTP2 and that's the only place I've opened the project. No special modified files and I'm only using the existing plugins such as the "Gallery", "Logo", etc.
the only unusual thing I'm doing is using multiple galleries so I can open individual images with all the bells and whistles that I don't see available in the other option


Are you using Beta 3?

If you have been working on the tour for 2 weeks then it cannot originally have been created with Beta 3?

If you are using Beta 3 then the gallery plugin has a lot of new problems in this version - expect fixes with a Beta 4 soon.


Top
 Profile  
 
PostPosted: Tue Nov 12, 2013 9:31 pm 
Offline
Member

Joined: Wed Nov 06, 2013 5:45 am
Posts: 25
The project as a whole is two weeks old. The build has been with beta 3 for a week... and only beta 3.
Any thoughts on what the error means, or are you recommending I start all over?
Beta four debuts when?


Top
 Profile  
 
PostPosted: Tue Nov 12, 2013 9:36 pm 
Online
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13641
Location: Isleham, Cambridgeshire, UK.
AndyJ wrote:
The project as a whole is two weeks old. The build has been with beta 3 for a week... and only beta 3.
Any thoughts on what the error means, or are you recommending I start all over?


I think it just means that the XML format kpano code generated by PTP cannot be processed by the krpano Panorama Viewer.

I would not recommend starting over again. If the problem is with the Gallery plugin then starting over won't help.

Quote:
Beta four debuts when?

Kolor has said 'soon' - so I would expect it this week.


Top
 Profile  
 
PostPosted: Tue Nov 12, 2013 9:59 pm 
Offline
Member

Joined: Wed Nov 06, 2013 5:45 am
Posts: 25
Can anyone else help?


Top
 Profile  
 
PostPosted: Tue Nov 12, 2013 10:02 pm 
Online
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13641
Location: Isleham, Cambridgeshire, UK.
AndyJ wrote:
Can anyone else help?


If you want to make to make the XML file mentioned in the error message available I'll take a look at it and others might too.


Top
 Profile  
 
PostPosted: Tue Nov 12, 2013 11:28 pm 
Offline
Member

Joined: Wed Nov 06, 2013 5:45 am
Posts: 25
Here's a copy and paste of the XML file and I've also attached it. I hope someone can help.

Thank you,

Andy


Attachments:
File comment: XML File
[PANORAMA BUILD]_skin.xml [140.45 KiB]
Downloaded 18 times
Top
 Profile  
 
PostPosted: Wed Nov 13, 2013 6:33 am 
Offline
Member

Joined: Wed Nov 06, 2013 5:45 am
Posts: 25
Anyone? Please?


Top
 Profile  
 
PostPosted: Wed Nov 13, 2013 11:05 am 
Offline
Member
User avatar

Joined: Tue Apr 09, 2013 10:59 am
Posts: 1934
Location: France
Hi Andy,

I've tested your XML file, thank for download.

It's a Panotour bug that I've reported.
In fact you have a string with sentence : "Freeway " Bike Car and the double quote broke the string sentence.
We have to check for this problem.

I send you the modified file without double quote or you can build again your project without the double quote (") into the string.

Thanks for report, Benjamin


Attachments:
[PANORAMA BUILD]_skin.xml [140.44 KiB]
Downloaded 13 times

_________________
Benjamin
http://www.kolor.com
Top
 Profile  
 
PostPosted: Wed Nov 13, 2013 2:59 pm 
Offline
Member

Joined: Wed Nov 06, 2013 5:45 am
Posts: 25
Thank you for the help, Benjamin. I would truly appreciate the rebuilt file, as I've put much effort into the original project. Although, I started a new build as well (with the latest November 7th PTP2 Beta 3) and received the same #1090 error). The problem seems to occur when a gallery is added to the build.
After I use the rebuilt XML file, do you believe that the problem will be fixed?
I need to submit my project by afternoon EST and I hope this fix works.

Thank you again for your help, Benjamin.

Andy


Top
 Profile  
 
PostPosted: Thu Nov 14, 2013 11:54 am 
Offline
Member
User avatar

Joined: Tue Apr 09, 2013 10:59 am
Posts: 1934
Location: France
Each build file is linked to a specific build. if you change some things into the project, builded xml files will change. So the better way is to correct string which can add the problem into the PTP interface and rebuild.
If errors happens again, you can use this link to test the bugged xml file and find le line which could have errors : http://validator.w3.org/#validate_by_upload

_________________
Benjamin
http://www.kolor.com


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 13 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group