Problème d'importation du fichier XML PapyWizard dans AutoPano Giga  

Partagez vos trucs et astuces dans ce forum ou obtenez de l'aide sur l'utilisation d'Autopano Pro / Giga.
Attention, pas de post sur les bugs ici ...
no avatar
bNj
New member
 
Posts: 5
Joined: Fri Dec 23, 2011 10:56 am

Problème d'importation du fichier XML PapyWizard dans AutoPano Giga

by bNj » Fri Dec 23, 2011 11:09 am

Bonjour,

L'importation du fichier XML généré par PapyWizard dans AutoPano me génére un rendu complètement faux. (rendu du bas)
En utilisant le mode automatique le rendu est correct (rendu du haut)
Pour info, il y'a 6 photos à  50°, 6 à  -20° et un zénith, avec un D90 + Nikkor 10.5mm Fisheye

Merci pour votre aide.

Rendu AutoPano
Image

XML PapyWizard
Code: Select all
<?xml version="1.0" encoding="utf-8"?>
<papywizard version="c">
    <header>
        <general>
            <title>
               
            </title>
            <gps>
                Entrer les coordonnées ici
            </gps>
            <comment>
                Généré par Papywizard 2.1.21
            </comment>
        </general>
        <shooting mode="preset">
            <headOrientation>
                up
            </headOrientation>
            <cameraOrientation>
                portrait
            </cameraOrientation>
            <stabilizationDelay>
                0.5
            </stabilizationDelay>
            <counter>
                039
            </counter>
            <startTime>
                2011-12-23_10h42m54s
            </startTime>
            <endTime>
                2011-12-23_10h45m38s
            </endTime>
        </shooting>
        <camera>
            <timeValue>
                0.5
            </timeValue>
            <bracketing nbPicts="1"/>
            <sensor coef="1.5" ratio="3:2"/>
        </camera>
        <lens type="fisheye">
            <focal>
                10.0
            </focal>
        </lens>
        <preset name="6@50 + 6@-20 + Z"/>
    </header>
    <shoot>
        <pict bracket="1" id="1">
            <time>
                2011-12-23_10h42m58s
            </time>
            <position pitch="50.0" roll="90.0" yaw="-0.0"/>
        </pict>
        <pict bracket="1" id="2">
            <time>
                2011-12-23_10h43m11s
            </time>
            <position pitch="50.0" roll="90.0" yaw="60.0"/>
        </pict>
        <pict bracket="1" id="3">
            <time>
                2011-12-23_10h43m23s
            </time>
            <position pitch="50.0" roll="90.0" yaw="120.0"/>
        </pict>
        <pict bracket="1" id="4">
            <time>
                2011-12-23_10h43m36s
            </time>
            <position pitch="50.0" roll="90.0" yaw="180.0"/>
        </pict>
        <pict bracket="1" id="5">
            <time>
                2011-12-23_10h43m49s
            </time>
            <position pitch="50.0" roll="90.0" yaw="240.0"/>
        </pict>
        <pict bracket="1" id="6">
            <time>
                2011-12-23_10h44m01s
            </time>
            <position pitch="50.0" roll="90.0" yaw="300.0"/>
        </pict>
        <pict bracket="1" id="7">
            <time>
                2011-12-23_10h44m15s
            </time>
            <position pitch="-20.0" roll="90.0" yaw="330.0"/>
        </pict>
        <pict bracket="1" id="8">
            <time>
                2011-12-23_10h44m28s
            </time>
            <position pitch="-20.0" roll="90.0" yaw="270.0"/>
        </pict>
        <pict bracket="1" id="9">
            <time>
                2011-12-23_10h44m40s
            </time>
            <position pitch="-20.0" roll="90.0" yaw="210.0"/>
        </pict>
        <pict bracket="1" id="10">
            <time>
                2011-12-23_10h44m52s
            </time>
            <position pitch="-20.0" roll="90.0" yaw="150.0"/>
        </pict>
        <pict bracket="1" id="11">
            <time>
                2011-12-23_10h45m05s
            </time>
            <position pitch="-20.0" roll="90.0" yaw="90.0"/>
        </pict>
        <pict bracket="1" id="12">
            <time>
                2011-12-23_10h45m18s
            </time>
            <position pitch="-20.0" roll="90.0" yaw="30.0"/>
        </pict>
        <pict bracket="1" id="13">
            <time>
                2011-12-23_10h45m38s
            </time>
            <position pitch="90.0" roll="90.0" yaw="0.0"/>
        </pict>
    </shoot>
</papywizard>

User avatar
AlexandreJ
Kolor Team
 
Posts: 5918
Joined: Mon Nov 14, 2005 4:56 pm
Location: Francin, France

by AlexandreJ » Tue Jan 03, 2012 3:38 pm

Bonjour,

Est-il possible de télécharger toutes les images et le fichier xml sur notre ftp ?
http://www.kolor.com/forum/t766-ftp-server

Alexandre

no avatar
bNj
New member
 
Posts: 5
Joined: Fri Dec 23, 2011 10:56 am

by bNj » Wed Jan 11, 2012 3:57 pm

Merci, je n'ai plus les fichiers sous la main mais je ne manquerai pas de les partager lors de mon prochain test.
Last edited by bNj on Wed Jan 11, 2012 3:58 pm, edited 1 time in total.

no avatar
bNj
New member
 
Posts: 5
Joined: Fri Dec 23, 2011 10:56 am

by bNj » Tue Jan 31, 2012 6:05 pm

AlexandreJ wrote:Bonjour,

Est-il possible de télécharger toutes les images et le fichier xml sur notre ftp ?
http://www.kolor.com/forum/t766-ftp-server

Alexandre

Bonjour Alexandre,

j'ai refait des tests aujourd'hui et je n'arrive toujours pas à  charger mes photos dans Autopano via le fichier XML de PapyWizard. Je précise que j'ai installé la dernière version d'Autopano la 2.6.2 RC1.

Image

J'ajoute les images sur le FTP avec le fichier XML.

Merci pour ton aide.

Benjamin

User avatar
AlexandreJ
Kolor Team
 
Posts: 5918
Joined: Mon Nov 14, 2005 4:56 pm
Location: Francin, France

by AlexandreJ » Wed Feb 01, 2012 9:10 am

Merci, j'ai reçu le message. Je m'en occupe.

User avatar
AlexandreJ
Kolor Team
 
Posts: 5918
Joined: Mon Nov 14, 2005 4:56 pm
Location: Francin, France

by AlexandreJ » Wed Feb 15, 2012 6:04 pm

Bilan etude :
- un bug trouvé si on combine papywizard et fisheye ( c'est pas forcement une bonne idée car ca marche déjà  direct en mode standard, papywizard n'apporte pas grand chose )
- le point nodal de cette série est plus de mal placée => donc assemblage pas très bon à  la fin.

no avatar
bNj
New member
 
Posts: 5
Joined: Fri Dec 23, 2011 10:56 am

by bNj » Wed Feb 15, 2012 10:01 pm

Merci pour ton retour.
Je me suis rendu compte aussi pour le point nodal, je suis entrain de voir pour faire la modification de la couronne en alu.
Je n'ai pas bien compris pour l'histoire du bug, je ne dois pas mettre l'objectif en fisheye dans papywizard ?

User avatar
AlexandreJ
Kolor Team
 
Posts: 5918
Joined: Mon Nov 14, 2005 4:56 pm
Location: Francin, France

by AlexandreJ » Thu Feb 16, 2012 8:54 am

En clair, passer par papywizard pour un panorama avec 7 images n'a que peut de sens, car en mode fisheye, quasiment toutes les images pourraient voir toutes les autres.
Donc que tu utilises papywizard ou pas ne change rien en temps de calcule ou précision. Le seul cas qui serait meilleur c'est si jamais tu avais une image fisheye de pur ciel bleu ( et la, c'est un vrai défi :) ).

Bref, ce cas ci, se traite super bien en mode standard aussi.

no avatar
bNj
New member
 
Posts: 5
Joined: Fri Dec 23, 2011 10:56 am

by bNj » Thu Feb 16, 2012 10:36 am

Ok merci !


Return to Utilisation d'Autopano Pro et d'Autopano Giga

Who is online

Users browsing this forum: No registered users and 1 guest

cron