Memory leak on AVP 2.3.2, Macbook Pro 10.10 (NOT SOLVED)  

This forum is dedicated to Autopano Video bug reports and features discussion.
Please read the posting rules before starting a topic!
no avatar
skeeterou
Member
 
Topic author
Posts: 11
Likes: 0 post
Liked in: 5 posts
Joined: Wed May 04, 2016 8:40 pm
Info

Memory leak on AVP 2.3.2, Macbook Pro 10.10 (NOT SOLVED)

by skeeterou » Thu May 05, 2016 4:41 am

I'm trying to render a 6 GoPro setup video (1440p 4:3 30fps, 30 minutes in length) using the latest Macbook Pro 15" with 16gb RAM in AVP 2. It crashes after about 15-20 minutes of render with AVP2 using 100% of my RAM. This is with no other programs open. I'm rendering a 1.5 minute video as I type, and I've included a screenshot of the memory usage through activity monitor as well as the error that pops up. This basically is making the program unusable. Any fix?

EDIT: When using EditReady to concatenate my videos, they got rewrapped (but not converted) as .mov files. I'm thinking this might be the issue. Will re-export as mp4 and report back.

EDIT 2: So it looks like that fixed the issue. I deleted the original project, and started from scratch. The original files were already h264, just in a .mov wrapper. I renamed the same files to use the mp4 extension, and no issues. So either the project file was corrupted, or renaming worked. Not sure which. Cheers. Hope this helps someone else with the same issue.

Edit 3: Spoke too soon. As export neared finishing, the same dreaded memory leak reared it's ugly head. Will actually export to mp4 using MPEG Streamclip, and start project from scratch. Will update.
Attachments
Screen Shot 2016-05-04 at 2.18.42 PM.png
Screen Shot 2016-05-04 at 2.07.03 PM.png
Screen Shot 2016-05-04 at 1.52.30 PM.png
Screen Shot 2016-05-04 at 1.48.58 PM.png

papazee55 likes this post.

User avatar
papazee55
New member
 
Posts: 9
Likes: 3 posts
Liked in: 0 post
Joined: Mon May 02, 2016 8:53 pm
Location: Boca Raton, FL
Info

Re: Memory leak on AVP 2.3.2, Macbook Pro 10.10 (NOT SOLVED)

by papazee55 » Thu May 05, 2016 3:27 pm

Same problem on a MAC PRO with 64GB of memory. I see the same issue in your Activity Monitor as mine. The compressed memory spiked on AVP as did mine and the kernel memory spiked as well. Once I restarted the program (force quit) I monitored my actions looking for another the spike i noticed that my AVP memory stayed at 5.5GB or so and compressed memory stayed at zero. I can't say that my videos were the problems as these were MP4's right out of the GoPro's. I have been working with these files for several days on different projects and this is the only time I have received the Out of Memory notice.
Attachments
Screen Shot 2016-05-05 at 10.00.04 AM.png
PapaZee55

MAC PRO
2.7 GHz, 12 core Xeon E5
AMD Fire Pro D700
64GB 1866 DDR3 ECC

no avatar
skeeterou
Member
 
Topic author
Posts: 11
Likes: 0 post
Liked in: 5 posts
Joined: Wed May 04, 2016 8:40 pm
Info

Re: Memory leak on AVP 2.3.2, Macbook Pro 10.10 (NOT SOLVED)

by skeeterou » Thu May 05, 2016 4:02 pm

Last night I re-exported as an mp4 using mpeg streamclip, and it worked finefine this morning. No memory leak whatsoever. It even stitched and synched at a much faster rate than usual. Might give that a try.


Who is online

Users browsing this forum: No registered users and 1 guest