AVP 2.2 RC2 not starting in Windows 10   [SOLVED] - View the solution

This forum is dedicated to Autopano Video bug reports and features discussion.
Please read the posting rules before starting a topic!
no avatar
dgdgdg
New member
 
Topic author
Posts: 8
Likes: 0 post
Liked in: 1 post
Joined: Tue Jul 21, 2015 6:15 pm
Info

AVP 2.2 RC2 not starting in Windows 10

by dgdgdg » Fri Aug 21, 2015 1:01 pm

Hi,

I tried to open AVP 2.2 RC2 in Windows 10, but it crashes everytime I try to launch it. Can you help me here?

Thanks
Daniel

polemos likes this post.

User avatar
Cliquetsy
Member
 
Posts: 1312
Likes: 106 posts
Liked in: 119 posts
Joined: Thu May 16, 2013 4:10 pm
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by Cliquetsy » Fri Aug 21, 2015 3:16 pm

Where you prompted to send in a crash report?

no avatar
dgdgdg
New member
 
Topic author
Posts: 8
Likes: 0 post
Liked in: 1 post
Joined: Tue Jul 21, 2015 6:15 pm
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by dgdgdg » Fri Aug 21, 2015 3:17 pm

Yes.

User avatar
Cliquetsy
Member
 
Posts: 1312
Likes: 106 posts
Liked in: 119 posts
Joined: Thu May 16, 2013 4:10 pm
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by Cliquetsy » Fri Aug 21, 2015 6:30 pm

Okay well that will be a start. Uhm did you install avp before upgrading to win10 or after?

no avatar
dgdgdg
New member
 
Topic author
Posts: 8
Likes: 0 post
Liked in: 1 post
Joined: Tue Jul 21, 2015 6:15 pm
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by dgdgdg » Fri Aug 21, 2015 6:32 pm

Before I upgraded. But I deleted and installed again it after it didn't work in Windows 10. After reinstalling, it still crashed.

User avatar
ThomasV
Kolor Team
 
Posts: 300
Likes: 0 post
Liked in: 1 post
Joined: Mon Aug 27, 2012 1:12 pm
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by ThomasV » Mon Aug 24, 2015 10:15 am

Hello Daniel,

I gave a look at the crash you uploaded, and something looks strange around Microsoft Visual studio redist. The version used not perfectly match the expected one.

Here is what I can suggest you.
- Download and install the initial version of the redist:
http://www.microsoft.com/en-US/download/details.aspx?id=13523
- Restart your computer.
- Launch Autopano Video Pro

If the crash persists, please upload it so that I can check which version is used.

Regards,
Thomas

User avatar
pgielen
Member
 
Posts: 158
Likes: 7 posts
Liked in: 5 posts
Joined: Wed Mar 12, 2008 11:43 pm
Location: The Netherlands
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by pgielen » Sun Sep 06, 2015 10:30 am

Has this been solved yet? I'd like to upgrade to Windows 10 but must be sure that my software will still work...

no avatar
olmy
New member
 
Posts: 4
Likes: 0 post
Liked in: 0 post
Joined: Thu Sep 10, 2015 12:07 am
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by olmy » Thu Sep 10, 2015 12:15 am

Hi All,
I've experienced the same issue.

I had AVP 2.0 installed on Win 8.1. I then upgraded to Win 10 and it continued to work.

Just downloaded and installed AVP 2.2 but it won't launch (sorry I didn't send the crash report).

Uninstalled 2.2 and tried installing again and it hung on the vcredis which is Microsoft Visual studio as Thomas mentions. I will follow Thomas's suggestion and let the forum know outcome.

Cheers,
DM

no avatar
olmy
New member
 
Posts: 4
Likes: 0 post
Liked in: 0 post
Joined: Thu Sep 10, 2015 12:07 am
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by olmy » Thu Sep 10, 2015 11:18 am

Hi,
Reinstalled Visual C++ from link but issue still persists.

Thanks,
DM

no avatar
michaelcsalmon
New member
 
Posts: 2
Likes: 0 post
Liked in: 0 post
Joined: Thu Jul 23, 2015 11:42 am
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by michaelcsalmon » Thu Sep 10, 2015 12:41 pm

Same issue here.....

User avatar
renan
Kolor Team
 
Posts: 362
Likes: 0 post
Liked in: 1 post
Joined: Mon Jan 05, 2009 1:57 pm
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by renan » Tue Sep 15, 2015 2:07 pm

We tried on all Windows 10 that we have and unfortunately we do not have reproduce this issue.
One eventuality, is to uninstall Microsoft Visual C++ redistribuable before reinstalling Autopano Video Pro.
To do that, go to "Control Panel > Programs > Programs and Features" (you have a shortcut by typing windows touch + X) and uninstall all 2010 and 2013 redistribuable.
I'm not sure that is the solution and this could be risky (you may have to reinstall other applications if some redist are missing after Autopano Video Pro reinstallation). But as we have not reproduced this crash we can't be sure how correct it...

Have you all make an update or someone has this issue with a fresh install ?

no avatar
olmy
New member
 
Posts: 4
Likes: 0 post
Liked in: 0 post
Joined: Thu Sep 10, 2015 12:07 am
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by olmy » Fri Sep 18, 2015 2:29 am

Renan are you Windows 10 installs fresh or in-place upgrades?

I may try full uninstall of all Visual C++ and then reinstall but you guys should consider investing a little more time on this. As Microsoft rolls out Windows 10 you most likely get many more of these.

If there is anything further I can do, let me know.

Thanks,
DM

User avatar
renan
Kolor Team
 
Posts: 362
Likes: 0 post
Liked in: 1 post
Joined: Mon Jan 05, 2009 1:57 pm
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by renan » Fri Sep 18, 2015 8:24 am

We tried on all Windows 10 we have (personal computers too). Some were updates, some were installed from scratch and we currently not reproduce this issue.
It' hard to fix an issue without reproduce it but we are working on it...
I'm also interested to know if Panotour 2.3 and 2.5 (even the demo versions) can be launched on your computers.

User avatar
renan
Kolor Team
 
Posts: 362
Likes: 0 post
Liked in: 1 post
Joined: Mon Jan 05, 2009 1:57 pm
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by renan » Fri Sep 18, 2015 12:55 pm

One other thing which could help, is to activate a debuging trace of our video library (the crash seems appear into this library).

For doing this:
* create a folder named mc on your main disk( C:\mc\ )
* open a console => windows touch+R and type cmd
* type the following commands into the console:
cd "C:\Program Files\Kolor\Autopano Video Pro 2.2"
Set MCTRANSCODING_DEBUG=C:\mc\log.txt
AutopanoVideoPro_x64.exe

If the file C:\mc\log.txt is created it can help us to have this file.

no avatar
polemos
New member
 
Posts: 4
Likes: 1 post
Liked in: 0 post
Joined: Mon Jun 29, 2015 5:43 pm
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by polemos » Mon Sep 21, 2015 12:32 am

I am having the same issue with windows 10 I get a straight crash I did sent a bugs report and now when I run it it doesn't crash it just runs but no window ever comes up it is just hung, should I try that reinstall the redis, like it says above did this work for anyone before I do that?

no avatar
polemos
New member
 
Posts: 4
Likes: 1 post
Liked in: 0 post
Joined: Mon Jun 29, 2015 5:43 pm
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by polemos » Mon Sep 21, 2015 12:42 am

I uploaded the log firl you guys requested please help us to resolve this issues it is a real bottleneck right now for us
Attachments
log.txt
I did what you guys wanted in the post before creating the mc folder and here is the log from that I really want to get this workling its been a while now and no response others are experiencing the same problem
(94.07 KiB) Downloaded 75 times

User avatar
renan
Kolor Team
 
Posts: 362
Likes: 0 post
Liked in: 1 post
Joined: Mon Jan 05, 2009 1:57 pm
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by renan » Mon Sep 21, 2015 8:06 am

According to your log the issue may come from an optional decoding module which allow to support DirectShow 32 bit and QuickTime formats.
So, you can try to rename the folder where this module to disable it. The module is here:
C:\Program Files\Kolor\Autopano Video Pro 2.2\MCPlugins\host32
Rename the folder host32 to host32test (for example) and launch Autopano Video again.

pablogreg likes this post.

no avatar
pablogreg
New member
 
Posts: 7
Likes: 2 posts
Liked in: 2 posts
Joined: Fri May 23, 2014 6:23 pm
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by pablogreg » Tue Sep 22, 2015 12:21 am

I have the same issue... renaming the folder launched AutoPano Video Pro 2.2
I didn't do any of the other options ...

What's the next step to solve this issue?

BTW My laptop has Both Nvidia and Intel Graphics card, and in Nvidia Control Panel Autopano Video is set to use Nvidia

no avatar
polemos
New member
 
Posts: 4
Likes: 1 post
Liked in: 0 post
Joined: Mon Jun 29, 2015 5:43 pm
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by polemos » Tue Sep 22, 2015 8:50 pm

renan wrote:According to your log the issue may come from an optional decoding module which allow to support DirectShow 32 bit and QuickTime formats.
So, you can try to rename the folder where this module to disable it. The module is here:
C:\Program Files\Kolor\Autopano Video Pro 2.2\MCPlugins\host32
Rename the folder host32 to host32test (for example) and launch Autopano Video again.



This worked for me! But am I going to run into any problems doing this?? or can I leave that folder name change?

User avatar
renan
Kolor Team
 
Posts: 362
Likes: 0 post
Liked in: 1 post
Joined: Mon Jan 05, 2009 1:57 pm
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by renan » Wed Sep 23, 2015 8:34 am

If you work with strandard video files (mp4) you will not have any issue related to this module. This allows to support DirectShow 32bit (usefull for cineform) and QuickTime formats (as ProRes).

I will try to prepare a package with an updated version of these video libraries to see if it could fix your issues.

pablogreg could you try to get a debuging trace as explain above ?

no avatar
olmy
New member
 
Posts: 4
Likes: 0 post
Liked in: 0 post
Joined: Thu Sep 10, 2015 12:07 am
Info

Re: AVP 2.2 RC2 not starting in Windows 10

by olmy » Mon Nov 09, 2015 2:44 am

Hi All,
Finally found some time to work on this. I unfortunately took the scattergun approach this time (meaning I did a whole bunch of things and not sure which one fixed the issue). But happy to say issue is now RESOLVED, at least for me.

Setup;
Windows 10 (in place upgrade, not fresh install). Had APV 2.0 installed on Win8. Upgrade to APV 2.2, all worked. Then did the in-place upgrade to Win10 and that's when 2.2 stopped working (2.0 still worked).
Gforce GTX 980 Nvidia card, lots of RAM/CPU/HDD

Process to resolve;
Uninstalled APV 2.0 and 2.2 also uninstalled APP v4
Uninstalled ALL versions of Microsoft Visual C++. in my view this most likely resolved problem.
Uninstalled PTGui and Hugin aswell (just in case, unlikely to have resolved issue but you never know)
Upgraded the drivers on my NVidia card to latest.
Downloaded Autopano Video 2.2 again (just in case)
Installed and allowed it to install its own Visual C++ Software, which coincidentally was v2013 i believe.

Launched, all working.

Hope this helps.

Cheers,
DM

User avatar
panoguy
Member
 
Posts: 106
Likes: 1 post
Liked in: 0 post
Joined: Mon Jan 25, 2010 3:55 am
Location: Bavaria
Info

Re: AVP 2.2 RC2 not starting in Windows 10  [SOLVED]

by panoguy » Sat Dec 12, 2015 12:08 pm

Till 1hour ago all was fine, I had Win 10 running with APV 2.2, APV 2.3 and Panotour Pro 2.5 without problems. I noticed there was some Windows update and after reboot all Kolor packages APV 2.2, APV 2.3 and Panotour Pro 2.5 are crashing right after start.
Btw. I have uploaded the dupms, in case someone at Kolor gets a chance to look at them, Thank You!

Seems my problem was caused by a simple problem, the disk with temp folder was full ;-) After cleaning it up, all works again ;-)


Who is online

Users browsing this forum: No registered users and 2 guests