hotspot et autres liens font planter la visite virtuelle  

Ce forum est entièrement consacré à  Panotour.
Rapport de bugs ainsi que des discussions sur les fonctionnalités.
no avatar
Maxime
Member
 
Posts: 12
Joined: Thu Oct 28, 2010 1:47 am
Location: Lyon, France

hotspot et autres liens font planter la visite virtuelle

by Maxime » Mon Dec 05, 2011 8:16 pm

Bonjour,

je viens de tester Panotour Pro V1.7.0 en 64bits sous windows 7 et si le soft fonctionne parfaitement c'est la visite virtuelle générée qui plante. Je m'explique. Au premier test, la feuille de style du texte n'était pas appliquée. Lors d'un second test, la feuille de style était appliquée. Mais le plus embêtant est que aucun hotspots et les liens de la pile de miniatures focntionnent. Elle devrait renvoyer vers d'autres panos mais rien. La visite plante. Aucune action n'est possible pas même interféré avec le pano chargé ou le menu. Seule le son continue de tourner.

Après plusieurs essais en local pour le même résultat, j'ai importé le projet (.kpt) dans Panotour Pro V1.6.1 en 64bits toujours sous windows 7 et là  tout fonctionne parfaitement.
J'imagine donc que le problème vient de la génération. ;)

Cordialement

EDIT 1: J'ai comme l'impression que le forum anglais rapporte le même genre de soucis, non?
Last edited by Maxime on Mon Dec 05, 2011 8:19 pm, edited 1 time in total.

User avatar
bdd
Kolor Team
 
Posts: 1775
Joined: Tue Jan 18, 2011 4:05 pm

by bdd » Tue Dec 06, 2011 9:14 am

Bonjour,

Votre visite contient-elle une GoogleMap ?

Si oui, pourriez vous tester sans la googlemap, et me dire si votre visite fonctionne dans ce cas ?

Si la réponse est toujours oui, je serais très intéressé par votre fichier projet (*.kpt) ainsi que par les XML générés par PanotourPro.

Cela me permettra de comprendre où le problème se passe exactement, et de tenter de le résoudre.
Cordialement,

Gérald

no avatar
Maxime
Member
 
Posts: 12
Joined: Thu Oct 28, 2010 1:47 am
Location: Lyon, France

by Maxime » Wed Dec 07, 2011 12:44 am

En effet, le projet contenait bien une googlemaps. Malheureusement, j'ai mis à  la corbeille tout le projet. C'était juste un test. Dans les jours qui viennent, je tâcherai de reproduire un projet similaire sous panotour pro 1.7.0. Et je vous tiendrai au courant d'éventuels problèmes.
Cordialement
Maxime
Last edited by Maxime on Wed Dec 07, 2011 12:44 am, edited 1 time in total.

User avatar
bdd
Kolor Team
 
Posts: 1775
Joined: Tue Jan 18, 2011 4:05 pm

by bdd » Wed Dec 07, 2011 8:33 am

Bonjour,

J'ai réussi à  reproduire le problème de blocage d'une visite avec googlemap, en ne suivant pas les prérequis d'utilisation d'une visite en local.
http://www.autopano.net/wiki-fr/Panotour_Pro_1.5_-_Pr%C3%A9requis

En local, si vous ne mettez pas vos visites dans un répertoire de confiance de Flash, nous ne garantissons pas son bon fonctionnement.
Dans le cas de la googlemap, la visite fait des requetes sur un site tierce (Google) pour obtenir de infos. Si la visite n'est pas "trusted", aucune carte ne s'affiche.

Là  ou le problème devient bloquant, c'est au changement de panorama. On essaie tout de même de centrer la carte sur le nouveau lieu, bien que la carte ne soit pas initialisée.
On n'obtient pas de réponse de Google, d'ou le blocage.

Bien que cette utilisation, hors répertoire de confiance soit (très) déconseillée, j'ai fait une modification qui sera dans la 1.7.1, pour ne pas appeler la carte au chargement d'un nouveau panorama si "on pense" que la carte n'a pas été initialisée.

Gérald

no avatar
Maxime
Member
 
Posts: 12
Joined: Thu Oct 28, 2010 1:47 am
Location: Lyon, France

by Maxime » Thu Dec 15, 2011 3:18 pm

Merci pour l'info. Ayant changé d'ordinateur il y a peu j'avais oublié de refaire cette manip' vis à  vis de flash... ;)
Je vais désormais refaire un autre essai.

Cordialement


EDIT1: Je viens de refaire un test avec panotourpro 1.7.1 et après avoir autorisé flash sur les dossiers d'export et tout fonctionne comme il faut. Merci pour vos réponses.
Last edited by Maxime on Thu Dec 15, 2011 3:55 pm, edited 1 time in total.


Return to Panotour bug et discussions 1.8

Who is online

Users browsing this forum: No registered users and 1 guest