Page 1 of 1

Son d'ambiance d'une visite en autoff au démarrage

PostPosted: Tue Oct 09, 2012 5:30 pm
by sabotage
Bonjour,

Je cherche en vain la possibilité de ne pas mettre en autoplay le mp3 accompagnant une visite virtuelle.
J'ai lu ici ou là  qu'il fallait modifier de "false" à  "true" la fonction "mute" dans l'xml mais je ne trouve pas de "mute" dans mes xml.
Je ne veux pas non plus supprimer le son d'ambiance de mes visites, je veux juste qu'il soit éteint par défaut au démarrage et activable à  la demande car sur une page contenant plusieurs Visites, tous les sons se lancent en même temps et c'est la cacophonie....
Voilà  merci de votre attention et future réponse ;)
++

Mathieu

PostPosted: Thu Oct 11, 2012 9:58 am
by bdd
Dans le fichier XML principal de chacune des visites, repérez la ligne suivante :

<plugin name="data" soundOn="true" keep="true"/>

Remplacez là  par

<plugin name="data" soundOn="false" keep="true"/>

Ensuite inversez les valeurs de l'attribut "visible" des plugins "soundON" et "soundOFF" .

PostPosted: Thu Oct 11, 2012 2:49 pm
by sabotage
Bonjour bdd,
merci pour votre réponse, j'ai mais il me semble avoir fait ce que vous m'avez demandé mais le son est toujours actif au lancement de la visite.
voici mon xml d'origine : http://sabotage.free.fr/pano/test/Bibliotheque/bibliotheque%20copie%20original.xml
et voici mon xml modifié : http://sabotage.free.fr/pano/test/Bibliotheque/bibliotheque.xml

de plus la syntaxe de la ligne que vous m'avez demandé de retrouver n'est pas exactement la même,
vous m'avez demandé de retrouver la ligne : <plugin name="data" soundOn="true" keep="true"/>
je ne l'ai pas retrouvé avec cette exacte syntaxe et ai donc agit sur : <plugin name="data" firstPanoHasBeenPlayed="false" soundOn="true" keep="true"/>

Peut-être est-ce du au fait que la visite date de plusieurs mois et qu'avec les mises à  jour que panotour à  subi depuis, la syntaxe a changé ?

Bref je n'ai pas obtenu le résultat escompté et ai donc encore un peu besoin de votre aide :/

+
Mathieu