Page 1 of 1

HTML5 viewer doesn't seem to be working for me

PostPosted: Thu May 16, 2013 5:55 pm
by ethan-kun
Hello - I am currently using the latest Pano Pro and can't seem to get the html5 viewer to work on my site. The flash player loads fine but when I disable flash in a browser (have tested in latest Firefox/Chrome) I just get an "ERROR: Adobe Flash Player 9/10 or higher needed" message.

I have saved a project with the "mobile devices tour" option selected. I've got the files uploaded and am using a build.html (that uses the same source code as the html5:auto example here, but with the name of the swf and xml files changed to what mine are named: http://krpano.com/krpano.html?xml=tours/corfu/tour.xml&html5=auto). I've confirmed that the javascript files (swfkrpano.js, krpanoiphone.license.js, krpanoiphone.js) are being loaded. I have also tried keeping the swfkrpano.js in it's default swfobject folder, and moving it up a level to the root where the swf and other js files are located to no avail.

Here is the url to my project page: http://denvercofinestrealty.com/virtual-tours/3006-s-macon-cir/build.html

Any thoughts? Thank you kindly in advance for your help.

** Also worth noting.. My build has 5 xml files but I wasn't sure how to properly reference them. I tried: xml:"build.xml, build0.xml, build1.xml, build2.xml, build3.xml" and just using one: xml:"build.xml" and it didn't make a difference with this error.

PostPosted: Thu May 16, 2013 6:08 pm
by mediavets
ethan-kun wrote:Hello - I am currently using the latest Pano Pro and can't seem to get the html5 viewer to work on my site. The flash player loads fine but when I disable flash in a browser (have tested in latest Firefox/Chrome) I just get an "ERROR: Adobe Flash Player 9/10 or higher needed" message................
Any thoughts? Thank you kindly in advance for your help.

Welcome to the forum....

Mobile-compatible output from PTP 1.8 is exclusively for Apple iDevices.

The HTML file generated by PTP 1.8, when specifying one of the HTML template options, invokes a script that detects the browser user-agent of the viewing platform.

When attemptong to view the tour via this HTML file it detects an iDevice browser user-agent it will load the HTML 5 version of the tour, othewise it will attempt to load the Flash version.

The HTML 5 version of the tour can be viewed using Safari on a PC is you set the browser-user-agent appropriately.

PTP 1.8 incorporates krpano Panorama Viewers V 1.0.8.14. You will have to model any custom HTML file on the HTML file created using one of the HTML template options when building the tour.

The example tour on which you modelled your HTML file is designed for V 1.16.x I think.

PTP 2.x - to be presented publicly for the first time at the IVRPA meeting in Iceland in mid-June - will incorporate the latest versions of the krpano Panorama Viewers which offer HTML5 support of a wider range of mobile platforms and browsers.

You cannot use code specific to the current V. 1.16.2 krpano Panorama Viewers with PTP1.8.

...........

You can export your krpano licenses from PTP 1.8 and use them with the latest versions of the krpano Panorama Viewers and tools, instead of using to PTP 1.8, to create your tours if you wish.

PostPosted: Thu May 16, 2013 7:07 pm
by ethan-kun
Thank you Sir for your response. Do you think this upgrade will be free since the software was just purchased and the update may come out soon?

PostPosted: Thu May 16, 2013 7:16 pm
by mediavets
ethan-kun wrote:Thank you Sir for your response. Do you think this upgrade will be free since the software was just purchased and the update may come out soon?

I don't work for Kolor so I have no idea of what the upgrade policy will be.

PostPosted: Thu May 16, 2013 7:19 pm
by ethan-kun
Ah yes, haha. Well thanks again. \m/

PostPosted: Thu May 23, 2013 2:17 pm
by raypayette
I bought Panotour Pro with the expectation (from the description) that it would produce HTML5 files that are compatible with mobile devices.
It simply doesn't do it. I tried with the KR pano and it doesn't do it either. In the HTMLl file the HTML5 option is "prefer" and it dfoesn't work but it the Tour editor it is "never" and it uses flash that works very well.

PostPosted: Thu May 23, 2013 2:52 pm
by klausesser
raypayette wrote:I bought Panotour Pro with the expectation (from the description) that it would produce HTML5 files that are compatible with mobile devices.
It simply doesn't do it. I tried with the KR pano and it doesn't do it either. In the HTMLl file the HTML5 option is "prefer" and it dfoesn't work but it the Tour editor it is "never" and it uses flash that works very well.

Actually mobile-devices in PTP means iPads. On iPads and iPhones panos and tours built with PTP work very well.
Not all features - but the relevant ones.

See this one on desktop and on iPad: http://360impressions.de/KBogen413/

best, Klaus

PostPosted: Thu May 23, 2013 3:16 pm
by Destiny
Hi..

Do you..:

Build your tours with mobile enabled...?
Do you add your mobile licence to your uploaded files...?
What kind of mobile device to you have...?

Are you able to provide a link to your work so we can test it...?

Destiny..


raypayette wrote:I bought Panotour Pro with the expectation (from the description) that it would produce HTML5 files that are compatible with mobile devices.
It simply doesn't do it. I tried with the KR pano and it doesn't do it either. In the HTMLl file the HTML5 option is "prefer" and it dfoesn't work but it the Tour editor it is "never" and it uses flash that works very well.

PostPosted: Thu May 23, 2013 6:47 pm
by mediavets
raypayette wrote:I bought Panotour Pro with the expectation (from the description) that it would produce HTML5 files that are compatible with mobile devices. It simply doesn't do it.

Panotour Pro (PTP) 1.8 can create HTML5 tours that are compatible with Apple iDevices, I am not aware that it has never claimed more extensive HTML5 mobile-compatibility.

I tried with the KR pano and it doesn't do it either. In the HTMLl file the HTML5 option is "prefer" and it dfoesn't work but it the Tour editor it is "never" and it uses flash that works very well.

I am confident that krpano 1.16.3 - the latest version - can produce HTML5 tours that work on many mobile devices:

http://krpano.com/docu/html5/

You can export your krpano licences from PTP and use them with the latest version of krpno Panorama Viewers and krpanotools.

PTP 1.8 incorporates krpano V. 1.0.8.14. PTP 2.x will incorporate the latest version of krpano.

PostPosted: Wed May 29, 2013 11:20 pm
by raypayette
I found the way, in Project Properties, Generation I clicked on Mobile devices tour. I works very well.

PostPosted: Sat Jul 27, 2013 11:46 pm
by itsrichphoto
have you checked that there is a folder called swfobjects and inside a .js file which is required to work in html5

krpano has an update tool where you can update the .js and swf files to the latest versions.

I have to agree, its a bit **** that things start to fall apart, just as there is a new update that can sort these things out...

Why does kolor never assist on the forum?