Image-stitching and virtual tour solutions My account Updates
It is currently Mon Sep 22, 2014 3:21 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 11 posts ] 
Author Message
 Post subject: Tooltips being cut short
PostPosted: Thu Jan 31, 2013 11:49 am 
Offline
Member

Joined: Wed Sep 26, 2012 12:46 pm
Posts: 12
I've noticed that some of my text tooltips get cut short and the last letter is either trimmed or missed off completely (particularly if the last letter is an "l")

I've attached a couple of images of what happens and wanted to find out if this was a bug anyone else was experiencing and, if so, if there was a fix. As you can see, the tooltip that ends with a "d" is fine, whereas the tooltips ending with an "l" are cut short.

I have tried adding spaces at the end of the tooltip text in PTP, but theese get removed. The only way to keep them in seems to be to add an " " to the end of the tooltip text in the XML file. The problem with this approach is that it then looks odd unless you add another space at the start of the text to center it. At this point it looks different to the other tooltips, so in order for the tooltips to all look consistent, it would require me to add an " " to the beginning and end of every tooltip. I'd then have to repeat that every time PTP re-builds the tour.

I had a look through the KRPano documentation to see if there were any textstyle attributes that might help, but I couldn't see any. There doesn't seem to be a "padding" setting for example.

Does anyone have any ideas?

Thanks.








Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 31, 2013 12:14 pm 
Offline
Member
User avatar

Joined: Tue Jun 09, 2009 1:01 pm
Posts: 3323
Location: Salzburg
the showtext statement in krpano does have the ability to insert linebreaks:
http://www.krpano.com/docu/actions/#showtext

Code:
onhover="showtext(line 1[br]line 2[br]line 3);"

Georg

_________________
pages: gigapixel.at - jedermann.at - My Equipment


Last edited by gkaefer on Thu Jan 31, 2013 12:14 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 31, 2013 12:25 pm 
Offline
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13977
Location: Isleham, Cambridgeshire, UK.
Pheliciano wrote:
I've noticed that some of my text tooltips get cut short and the last letter is either trimmed or missed off completely (particularly if the last letter is an "l")

I've attached a couple of images of what happens and wanted to find out if this was a bug anyone else was experiencing and, if so, if there was a fix. As you can see, the tooltip that ends with a "d" is fine, whereas the tooltips ending with an "l" are cut short.

I couldn't reproduce this issue.

I am using PTP V1.8 on Windows XP/32 and viewing with latest Firefox:





_________________
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 31, 2013 12:35 pm 
Offline
Member

Joined: Mon May 22, 2006 12:18 am
Posts: 7734
Location: Duesseldorf, Germany
Pheliciano wrote:
I've noticed that some of my text tooltips get cut short and the last letter is either trimmed or missed off completely (particularly if the last letter is an "l")

I've attached a couple of images of what happens and wanted to find out if this was a bug anyone else was experiencing and, if so, if there was a fix. As you can see, the tooltip that ends with a "d" is fine, whereas the tooltips ending with an "l" are cut short.

I have tried adding spaces at the end of the tooltip text in PTP, but theese get removed. The only way to keep them in seems to be to add an " " to the end of the tooltip text in the XML file. The problem with this approach is that it then looks odd unless you add another space at the start of the text to center it. At this point it looks different to the other tooltips, so in order for the tooltips to all look consistent, it would require me to add an " " to the beginning and end of every tooltip. I'd then have to repeat that every time PTP re-builds the tour.

I had a look through the KRPano documentation to see if there were any textstyle attributes that might help, but I couldn't see any. There doesn't seem to be a "padding" setting for example.

Does anyone have any ideas?

Thanks.

I assist! Even with short words [h]sometimes[/h] the last letter is cut in half. MacOSX 10.6.8 and PTP1.8

Try to type in a space after the last letter!

What´s funny: it´s not alway reproducable . . .

best, Klaus

_________________
Simplicity is the keynote of all true elegance. Coco Chanel


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 31, 2013 12:52 pm 
Offline
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13977
Location: Isleham, Cambridgeshire, UK.
gkaefer wrote:
the showtext statement in krpano does have the ability to insert linebreaks:
http://www.krpano.com/docu/actions/#showtext

Code:
onhover="showtext(line 1[br]line 2[br]line 3);"

Georg

Did you try entering the line break [br] in the tooltip text via PTP/PTP GUI?

It doesn't work because the code generated ends up as [[br]]

................

I thought I'd done this in the past but it doesn't sem to work now.







_________________
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.


Last edited by mediavets on Thu Jan 31, 2013 12:57 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 31, 2013 12:58 pm 
Offline
Member
User avatar

Joined: Tue Jun 09, 2009 1:01 pm
Posts: 3323
Location: Salzburg
;) seems to be like hunting ghosts...

I did use the exact same text using Object info and Object info (sequence).
I cant reproduce this with Win7 64 bit and using IE10 Preview and Firefox 18.0.1, Safari and Opera.

Also, If I rename my testpano to "Middle School Rooftop - Walk across this to connect to High School"
and use than %p under Tooltip I get an correct (uncut) tooltip.

Georg

_________________
pages: gigapixel.at - jedermann.at - My Equipment


Last edited by gkaefer on Thu Jan 31, 2013 12:59 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 31, 2013 1:08 pm 
Offline
Member
User avatar

Joined: Tue Jun 09, 2009 1:01 pm
Posts: 3323
Location: Salzburg
@Andrew:

no. doing this directly in ptp1.8 will result in what you described.
create the tour in ptp1.8 without any modification.
in resulting xml file go to according line of the hotspot and add the [br] code (in my case instead of the "-" character:

Code:
    <hotspot name="spot1" onclick="lookto(0,0,90);" url="virtualtourdata/graphics/spots/spot0.png" crop="0|0|65|65" frame="0" lastframe="9" frameheight="65" framewidth="65" onloaded="set(stopSequence,false);animate(spot1,0.1);" onhover="showtext(Middle School Rooftop [br] Walk across this to connect to High School);" ath="34.2627" atv="0" width="28" height="prop"/>

result on screen:

Georg



_________________
pages: gigapixel.at - jedermann.at - My Equipment


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jan 31, 2013 1:22 pm 
Offline
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13977
Location: Isleham, Cambridgeshire, UK.
gkaefer wrote:
@Andrew:

no. doing this directly in ptp1.8 will result in what you described.

Yes, but I think it may be a bug, and that Kolor intends it to be possible to enter formatting codes via the GUI, because when you enter [br] PTP seems to 'acknowledge' that this is a formatting/special code and adds a second bracket resulting in [[br]] in the tour code, but when the tour is viewed the second bracket is removed when the tooltip is displayed.

See my previous screenshots: http://www.kolor.com/forum/p111285-today-11-52-29#p111285

_________________
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.


Last edited by mediavets on Thu Jan 31, 2013 1:23 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Fri Feb 01, 2013 9:04 am 
Offline
Member

Joined: Wed Sep 26, 2012 12:46 pm
Posts: 12
@Georg & Andrew

Interesting issue that been raised about the [br] issue, but in my case I'm not trying to add a line break to the text. This clipping seems to affect tooltips regardless of length. The tooltip background should expand to the length of the tooltip anyway right?

On the [br] topic though, I have found that adding <br> to the tooltip text in the PTP GUI results in a correct line break oin the built tour. i don't know if that helps.

@Klaus

It sound like you're seeing exactly what I'm seeing. It's not a consistent occurrence and doesn't seem to be realted to tooltip length or specific text. I'm using PTP 1.8 64bit on Mac OSX 10.7.5. Since Andrew can't reproduce the issue using the same text, maybe this is a Mac only bug?


Top
 Profile  
 
 Post subject:
PostPosted: Fri Feb 01, 2013 10:56 am 
Offline
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13977
Location: Isleham, Cambridgeshire, UK.
Pheliciano wrote:
On the [br] topic though, I have found that adding <br> to the tooltip text in the PTP GUI results in a correct line break oin the built tour. i don't know if that helps.

Thanks - I knew it was possible and that I had done it in the past. I'd forgotten how and it doesn't apoper in the onlien documentation.

_________________
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.


Top
 Profile  
 
 Post subject:
PostPosted: Fri Feb 01, 2013 10:59 am 
Offline
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13977
Location: Isleham, Cambridgeshire, UK.
Pheliciano wrote:
@Georg & Andrew

Interesting issue that been raised about the [br] issue, but in my case I'm not trying to add a line break to the text. This clipping seems to affect tooltips regardless of length. The tooltip background should expand to the length of the tooltip anyway right?

Yes, it should.

As a workaround perraphs add ... before and after the tooltip text that way it will stilll look OK-ish even if clipped.

Quote:
It sound like you're seeing exactly what I'm seeing. It's not a consistent occurrence and doesn't seem to be realted to tooltip length or specific text. I'm using PTP 1.8 64bit on Mac OSX 10.7.5. Since Andrew can't reproduce the issue using the same text, maybe this is a Mac only bug?

Perhaps it is, but hard to see why that should be.

_________________
Andrew Stephens
Many different Nodal Ninja and Agnos pano heads. Merlin/Panogear mount with Papywizard on Nokia Internet tablets.
Nikon D5100 and D40, Sigma 8mm f3.5 FE, Nikon 10.5mm FE, 35mm, 50mm, 18-55mm, 70-210mm. Promote control.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 11 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group