Image-stitching and virtual tour solutions My account Updates
It is currently Tue Sep 02, 2014 3:02 pm

All times are UTC + 1 hour




Post new topic Reply to topic  [ 6 posts ] 
Author Message
PostPosted: Sat Nov 24, 2012 9:02 pm 
Offline
New member

Joined: Sat Nov 24, 2012 8:45 pm
Posts: 4
Hi,

I am new in PTP use. In my first project I added panotour map. It worked fine and google map opened instantly in Hotspot Editor. I added two hotspots on the map to mark locations of panoramas. Then I entered an API key to be able to see the google map and saved the project. After saving the project program crashed when I tried to click on the map - the Loading map progress bar stoped at 50 % and program stopped to respond. I restarted computer and program still crahed when I click on Panotour Map, sometimes progress bar stops at 50%, sometimes no progress bar is displayed. I reinstalled PTP but problem is the same. Can anyone help me to solve this problem?

Thanks
zm


Top
 Profile  
 
 Post subject:
PostPosted: Sat Nov 24, 2012 10:41 pm 
Offline
Member
User avatar

Joined: Tue Jun 09, 2009 1:01 pm
Posts: 3322
Location: Salzburg
welcome to forum...

the API key you did use... which version is it?
panotour 1.8 only accepts google flash api v2 and is since several months no longer available to aquire from Google.
the html5 based v3 API from google will be available with panotour 2.0 which is coming (hopefully January 2013)...

Liebe Gruesse,
Georg

_________________
pages: gigapixel.at - jedermann.at - My Equipment


Top
 Profile  
 
 Post subject:
PostPosted: Sun Nov 25, 2012 9:07 am 
Offline
New member

Joined: Sat Nov 24, 2012 8:45 pm
Posts: 4
Thank you Georg for response.

I put v3 API key there. But today I found old API key and I put it to a new project. Before touching a map I saved the project, however the behavior of PTP is the same. It crashed when I clicked on the map and it is not responding any more.

Can it be related to communication with Adobe Flash? I use Windows 7 64-bit system and Flash version is 11.4.402.287
Are there any logs I could look at to see what is the problem?

What I can do to make PTP usable on my computer again?

Thanks,
zm


Top
 Profile  
 
 Post subject:
PostPosted: Sun Nov 25, 2012 11:34 am 
Offline
New member

Joined: Sat Nov 24, 2012 8:45 pm
Posts: 4
Hi,

I uninstalled PTP 1.8 and updated Adobe Flash. Next I cleaned registry and I installed again PTP but this time 32-bit version (I have Win 7 64-bit OS). I run PTP and this time it worked. I created very simple project with one pano and OSM map. It is uploaded to:
http://iga.vot.pl/virtualtour_blok.swf
I closed PTP. When I opened the project again to start improving it the problem occured again: Loading map stops at 50% like on the image below and program is not responding. It seems that progress of loading of the map stucks at 50% due to some display issues.

Any help will be appreciated.

Thanks,
zm

Image


Top
 Profile  
 
 Post subject:
PostPosted: Sun Nov 25, 2012 12:43 pm 
Offline
Member
User avatar

Joined: Tue Jun 09, 2009 1:01 pm
Posts: 3322
Location: Salzburg
if you've a 64bit OS, I never would use the 32bit ptp...
you write you found a v2API key for Google maps... but you than say you tested it with OSM...

in ptp 1.8 hotspot editor google maps is always displayed and it makes no difference which map provider you selected on project properties tab under panotour maps.

so on my test it stays about a fraction of a second at the same 50% level before going to 100% and displaying google maps.

I do not believe its ptpt installation nore Flash...
can you check your firewall... maybe this internet access to google is not allowed. start ptp with admin rights to check the same from another point of view...

Georg

_________________
pages: gigapixel.at - jedermann.at - My Equipment


Last edited by gkaefer on Sun Nov 25, 2012 12:43 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Mon Nov 26, 2012 12:16 am 
Offline
New member

Joined: Sat Nov 24, 2012 8:45 pm
Posts: 4
It crashes both 32 and 64-bits versions. It works fine only after reinstalation. When I open ptp second time Panotour map stucks on 50 %. What can be wrong? Configuration of my system? Which settings shall I check? Google Maps works fine in all browsers on my computer. I have not any problem with display of Flash.

I am wondering what stops loading map at 50%. And why it does not crash on freshly installed software?

Georg -, I checked it on Admin account and my firewall does not stop any traffic with google.

zm


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 6 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group