Image-stitching and virtual tour solutions My account Updates
It is currently Thu Oct 23, 2014 7:00 pm

All times are UTC + 1 hour

Post new topic Reply to topic  [ 1 post ] 
Author Message
PostPosted: Thu Jul 19, 2012 10:11 am 

Joined: Mon Nov 28, 2011 12:51 pm
Posts: 61
I had a strange issue with a tour that was working perfectly in normal browsers but was throwing a string of errors if I tried to access it via any iOS device.

The first error was
WARNING: tween type " not found - using 'easeOutQuad' instead!
followed by
ERROR: hotspot[logo0] loading error: virtualtourdata/graphics/logo0.png
and then the tween error just kept repeating itself a lot.


Directly accessing the logo0.png in the iOS safari browser worked so it's not that the file is missing or a permissions error. Then I loaded the png on my desktop and noticed that it's a huge png in terms of pixels (small kb) but it was 2638x2350 pixels so I reduced it to something more sensible and uploaded it to replace the large one and now the tour works without throwing any errors on my iOS devices.

Obviously I shouldn't have had the nadir png so big in the first place but as it is resized I didn't notice on a desktop browser. The HTML krpano doesn't seem to like nadir logos being larger than the tile sizes generated for iOS devices, and quit rightly so, but I would have thought it would catch the error in a nicer manner and perhaps just hide the nadir logo rather than throw errors like this?

Test System Spec: 15" Retina MacBook Pro, 2.7GHz i7, 16GB RAM, 768GB SSD, OS X 10.8.5

Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC + 1 hour

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group