Image-stitching and virtual tour solutions My account Updates
It is currently Sat Aug 23, 2014 6:36 am

All times are UTC + 1 hour




Post new topic Reply to topic  [ 8 posts ] 
Author Message
PostPosted: Tue Jun 26, 2012 2:35 pm 
Offline
New member

Joined: Tue Jun 26, 2012 1:17 pm
Posts: 9
Hello people

i have two question reagarding hotspots which i need help with. i hope u guys can help me out

question one:
when i creat a hotspot and go to hotspot properties i set the hotspot to url, type in any url, f.a http://www.google.nl, i rebuild my pano, en when i view the pano, i see the hotspot but when i click it it doenst open the url. it also doesnt matter if i set it to _blank, parent or self, nothing seems to work. It doesnt work in any browser. Anyone have a solution for this ?

second question
second question is regarding javascript.
in virtualtour.html i put a function, say:

function test() { alert("test"); }, and i put test() in the javascript line in the software, why doesnt this work ?

thnx alot for helping out.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jun 26, 2012 2:39 pm 
Online
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13784
Location: Isleham, Cambridgeshire, UK.
willem wrote:
when i create a hotspot and go to hotspot properties i set the hotspot to url, type in any url, f.a http://www.google.nl, i rebuild my pano, en when i view the pano, i see the hotspot but when i click it it doenst open the url. it also doesnt matter if i set it to _blank, parent or self, nothing seems to work. It doesnt work in any browser. Anyone have a solution for this ?

Is this with local (offline) playback or viewing online?

If local, have you set Flash security settings appropriately?:
http://krpano.com/docu/localusage/

_________________
Andrew Stephens
Nikon D40, Nikkor 10.5mm fisheye, Sigma 8mm f3.5 fisheye, Nikkor 18-55/50/35mm lenses, Nodal Ninja 5 Lite, Nodal Ninja 4 with R-D16, Agno's MrotatorTCS short.
Nikon P5100, CP5000, CP995, FC-E8, WC-E63,WC-E68, TC-E2, Kaidan Kiwi 995, Bophoto pano bracket, Agno's MrotatorA.
Merlin/Orion robotic pano head + Papywizard on Nokia 770/N800/N810 and Windows 8/XP/2K.


Last edited by mediavets on Tue Jun 26, 2012 2:39 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject:
PostPosted: Tue Jun 26, 2012 2:40 pm 
Offline
Member

Joined: Mon May 22, 2006 12:18 am
Posts: 7678
Location: Duesseldorf, Germany
willem wrote:
when i creat a hotspot and go to hotspot properties i set the hotspot to url, type in any url, f.a http://www.google.nl, i rebuild my pano, en when i view the pano, i see the hotspot but when i click it it doenst open the url. it also doesnt matter if i set it to _blank, parent or self, nothing seems to work. It doesnt work in any browser. Anyone have a solution for this ?

Put it online - and it works . . Doesn´t work locally.

best, Klaus

_________________
Simplicity is the keynote of all true elegance. Coco Chanel


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jun 26, 2012 2:50 pm 
Online
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13784
Location: Isleham, Cambridgeshire, UK.
klausesser wrote:
. . Doesn´t work locally.

best, Klaus

It will with appropriate Flash security settings.

_________________
Andrew Stephens
Nikon D40, Nikkor 10.5mm fisheye, Sigma 8mm f3.5 fisheye, Nikkor 18-55/50/35mm lenses, Nodal Ninja 5 Lite, Nodal Ninja 4 with R-D16, Agno's MrotatorTCS short.
Nikon P5100, CP5000, CP995, FC-E8, WC-E63,WC-E68, TC-E2, Kaidan Kiwi 995, Bophoto pano bracket, Agno's MrotatorA.
Merlin/Orion robotic pano head + Papywizard on Nokia 770/N800/N810 and Windows 8/XP/2K.


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jun 26, 2012 3:05 pm 
Offline
New member

Joined: Tue Jun 26, 2012 1:17 pm
Posts: 9
okay question 1 (embarressed) works thnx guys !

anyone have a solution for my second problem ?


Top
 Profile  
 
 Post subject:
PostPosted: Tue Jun 26, 2012 4:09 pm 
Online
Member

Joined: Wed Nov 14, 2007 2:12 pm
Posts: 13784
Location: Isleham, Cambridgeshire, UK.
willem wrote:
anyone have a solution for my second problem ?

I don't know whether your javascipt syntax is OK nor whether javascript will work locally but I do know that you must enter at least one domain - see screenshot - for javascript to work.



_________________
Andrew Stephens
Nikon D40, Nikkor 10.5mm fisheye, Sigma 8mm f3.5 fisheye, Nikkor 18-55/50/35mm lenses, Nodal Ninja 5 Lite, Nodal Ninja 4 with R-D16, Agno's MrotatorTCS short.
Nikon P5100, CP5000, CP995, FC-E8, WC-E63,WC-E68, TC-E2, Kaidan Kiwi 995, Bophoto pano bracket, Agno's MrotatorA.
Merlin/Orion robotic pano head + Papywizard on Nokia 770/N800/N810 and Windows 8/XP/2K.


Top
 Profile  
 
 Post subject:
PostPosted: Wed Jun 27, 2012 12:37 pm 
Offline
New member

Joined: Tue Jun 26, 2012 1:17 pm
Posts: 9
problem fixed, thnx for the help

topic can be closed :)


Top
 Profile  
 
 Post subject:
PostPosted: Thu Jul 12, 2012 3:25 am 
Offline
Member

Joined: Wed Jun 13, 2012 6:32 pm
Posts: 18
I'm not sure if this is the a similar issue.

I create a vt.... And Place a hotspot.

Many times, I can see the hotspot but the hotspot is not clickable. No tooltip appears on the hotspot.

If I drag the Pano around a little... Then place the cursor over the hotspot... A tooltip appears and the hotspot becomes clickable.

Any ideas ?

_________________
Revolutiion Photography, AP Freelance Photographer
Nikon D3, D3x : Nikkor 16mm f/2.8, 14-24mm f/2.8, 24-70mm f/2.8, 70-200mm VR2 f/2.8, 105mm f/2 DC, 50mm G f/1.4, Nodal Ninja M1-L Ultimate / RD16, Win 7 16GB + Dual 24" Monitors, MacPro 16GB + Dual 36" Cinema Monitors, MacBook Pro 17" 8GB, MacBook Pro 15" 8GB, MacBook Pro 13 4GB, iPad 64GB 3G+Wifi, iPad II 64GB 3G+Wifi


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 8 posts ] 

All times are UTC + 1 hour


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group